cancel
Showing results for 
Search instead for 
Did you mean: 

Strange problem with speed readouts

jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

Strange problem with speed readouts

Hi, I have for some months now had a strange what I thought was a fault with readouts when doing a speed test, I have used many sites and get the same results, I get the same results with the BT speed tester.
Plusnet have checked my line and everything was OK, I've tried another router and so on and so on, just by accident I tried using Internet Explorer which for years now I have not used, I prefer Firefox, I found when doing speed test using I.E results are what I expected, go back to Firefox and they are all over the place.
BT test using Firefox  Ping 43 / Download 13.4mbps / upload 1.02 mbps The download speed is is usually less than the one stated here.
BT Test Using I.E. Ping 31.25 / Download 20.23mbps/ Upload 1.02mbps
I've checked and double checked and similar results are reached, I disabled all but essential items in the Plugins and Extensions.
I know I have no fault as such but was wondering if anyone had come across this strange behavior before, I would like to know what is wrong if possible or if some one has any ideas i could try.
regards
Jono
9 REPLIES
Community Veteran
Posts: 1,233
Thanks: 19
Fixes: 2
Registered: 22-06-2012

Re: Strange problem with speed readouts

Strange. I've just run similar checks & my up & down speeds are identical although my FF ping is 50% of that from IE.
Plusnet Help Team
Plusnet Help Team
Posts: 12,995
Thanks: 142
Fixes: 46
Registered: 27-04-2007

Re: Strange problem with speed readouts

That's quite unusual I seem to get identical/very similar results whether using IE or FF or Chrome!
I've had a skim through the FAQ pages and there's nothing to state that any particular browser should be used.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
Community Veteran
Posts: 6,313
Thanks: 86
Fixes: 3
Registered: 08-01-2008

Re: Strange problem with speed readouts

Some antivirus and/or firewall programs can 'distort' the speedtest readings though I don't know if they'd affect different browsers differently.
I had a problem recently where my 2.2GHz laptop would start running at 400MHz (and 'stick' at the reduced speed), that gave me some pretty poor speedtest readings.
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

Re: Strange problem with speed readouts

Hi, Thanks for the replies, I have just downloaded and used Google Chrome to see if it does the same as Firefox, it doesn't, Speed test is ok so I can't understand it. If I ever fathom it out I'll post back with results just in case someone has a similar problem.
regards
jono
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: Strange problem with speed readouts

It might be worth trying to uninstall Firefox and then reinstall it.
jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

Re: Strange problem with speed readouts

Hi Chrispurvey, I had a few spare minutes and removed all traces of Firefox, I think. I reinstalled and ran the test using Firefox with the same results, On your speed test site started at about 8mb then half way through jumped to 19mb, same with bt , I achieved 10.74 mbps down 1.02 up and a ping of 41.
I will work my way through Firefox at a later date when I have more time, nothing wrong with the system, its just niggling at me to find what is wrong with Firefox, I.E and Chrome work fine, I get normal results with them.
Thanks for your time, if I ever do find out I will let you know.
regards
jono
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: Strange problem with speed readouts

Have you tried it on any other devices?
Please let us know how you go on,
jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

Re: Strange problem with speed readouts

Hi, I have tried Firefox  on another partition running Windows 7 Pro with same results, I'm running windows 8 pro on my other partition, the one I use the most.
I started Firefox in safe mode which did not make any difference, I'm stumped again, I will keep picking at it until I find the problem, hopefully find the problem that is.
regards
Jono
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

Re: Strange problem with speed readouts

Depends which version you're using (there's the usual one and then also one that offers extra detail I believe) - the usual one is Flash, the more advanced one Java. Perhaps the Firefox plugins of those work differently than they do on other browsers?