cancel
Showing results for 
Search instead for 
Did you mean: 

Speed tests pass but download speed is awful

magicaltrout
Newbie
Posts: 2
Registered: ‎19-08-2014

Speed tests pass but download speed is awful

Hi guys
I have recently switched from BT to Plusnet business, which Im now wondering if it was a sane idea, but thats life. Anyway the kit and the line are the same as far as I know so I wouldn't imagine it to completely sink.
I have run BT speed tests, speedtest.net speed tests they all report 1.5-2.5 mb/s downloads and I'm sync'd around 4.5mb/s so I'll cope with that.
But my HTTP downloads never get close to my old speeds usually settling around 35kb/s currently. Anyone got any idea how to diagnose potential problems here? If I'm getting 1.5mb/s down on the speed tests I wouldn't expect my generic downloads to suck quite so badly unless the pipes were getting opened for the speed tests and  I was getting shaped or something.
Oh and I tried the same downloads I have tried here on a server elsewhere and I got 10mb/s so its not the source, although I appreciate server proximity & location do have an effect its not that much!
Thanks
Tom
3 REPLIES
magicaltrout
Newbie
Posts: 2
Registered: ‎19-08-2014

Re: Speed tests pass but download speed is awful

Rebooted the router and the speeds jumped to 300kb/s which is odd but I'll cope with, still don't really understand why there was such a large differential between downloads and the speed testers. Although the day i actually get 3.5mb/s downloads like the speed testers suggest I will fall off my chair.
Community Veteran
Posts: 3,404
Thanks: 10
Registered: ‎18-01-2013

Re: Speed tests pass but download speed is awful

Hi Tom - are you doing this via a wired or wireless connection (not that it would make a huge difference at lower speeds) ?
Acassim
Grafter
Posts: 1,075
Thanks: 1
Registered: ‎11-06-2007

Re: Speed tests pass but download speed is awful

Hi Tom,
Sorry to hear that you're seeing issues with the speed, I can confirm that the profile on our side matches BT at 3500 / 3.5mbps so nothing seems suspect there. Would it be possible for you to post us the results of the BT speed test along with the 'Further Diagnostics' test at the bottom of the page as well and we can take a look at what you're seeing.