cancel
Showing results for 
Search instead for 
Did you mean: 

Speed drop problem

oldboke
Dabbler
Posts: 21
Registered: ‎12-01-2013

Speed drop problem

Hi I am hoping that someone may be able to help me.
I have had FTTC broadband for about 6 months.
I was originally told my line could take speeds around 68 Mbps, after some initial problems, my speed settled down to about 65Mbps, which was great.
Now it seems to have dropped to between 25Mbps and 35 Mbps, about half of what it was.
Even the BT speed test shows my line capable of a Max speed of 69.47 Mbps
Nothing has changed my end, no new equipment etc.
Can anyone explain why the speed has dropped so much?
I have attached a couple of speed test results.
Thanks
4 REPLIES
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: ‎13-07-2012

Re: Speed drop problem

Hi there,
I've checked over your connection and it looks fine, your sync speed is currant at 71.8Mb/s.
Try a wired connection if you already haven't, if there's no difference then I'd suggest trying a PPPoE connection which will help rule the router out as the cause.
oldboke
Dabbler
Posts: 21
Registered: ‎12-01-2013

Re: Speed drop problem

Hi thanks for the reply.
It is a wired connection, and Ive tried 2 different routers, same result !!
I use a Mac, but looked at the PPPoE link that you suggest and it give info for a Mac.
I won't be able to try this for a couple of days, but I"ll let you know when I do.
Thanks for the help
oldboke
Dabbler
Posts: 21
Registered: ‎12-01-2013

Re: Speed drop problem

Hi Chris,
I did as you suggested and connected direct without the router on a PPPoE connection.
My speed is 65Mbps.
I then carried out a factory reset on the router, before reconnecting, now my speed is showing as 65 Mbps using the router.
Thanks for your help
Regards
Smiley
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: ‎13-07-2012

Re: Speed drop problem

Great to hear! Smiley