cancel
Showing results for 
Search instead for 
Did you mean: 

Specific website access issue

megawifi500
Newbie
Posts: 2
Registered: ‎30-06-2021

Specific website access issue

Hi there

Firstly, I know there have been a fair few similar topics on this forum, but looking at the solutions posed, they all seemed quite specific to the setup and website in question, so I thought it best to start a new one.

I'm having difficulty connecting to https://player.bfi.org.uk/ which has persisted for a few months now. I don't believe it ever worked properly, but previously I had a workaround where I could go to the page and get an error message first time, leave the tab open for an hour or two and return to it somehow working properly. Just recently this stopped working - I can't reach the site at all.

The error I get each time is an 'ERR_SSL_VERSION_OR_CIPHER_MISMATCH'. I generally use Chrome, but Edge, Firefox and Internet Explorer all give the same one.

My computer is a HP laptop running an up-to-date Windows 10, and I checked that all the browsers are up-to-date too - interestingly, the issue seems to be localised to my laptop only, on my home network only - it loads fine on my laptop when connected to other wifi networks, and another computer on the same home network as me can access it also with no issues.

Any help is appreciated - I'm no expert so I may need talking through anything more complex.

Cheers all

3 REPLIES 3
Townman
Superuser
Superuser
Posts: 23,289
Thanks: 9,779
Fixes: 162
Registered: ‎22-08-2007

Re: Specific website access issue

Hello,

A warm welcome to the forums.

Your description points to something quite odd in that the issue occurs only with one device when connected to to the home network.  A different device on the home network, or the same device on a different network does not exhibit the problem.  The problem is seen only on this website.

You are going to need to try to eliminate potential contributors here.  Is the laptop in question connecting over WiFi?  If yes, have you tried this site with the laptop connected via an ethernet cable, with WiFi turned off?

Which router are you using?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

megawifi500
Newbie
Posts: 2
Registered: ‎30-06-2021

Re: Specific website access issue

 

Thanks for your response.

It is normally connected over wifi, so I gave it a try with an ethernet cable too, but unfortunately it gave the same result.

The router is a Plusnet Hub One.

Townman
Superuser
Superuser
Posts: 23,289
Thanks: 9,779
Fixes: 162
Registered: ‎22-08-2007

Re: Specific website access issue

Try this https://answers.microsoft.com/en-us/microsoftedge/forum/all/errsslversionorciphermismatch-error-mess...

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.