cancel
Showing results for 
Search instead for 
Did you mean: 

Slow loading with normal speed

Scribe
Grafter
Posts: 43
Thanks: 1
Registered: ‎05-02-2011

Slow loading with normal speed

Since the 26th February I've been getting very slow, or no loading of what seems to be data intensive sites. Using the Met Office map page as a benchmark http://www.metoffice.gov.uk/public/weather/forecast/#?tab=map&fcTime=1363910400&map=CloudAndRain&zoo... , it won't load at all using Explorer, it's painfully slow with Opera and pretty sluggish using Firefox.

At first I thought it might be the site itself, but now I'm beginning to think not, because as an example, speedtest.net is taking around 50 secs to load with IE / Opera.
My speed and ping are normal at around 8-9 Megs / 30-40ms.
It's exactly the same with different PC's, and I haven't changed anything.
It looks as if a site loads at normal speed up to a certain point, and then gets stuck! - Maybe that will mean something to someone more versed in the technicalities than I am.
It's interesting, if rather irritating, Angry  that a friend 2-3 miles away, who has recently switched to PN on my recommendation, is having no problem at all, even with Explorer!
18 REPLIES
PeeGee
Aspiring Pro
Posts: 1,104
Thanks: 55
Fixes: 3
Registered: ‎05-04-2009

Re: Slow loading with normal speed

Are you running out of "temporary" storage? Have you checked if your machine is "bloated" with temporary files/Windows update data (for those updates you did 4 years ago Shocked ) ..... ? If you can put up with the hassle, you could check/delete your surfing history etc. and see if that has an effect.
I'm not up-to-date with MS Windows tools, so leave that for someone else  Wink
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link Archer VR600 modem-router.
Highlighted
Scribe
Grafter
Posts: 43
Thanks: 1
Registered: ‎05-02-2011

Re: Slow loading with normal speed

Hi Pee Gee.Thanks for the idea, but have already tried that - have defragmented, run disk cleanup, cleared cache / cookies / history. But it's the same on two PC's and tablet, so don't see how it can be me, and anyway it happened very suddenly, as if someone somewhere threw a switch - I know 'cos I check the Met Office site every day!
Community Veteran
Posts: 6,824
Thanks: 1
Registered: ‎27-10-2012

Re: Slow loading with normal speed

Which router are you using?
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Slow loading with normal speed

Hmm, there's the odd drop but nothing that looks out of the ordinary and it looks like your speed profiles are fine so I doubt that's causing it either. Wondering which element it's stalling on loading though, if anything in particular is noticeable?
PeeGee
Aspiring Pro
Posts: 1,104
Thanks: 55
Fixes: 3
Registered: ‎05-04-2009

Re: Slow loading with normal speed

Does the timing coincide with a Flash/Java update? From what you have said, it looks as if some page element is "timing out" or failing to load successfully. I have had problems in the past where "network http pipelining" in Firefox caused page loading problems with my bank website. I now have it set to false and have had no further problems. If you have any add-ons for your browsers, what happens if you run with them disabled?
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link Archer VR600 modem-router.
Bright
Grafter
Posts: 363
Registered: ‎02-02-2013

Re: Slow loading with normal speed

Quote from: Scribe
speedtest.net is taking around 50 secs to load with IE / Opera.

But not with Firefox?Huh
Scribe
Grafter
Posts: 43
Thanks: 1
Registered: ‎05-02-2011

Re: Slow loading with normal speed

Hi guys.
AndyH, I'm using the TG 585.
Matt, I've just tried the Met Office using Opera and its okay up to element 18, then goes up to 67 much more slowly, after that it's snails pace.
PeeGee, I don't have Java or add-ons, and TBH there are so many Adobe updates I couldn't say for sure if it coincides with any, but never had any problems before.
Bright, I've just tried speedtest.net with Firefox and it took 45 secs to fully load.
Bright
Grafter
Posts: 363
Registered: ‎02-02-2013

Re: Slow loading with normal speed

@Scribe
So once the speedtest.net Flash programme has loaded (after 45-50 seconds), it then runs the speed test OK and produces a result of 8-9Mbps and a ping of 30-40ms? And exactly the same happens on 2 different (Windows?) PCs connected (by ethernet?) to the same router? (just want to be clear we're not missing anything).
Do you get (roughly) the same performance figures from the BTW speed tester?
Are the 2 PCs running the same anti-virus programme?. Does disabling the AV make any difference?  (I think you might have gone round that loop in a previous thread...)
What happens if you go to a web page that is simple to load (eg Google home page)? Does it load quickly? How about a Google search results page? Is there some kind of pattern in which sorts of pages load OK and which get bogged down?
Community Veteran
Posts: 6,824
Thanks: 1
Registered: ‎27-10-2012

Re: Slow loading with normal speed

The thing I don't get is Scribe said it's
Quote
the same on two PC's and tablet
.
Just to be clear - sites like speedtest.net run equally slow on all machines/devices?
Bright
Grafter
Posts: 363
Registered: ‎02-02-2013

Re: Slow loading with normal speed

Indeed, yet the symptoms sound like a device problem, rather than a network problem.
That Met Office page is using HTML5 scalable vector graphics, so there's a lot of data to load and a lot of processing to actually draw the page. And once it's drawn, the results are pretty depressing for the first day of Spring!  Cheesy
@Scribe
Just wondering if one of your PCs is a laptop and you could take it to your friend's house and see if the problem is the same there or goes away (that would work with the tablet, I guess)?
Scribe
Grafter
Posts: 43
Thanks: 1
Registered: ‎05-02-2011

Re: Slow loading with normal speed

Yes the speedtest.net site takes roughly the same time to load, and gives the same speed result on two Windows PC's. BTW tester gives about the same speed results as well. I'm using wifi, and PC's are less than 3 feet from the router. Both are using Avast, but tried turning that off, so not that.
Google search loads okay, as do many other pages - Plusnet, Tesco, Ebay are okay. It seems to be ones with a lot of data.
I definitely used to be able to load the Met Office site on my Android tablet as well - it wasn't fast, but it was okay, - so to my way of thinking, that rules out my PC's.
This might be significant however - at the time I didn't attach any importance to it, thinking it was just PN or BT maintenance. But on what I think might well have been the same day that this started, the router 'internet' light went out for 20-30 secs, then came back up again for the same time, then went out again - like a very slow blinking. This went on for, I would think about 10 mins. After that all the lights were on as usual. I've never seen anything like that before or since. My money's on the problem being something to do with that.
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Slow loading with normal speed

Well, there's only one drop showing for that date - though it looks like you're turning the router off overnight, or at least were doing? If so probably best to disconnect via the router's interface before turning it off in future (though if that's only happening once per day it's nothing to worry about - just good practice).
<img src="http://ccgi.psmith12.plus.com/visradius/generated/image13638606669367.png"/>
Not sure there's anything there that would indicate a fault though :/
Scribe
Grafter
Posts: 43
Thanks: 1
Registered: ‎05-02-2011

Re: Slow loading with normal speed

Thanks Matt. Yes I usually turn the router off at night  - I tried leaving it on all the time ages ago, and it didn't seem to make any difference.
Curiously though, I don't usually look at newspapers online, but thought I would read about the budget Roll eyes, and the Telegraph, Guardian and Mail, all loaded without any problem even using Explorer, and they seem to be pretty big sites. I don't get it!
Community Veteran
Posts: 5,183
Thanks: 486
Fixes: 21
Registered: ‎10-06-2010

Re: Slow loading with normal speed

Which DNS servers do you use? If you don't use Plusnet's, you can end up with different, further away akamai IP addresses:
e.g. Plusnet DNS gives 23.62.53.66 and 23.62.53.73 for www.metoffice.gov.uk
[tt]traceroute to 23.62.53.66 (23.62.53.66), 30 hops max, 60 byte packets
1  192.168.0.1 (192.168.0.1)  3.347 ms  3.521 ms  3.970 ms
2  lo0-central10.pcl-ag03.plus.net (195.166.128.184)  159.314 ms  163.674 ms  168.696 ms
3  link9-central10.pcl-gw01.plus.net (84.93.249.80)  25.554 ms  29.262 ms  29.720 ms
4  xe-1-2-0.pcl-cr01.plus.net (212.159.1.4)  30.328 ms  33.912 ms  34.338 ms
5  ae2.pcl-cr02.plus.net (195.166.129.7)  35.050 ms  40.319 ms  43.724 ms
6  ae1.ptw-cr02.plus.net (195.166.129.2)  93.484 ms  90.089 ms  90.470 ms
7  * * *
8  a23-62-53-66.deploy.akamaitechnologies.com (23.62.53.66)  20.263 ms  23.799 ms  20.437 ms[/tt]
Google DNS gives 80.239.148.145 and 80.239.148.179 or 80.239.205.65 and 80.239.205.56 for www.metoffice.gov.uk which give longer routes:
[tt]traceroute to 80.239.205.65 (80.239.205.65), 30 hops max, 60 byte packets
1  192.168.0.1 (192.168.0.1)  2.185 ms  3.746 ms  4.419 ms
2  lo0-central10.pcl-ag03.plus.net (195.166.128.184)  28.210 ms  32.840 ms  33.192 ms
3  link4-central10.pcl-gw02.plus.net (84.93.249.70)  26.515 ms  27.589 ms  29.084 ms
4  xe-1-2-0.pcl-cr02.plus.net (212.159.1.6)  32.177 ms  33.555 ms  33.867 ms
5  ae2.pcl-cr01.plus.net (195.166.129.6)  34.685 ms  35.010 ms  37.284 ms
6  ae1.ptw-cr01.plus.net (195.166.129.0)  37.662 ms  35.613 ms  38.328 ms
7  te-4-2.car5.London1.Level3.net (217.163.45.249)  68.799 ms  51.151 ms  50.518 ms
8  ae-1-51.edge5.London1.Level3.net (4.69.139.75)  20.695 ms  22.997 ms  20.440 ms
9  ldn-b5-link.telia.net (213.248.96.37)  21.386 ms  24.627 ms  24.613 ms
10  ldn-bb2-link.telia.net (80.91.246.114)  31.160 ms  32.151 ms  32.521 ms
11  adm-bb3-link.telia.net (80.91.253.146)  32.143 ms  34.052 ms  34.145 ms
12  adm-b5-link.telia.net (213.155.134.45)  36.567 ms  29.616 ms  28.046 ms
13  80-239-205-65.customer.teliacarrier.com (80.239.205.65)  31.610 ms  30.322 ms  28.924 ms[/tt]