cancel
Showing results for 
Search instead for 
Did you mean: 

Slow download speed, but fast upload?

theberrys
Grafter
Posts: 69
Registered: 30-05-2009

Slow download speed, but fast upload?

I am on the Plusnet Fibre Extra product, the one with 80/20 download/upload speed and current speed tests show that I am getting 30mb download and close to 19mb upload.  The speed estimate on my account shows close to 60mb download.  What should I do to diagnose the speed problem?
5 REPLIES
AndyHamp
Grafter
Posts: 36
Registered: 07-07-2011

Re: Slow download speed, but fast upload?

Greg,
sorry i can't help you but i've just switched to the 80/20 service from the 40 version .... i was getting 36/1.5 ... now i'm getting 35/17 ! I guess we're going to have to call customer services ...
Andy
AndyHamp
Grafter
Posts: 36
Registered: 07-07-2011

Re: Slow download speed, but fast upload?

Followed advice written elsewhere and powered of the modem for 10 minutes and it has resynced at 64/16  Grin
I'd suggest you do the same ... shame the email from plus.net didn't say this needed to be done ....
Andy
G3YBO
Grafter
Posts: 104
Registered: 27-11-2010

Re: Slow download speed, but fast upload?

Hi................I also changed my account from 40/10 and my download speed is down for last few days.......Did a reset on both modem and router and no change.......Roger
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: Slow download speed, but fast upload?

Hi G3YBO,
Are you using a wired or wireless connection? Your profile is set correctly, if you are using a wired connection then I would suggest raising a fault at http://faults.plus.net If not then please try with a wired connection and see if there is any difference.
Chris
theberrys
Grafter
Posts: 69
Registered: 30-05-2009

Re: Slow download speed, but fast upload?

Also, if any of you are connected to your router via powerline, I suggest you connect directly to the router with an Ethernet cable and re run the speed test.  I did a speed test with my 200mbps powerline kit and maxed out at 30mb, but I just tried connecting directly to the router and it was hitting 60mb.  I guess I need to update my connection to the router.  I am using the TP-Link AV200 200Mbps Mini Powerline Starter Kit and it just cannot deal with the speeds Sad
Significant difference in speed when using direct wired Ethernet vs powerline Ethernet