cancel
Showing results for 
Search instead for 
Did you mean: 

Setting Up VPN On Plusnet 2704n Router - Possible?

netspeed
Grafter
Posts: 61
Registered: 24-12-2009

Setting Up VPN On Plusnet 2704n Router - Possible?

Has anyone got a VPN working ok on their Plusnet supplied 2704n router? And if you do, could you help with some setting advice or point to a FAQ that runs through the correct configuration.

I have a VPN working fine with its GUI from my PC. But I want all devices connected to router (incl some which can't themselves be configured for a VPN) to be able to use it. So far a search of google hasn't led me to a how-to for router dummies nor experts. I'm more on the router dummy end of scale. Smiley

I'll paste in minute what I've tried. The router has a LOT of settings in the VPN section of expert menu. I'm sure I'm gonna have to change some more than I tried.

Any help gratefully received.

1 REPLY
netspeed
Grafter
Posts: 61
Registered: 24-12-2009

Re: Setting Up VPN On Plusnet 2704n Router - Possible?

This is what I've tried so far:

 

ROUTER EXPERT MENU CONFIGURING VPN [sagem 2704n router]
http://192.168.1.254/expert_user.html

DID
Advanced Settings --> VPN --> L2TP Client


FIRST PAGE
Tunnel Name - MY VPN [my entry]
L2TP Server Ip Address - xxx.xxx.xxx.xx [my VPN Server IP]

-------------------------------------------------------------------------------------------------------------------------------------------------

SECOND PAGE
PPP usually requires that you have a user name and password to establish your connection. In the boxes below, enter the user name and password that your ISP has provided to you.

Enter username-password generated on VPN site for this. Get a warning that this connection is not secure. Logins entered here could be compromised. [I ignore it]
PPP Username -  username generated for this on VPN site
PPP Password - password generated for this on VPN site
PPPoE Service Name: [Left Blank]
Authentication Method: [Left on AUTO]

Checkbox [left unchecked] Dial on demand (with idle timeout timer)
Checkbox [left unchecked] ppp retry on authentication error

PPP MTU (Bytes) [PPPoE:68-1492,PPPoA:68-1500]: 1492 [value in box there, I reduced it to 1400 per advice on VPN site]
Checkbox [left unchecked] Use Static IPv4 Address
Checkbox [left unchecked] Use Static IPv6 Address
IPv6 Address: [left box empty]

Checkbox [left unchecked] Enable IPv6 Unnumbered Model
Checkbox [left unchecked] Launch Dhcp6c for Address Assignment (IANA)
Checkbox [left unchecked] Launch Dhcp6c for Prefix Delegation (IAPD)
Checkbox [left unchecked] Enable PPP Debug Mode

Multicast Proxy
Checkbox [left unchecked] Enable IGMP Multicast Proxy
Checkbox [left unchecked] No Multicast VLAN Filter


-------------------------------------------------------------------------------------------------------------------------------------------------

THIRD PAGE

WAN Setup - Summary

Make sure that the settings below match the settings provided by your ISP.

Connection Type: PPPoE
NAT: Enabled
Firewall: Enabled
IGMP Multicast: Disabled
Quality Of Service: Disabled

Click "Apply/Save" to have this interface to be effective. Click "Back" to make any modifications

I click Save And get saved screenshot.
Hit reboot

Connection goes down, eventually comes back. But IP is not changed, still on my Plusnet's IP. Only via the app on PC can I connect to VPN and change IP.