cancel
Showing results for 
Search instead for 
Did you mean: 

SSH connections using non-standard port

Louison
Newbie
Posts: 2
Registered: ‎26-04-2012

SSH connections using non-standard port

Having just signed up for the Extra broadband package (but not yet connected), I'm trying to establish whether I'm likely to have problems with SSH connections to an external server using non-standard port (ie not 22, this is to head off unwanted port scanning traffic). A few years ago my brother had to leave PlusNet because the connection kept dropping and he was advised it was because of the non-standard port.
I've checked with PlusNet support and they've said the non-standard port would not be blocked, but might have been subject to "a de-prioritized band to the extent that the tunnel wasn't functioning properly" but that I should check with the Forums to see if people are having any problems.
Is anyone using SSH in this way?
Thanks
3 REPLIES
kmilburn
Grafter
Posts: 905
Thanks: 2
Registered: ‎30-07-2007

Re: SSH connections using non-standard port

I have SSH on a non standard port and it works fine.
I've not noticed any problems with it dropping out,  but I don't tend to have it open for extended periods.
You will need to turn the Broadband firewall (https://portal.plus.net/my.html?action=firewall) off or to low(can't remember its default) to allow it to work though;  or one of the other advanced settings.
If you using Linux  I'd also suggest installing DenyHosts (http://denyhosts.sourceforge.net/).
Louison
Newbie
Posts: 2
Registered: ‎26-04-2012

Re: SSH connections using non-standard port

Thanks, my service is activate now and so far no problems with SSH.  Smiley
Moderator
Moderator
Posts: 18,838
Thanks: 2,021
Fixes: 260
Registered: ‎11-01-2008

Re: SSH connections using non-standard port

If you do notice problems it's likely to be in peak hours, one option would be to add on pro as you would not be subject to the traffic management.

Customer / Moderator / If it helped click the thumb / If it fixed it click 'This fixed my problem'