cancel
Showing results for 
Search instead for 
Did you mean: 

Routing issues on ptn-bng01?

allwork
Dabbler
Posts: 11
Registered: 25-07-2012

Routing issues on ptn-bng01?

Hi,
I've been having issues for a number of days which I finally managed to troubleshoot on Friday to ensure they weren't local. Plusnet still haven't responded to the ticket from 36hrs ago so I thought I'd look for similar issues in the forums.
I'm having total failures in reaching CDNs (Akamai, often Amazon) which means that websites are either timing out or partially loading. I would try with a different IP but reconnecting never gives a different on, so could anyone help?
If you're on ptn-bng01 could you share a few traceroutes to www.tesco.com , news.bbcimg.co.uk, www.netflix.com .

Bit more info: My traceroutes to these sites never get past the next plus.net server after the gateway (see below). It's not an individual machine, router, DNS or other local issue.
1  vigor.router (192.168.1.1)  1.375 ms  1.678 ms  1.059 ms
2  lo0.11.central11.ptn-bng01.plus.net (195.166.128.229)  22.706 ms  23.164 ms  23.688 ms
3  irb.11.ptw-cr02.plus.net (84.93.249.1Cool  22.605 ms  23.939 ms  23.727 ms
4  * * *
5 REPLIES
Community Veteran
Posts: 6,653
Thanks: 233
Fixes: 16
Registered: 16-02-2009

Re: Routing issues on ptn-bng01?

No problems with the first 2, netflix takes a while though then times out:

hairybiker@duo:~$ traceroute www.tesco.com
traceroute to www.tesco.com (212.56.73.43), 30 hops max, 60 byte packets
1  dsldevice.lan (192.168.1.254)  0.714 ms  0.864 ms  0.998 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.228)  46.270 ms  46.274 ms  46.945 ms
3  irb.10.ptw-cr01.plus.net (84.93.249.1)  47.469 ms  47.446 ms  47.879 ms
4  ae1.pcl-cr02.plus.net (195.166.129.3)  55.287 ms ae1.pcl-cr01.plus.net (195.166.129.1)  47.853 ms ae1.pcl-cr02.plus.net (195.166.129.3)  55.250 ms
5  ae2.pcl-cr01.plus.net (195.166.129.6)  49.515 ms cache.akamai.com (212.56.73.43)  49.007 ms  48.984 ms
hairybiker@duo:~$ traceroute news.bbcimg.co.uk
traceroute to news.bbcimg.co.uk (212.56.73.17), 30 hops max, 60 byte packets
1  dsldevice.lan (192.168.1.254)  0.627 ms  0.805 ms  1.038 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.228)  46.405 ms  46.369 ms  46.356 ms
3  irb.10.ptw-cr01.plus.net (84.93.249.1)  45.877 ms  46.456 ms  46.665 ms
4  ae1.pcl-cr02.plus.net (195.166.129.3)  47.001 ms ae1.pcl-cr01.plus.net (195.166.129.1)  46.983 ms ae1.pcl-cr02.plus.net (195.166.129.3)  47.528 ms
5  cache.akamai.com (212.56.73.17)  48.539 ms ae1.pcl-cr01.plus.net (195.166.129.1)  77.375 ms cache.akamai.com (212.56.73.17)  49.826 ms
hairybiker@duo:~$ traceroute www.netflix.com
traceroute to www.netflix.com (54.247.102.156), 30 hops max, 60 byte packets
1  dsldevice.lan (192.168.1.254)  0.680 ms  0.881 ms  1.102 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.228)  45.134 ms  46.815 ms  46.803 ms
3  irb.10.ptw-cr02.plus.net (84.93.249.2)  47.569 ms irb.10.ptw-cr01.plus.net (84.93.249.1)  46.960 ms  46.939 ms
4  amazon-gw-a.lonap.net (5.57.80.8)  47.497 ms 195.66.225.175 (195.66.225.175)  64.366 ms  64.346 ms
5  176.32.106.4 (176.32.106.4)  59.991 ms 178.236.3.51 (178.236.3.51)  62.692 ms 178.236.3.53 (178.236.3.53)  92.199 ms
6  176.32.106.14 (176.32.106.14)  61.615 ms 176.32.106.29 (176.32.106.29)  57.911 ms 176.32.106.34 (176.32.106.34)  56.336 ms
7  178.236.0.83 (178.236.0.83)  76.361 ms 178.236.1.139 (178.236.1.139)  59.992 ms 178.236.0.173 (178.236.0.173)  61.628 ms
8  178.236.0.208 (178.236.0.208)  57.282 ms  57.253 ms 178.236.0.206 (178.236.0.206)  57.206 ms
9  178.236.0.125 (178.236.0.125)  57.199 ms  58.047 ms  58.021 ms
10  ec2-79-125-0-133.eu-west-1.compute.amazonaws.com (79.125.0.133)  67.360 ms  67.335 ms  67.313 ms
11  * * *
-------cut duplicates-------
30  * * *
hairybiker@duo:~$

I have noticed that my ping has gone up to 50ms on this gateway though.
Community Veteran
Posts: 4,972
Thanks: 367
Fixes: 16
Registered: 10-06-2010

Re: Routing issues on ptn-bng01?

I noticed today that trying to load http://labs.adobe.com ending up sitting around waiting indefinitely for wwwimages.adobe.com
The trouble with the traceroutes to those akamai addresses is that there are multiple routes / destinations, so the traceroute displays a composite of any or all of the different routes:
[tt]traceroute -T -p 80 www.tesco.com
traceroute to www.tesco.com (212.56.73.43), 30 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  4.252 ms  5.537 ms  5.520 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.22Cool  26.147 ms  27.387 ms  27.389 ms
3  irb.10.ptw-cr01.plus.net (84.93.249.1)  28.975 ms  34.173 ms irb.10.ptw-cr02.plus.net (84.93.249.2)  34.190 ms
4  ae2.ptw-cr01.plus.net (195.166.129.4)  34.178 ms ae1.pcl-cr02.plus.net (195.166.129.3)  34.170 ms ae1.pcl-cr01.plus.net (195.166.129.1)  34.184 ms
5  ae2.pcl-cr01.plus.net (195.166.129.6)  34.174 ms cache.akamai.com (212.56.73.43)  34.177 ms ae2.pcl-cr01.plus.net (195.166.129.6)  34.562 ms
# traceroute -T -p 80 wwwimages.adobe.com
traceroute to wwwimages.adobe.com (212.56.73.11), 30 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  3.795 ms  5.437 ms  5.834 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.22Cool  25.281 ms  26.553 ms  27.123 ms
3  irb.10.ptw-cr01.plus.net (84.93.249.1)  27.542 ms irb.10.ptw-cr02.plus.net (84.93.249.2)  29.113 ms  30.384 ms
4  ae1.pcl-cr01.plus.net (195.166.129.1)  32.064 ms  32.060 ms  33.740 ms
5  cache.akamai.com (212.56.73.11)  34.287 ms  35.025 ms ae2.pcl-cr01.plus.net (195.166.129.6)  40.210 ms
# traceroute -T -p 80 www.netflix.com
traceroute to www.netflix.com (54.247.103.242), 30 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  4.382 ms  9.333 ms  9.345 ms
2  lo0.10.central10.ptn-bng01.plus.net (195.166.128.22Cool  24.388 ms  25.757 ms  26.481 ms
3  irb.10.ptw-cr01.plus.net (84.93.249.1)  27.516 ms  28.216 ms  29.591 ms
4  amazon-gw-a.lonap.net (5.57.80.Cool  32.418 ms * *
5  176.32.106.6 (176.32.106.6)  47.282 ms 178.236.3.51 (178.236.3.51)  47.325 ms 176.32.106.6 (176.32.106.6)  49.327 ms
6  176.32.106.27 (176.32.106.27)  53.189 ms  51.497 ms  45.592 ms
7  176.32.106.51 (176.32.106.51)  43.998 ms 178.236.0.101 (178.236.0.101)  32.746 ms 176.32.106.71 (176.32.106.71)  35.895 ms
8  178.236.0.114 (178.236.0.114)  34.138 ms 178.236.0.112 (178.236.0.112)  34.826 ms 178.236.0.110 (178.236.0.110)  35.789 ms
9  178.236.0.58 (178.236.0.5Cool  35.389 ms 178.236.1.17 (178.236.1.17)  37.089 ms 178.236.0.58 (178.236.0.5Cool  31.256 ms
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  ec2-54-247-103-242.eu-west-1.compute.amazonaws.com (54.247.103.242)  46.584 ms  47.701 ms  48.919 ms
[/tt]
allwork
Dabbler
Posts: 11
Registered: 25-07-2012

Re: Routing issues on ptn-bng01?

Thanks Both,
As ejs says, it's hard to troubleshoot CDNs so this really helps.
Ideally I'd like to move to a different gateway & IP but no amount of time between reconnecting has done this!
Annoying to have to wait for Plusnet to respond to tickets after 48hrs+ too
Oh well. At least the streaming from Netflix is ok Wink
Community Veteran
Posts: 6,824
Thanks: 1
Registered: 27-10-2012

Re: Routing issues on ptn-bng01?

Are you logged in with username@plusdsl.net? There was a user before with similar issues and he was using @plus.net as the login I think.
Community Veteran
Posts: 4,972
Thanks: 367
Fixes: 16
Registered: 10-06-2010

Re: Routing issues on ptn-bng01?

The issue with wwwimages.adobe.com on labs.adobe.com is presumably some Firefox issue, or something weird, because WebKitGTK+ MiniBrowser doesn't have the same problem, but MiniBrowser isn't even loading the images from the same URLs.
WebKitGTK+ MiniBrowser requests images such as:
GET /technologies/acrobat/images/acrobat_appicon_30x30.jpg HTTP/1.1
Host: labs.adobe.com
Firefox is trying to do this first:
GET /labs.adobe.com/cdn/technologies/acrobat/images/acrobat_appicon_30x30.jpg HTTP/1.1
Host: wwwimages.adobe.com
Edit to add:
$ wget http://wwwimages.adobe.com/labs.adobe.com/cdn/technologies/acrobat/images/acrobat_appicon_30x30.jpg
--2014-09-28 18:19:41--  http://wwwimages.adobe.com/labs.adobe.com/cdn/technologies/acrobat/images/acrobat_appicon_30x30.jpg
Resolving wwwimages.adobe.com... 212.56.73.26, 212.56.73.11
Connecting to wwwimages.adobe.com|212.56.73.26|:80... connected.
HTTP request sent, awaiting response... 504 Gateway Time-out
2014-09-28 18:23:41 ERROR 504: Gateway Time-out.