cancel
Showing results for 
Search instead for 
Did you mean: 

Router/Printer problem

slavo71
Rising Star
Posts: 135
Thanks: 8
Fixes: 1
Registered: 05-09-2014

Router/Printer problem

Hi, I have a HP 2540 wireless printer. My PC is running W8 without a wifi card in it, whilst I was using the homehub 3 router on BT (hard wired into it) I could use the wireless printer with no issues.
I have done the same with the Plusnet router, plugged my PC directly into it, but I've just tried to use the printer and it's saying it's off line! However, my wife's laptop, my ipad and iphone all find it straight away and are able to print!
I've uninstalled all the HP software from my PC and rebooted, when I try to install the HP printer software it can see the printer on the network straight away and it allows me to select it, yet when I click continue it goes through the installing part and then comes up with 'The printer was unable to be installed over the network'.
Any ideas? Is there something in the router that I need to change to allow it to connect with the printer?
Thanks
2 REPLIES
Razorback
Grafter
Posts: 208
Registered: 08-08-2014

Re: Router/Printer problem

I had a similar issue with the same printer when I was with BT using a homehub 4. I could never see the printer over the network. When I moved to plusnet I did a factory reset of the homehub and found the printer was visible immediately. Has worked perfectly since.
slavo71
Rising Star
Posts: 135
Thanks: 8
Fixes: 1
Registered: 05-09-2014

Re: Router/Printer problem

Cheers for that but I've fixed it...somehow!!! Think it was pure fluke!
First off I restored this PC to before I started dicking around with new drivers today, so it was back where we started!
I then clicked on the main printer setup icon on the wifes laptop and saw a button to update the ip network, it then asked me to plug in the laptop to the printer....it did the update and that changed the ip around to the new Plusnet one!
I came into this room and tried installing the software again...same thing! I then clicked add new printer...no printer found. So I clicked one of the print/scan icon tiles on the main W8 screen. That was still showing her old printer name, I clicked on settings and did a manual search for the new ip, it found it and added it. Everything now works again even though it's showing under the old printer name!!!! I assume it's just picked it up and the name I called it just runs on my PC.
I just can't understand how it was still printing wirelessly with the iphone/ipad and her laptop when it still had the old BT ip stored in the printer!!!
Crazy and that's another almost 3 hours I'm never getting back!!! lol  Roll eyes