cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with VPN connection

mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Problems with VPN connection

Hi,
I have recently started having problems connecting to my work VPN through my residential PluseNet Extra account. This has been working in the past, but in the last two weeks or so it has stopped completely. This is on a laptop running XP and a desktop running Vista.
I now get an error saying that the server can not be contacted.
I have tested the VPN connection from an external wifi hotspot and can connect without a problem, so I know that it should be working. I can even connect to it using my phone.
I have tried turning off my firewall and anti-virus, but this did not help.
I am using a BT Voyager 2110 router with the latest firmware installed.
Does anybody know if there is there anything that I should be aware of or that I can test in order to get this working again as I am now completely stumped...Huh
I did ask technical support but they simply said 'we do not directly support VPN connections on residential accounts' and told me to try the forums.... hmmm not much help.

All the best,
Martin
27 REPLIES
jojopillo
Grafter
Posts: 9,786
Registered: 16-06-2010

Re: Problems with VPN connection

Hi mjwebb,
It is an odd one that. A good idea to help us find out a bit more information would be to perform a wireshark capture while you're trying to connect. You can either post your results here or send a ticket to us via your account and we can analyse the data and see if we can come up with some answers for you.
Jojo Smiley
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

Hi Joanne,
Thanks for the response. I will try using wireshark tonight (am I at work now) and let you know the results.

All the best,
Martin
jojopillo
Grafter
Posts: 9,786
Registered: 16-06-2010

Re: Problems with VPN connection

HI Martin,
no worries, just hope we can shed a bit more light on it for you.
Jojo Smiley
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Problems with VPN connection

@mjwebb,
What setting do you have on the PlusNet Firewall ? https://portal.plus.net/my.html?action=firewall
It needs to be Off or Low for VPN to work
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

@MisterW,
The PlusNet Firewall is turned off.
Cheers,
Martin
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Problems with VPN connection

OK , it was worth checking.
A spot of googling turned up this http://www.broadbandbanter.com/showthread.php?t=17026
which seems to indicate that VPN passthrough ( particulary for IPSEC ) is broken on the Voyager 2110.
Have you always used the 2110 ?
or has the VPN method changed recently ( say from PPTP to IPSEC ) ?
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

@MisterW,
Thanks for looking, but no - I am using PPTP - I should have mentioned that in my initial message but forgot.
I am at home now and am going to try using the wireshark to see if that shows anything.
I also have a Thomson router that I was sent recently. I will try that later tonight also to see if it is simply the router. I have noted the firmware issues for this router in other forums posts, so will be sure the make sure that I have the correct version running....

Cheers,
Martin
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Problems with VPN connection

Quote
Thanks for looking, but no - I am using PPTP - I should have mentioned that in my initial message but forgot.

That thread isn't clear whether the 2110 is broken for all VPN passthrough or just ISPEC.
If it helps to know, I use PPTP VPN to connect to the office through my Plusnet connection ( Firewall on Low ) without any problems
so its not a general PlusNet problem. I don't have a Voyager 2110 though, my router's a BT Business Hub ( aka 2wire 2700HGV).
As you say, if you're going to try the TG585 check the firmware rev.
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

OK - it has been a long evening.
I started by downloading wireshark and capturing the traffic as I tried to connect to the VPN through the BT router. This did not show anything interesting (to my eyes anyway...), as it would not get past the first request to the VPN. It had a header checksum error in that request - which Google failed to shed any light on for me.
I decided to try the Thomson router that was sent out when I recently changed my contract with PlusNet. I had not bothered setting this up before because everything was working fine with the BT Voyager.
I got this up and running and then downgraded the firmware to from 8.2.23.0 to 8.2.6.5 after reading forum posts about VPN issues with this router (http://community.plus.net/library/hardware/how-to-upgradedowngrade-the-firmware-on-the-thomson-585v7...).
Fingers crossed I tried again - still no luck.
I noticed that there was a firewall on the router so I disabled this and tried again.... still no luck. hhhmmmppphhh.
I then started to capture data again using wireshark. This was still only showing the connection stopping at the first hurdle, but I was going to upload it to this forum for more knowledgeable people to have a look at.
I was just about to post a reply here when I tried one last time to connect.... and guess what.... It connected!!!
I disconnected and re-connected a few times to make sure it wasn't a fluke. I also turned on my laptop and made sure that could connect too.
I have no idea why it suddenly started to work, but it seems to be OK now. I am going to risk breaking things again by trying the BT router again - just out of curiosity...
Thanks for your help and suggestions.
All the best,
Martin
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Problems with VPN connection

Glad you got it working, but if you're like me I would always like to understand why it wasn't working...
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

Ah.
Thought it was too good to be true.
I tried connecting to the VPN again this morning and it is not working again.... I have not changed anything since it was working last night.
I have attached a png file which is a screen grab from wireshark. It looks like I can not upload the actual data file to this forum... so hopefully that screen shows some information to somebody....
I get the feeling that this inconsistent behaviour has more to do with the actual broadband line / connection than the hardware now. Sometimes it works, most of the time it does not.
I recently moved my phone line from BT to PlusNet and changed my broadband account from an old PAYG tariff to 'Extra'. Can these things have played a part in destabilising the VPN somehow?Huh
I am not sure where I can go from here.

Cheers,
Martin

PS. Just tried it again after writing this and it connected!! However, I need some help to figure what is causing this inconsistency. Can the router be taking time to 'wake up' when a PPTP connection is requested....?Huh
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Problems with VPN connection

I'm a little concerned by the packet with a checksum error. That's a packet from your local pc and is going to be rejected by the receiver.
If that was part of the initial PPTP negotiation then its going to fail. You might want to monitor your traffic with wireshark for a while and see if you are getting a number of checksum errors. They may not be as noticable with other protocols as they may retransmiit and recover but it could well be affecting the VPN setup. Checksum errors could indicate either an external electrical interference affecting the transmission or possibly a faulty network card.
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

From reading around it sounds like the checksum errors are to do with where wireshark intercepting the packet before the TCP checksum is created (http://www.wireshark.org/faq.html#q11.1).
I do not believe that this is the problem - particularly as my problem is effecting two computers and is being experienced using two different routers.
I do have something odd to throw into the mix however. I have been trying the VPN connection through the evening and it has failed continuously up until 21:30 - after which it now connects without a problem.... This same behaviour was seen when I was trying to get this working last week - see my post from 02/09/2010.
Does anybody know if Plus Net have any odd restrictions or if my account with them could be miss configured in some way?Huh
mjwebb
Dabbler
Posts: 11
Registered: 02-09-2010

Re: Problems with VPN connection

I have been unable to connect to the VPN at all tonight, so it looks like my delusional paranoia about the time was just that...
I had a complete fob off from the support team - 'Unfortunately there is no support we can offer in this area.'... nice.
I am sending Jojo some wireshark data so will have to see if it shows anything to her...
Interestingly colleagues of mine are also using Plus Net at home and are having similar problems with the VPN access.
This is soooo frustrating now. Everything worked until a month or so ago.