cancel
Showing results for 
Search instead for 
Did you mean: 

Problem port forwarding http on latest ADSL router

greengenie
Newbie
Posts: 2
Registered: 23-02-2013

Problem port forwarding http on latest ADSL router

Recently, I received new ADSL router (brilliant performance) and SSH port forwarding is fine, but http (port 80) isn't working.
In advanced settings, I try to choose the destination mac address (to my main Win7 PC nic, same as for SSH port 22). The list of destinations on the menu include my other PC by its name, but the main PC is listed only as "Unknown-80:ee:73:a6:55:e4" (correct, but this computer does have a name "RISCUBE4" and in the SSH port forwarding rule its correctly shown with that name).
Anyway, I choose this destination and the router shows the new port forwarding rule, but it fails to actually forward port 80 traffic to the required destination.
When I open the router's port forwarding setting page again, I find that the http rule now has "Unknown-80:ee:73:a6:55:e4 (70:de:e2:0f:54:e3)". i.e. it has changed the mac address to point to a different device but kept the original setting as a description only.
If I delete the rule and recreate it, every time I set the correct destination mac address. it later gets changed to a wrong one (not the same every time).
Consequently, I am unable to get the router to do what I want.
I know what I'm doing with this stuff as I've run my own web server on earlier plusnet routers (and others) for years. I've discovered there is no telnet interface to these new routers so I can't log in as admin and manually set the port forwarding rules.
Has anyone else had this problem and found a solution?  Or will I have to get a more sophisticated router where the port forwarding works as it has done for me in the past?
Thanks