cancel
Showing results for 
Search instead for 
Did you mean: 

Port forwarding prevented

p99t
Newbie
Posts: 4
Registered: ‎07-04-2013

Port forwarding prevented

I have installed a WiFi thermostat that is controlled through my Tecnicolour 582n router. I can now control our heating via the LAN (using a static IP address (192.168.1.200). It should also be possible to control the system through the WAN via a smartphone App or the web. External control requires a fixed IP address which I have set up and also port forwarding (ports 80 and 806Cool to the device's local address, but I can't get this to work.
Despite following the port forwarding instructions to the letter, these two ports remain invisible to  http://www.t1shopper.com and http://www.canyouseeme.org. Also I cannot connect through the web or through the phone App when off my home network. I have tried dropping the TG582n firewall and also the Plusnet firewall (the existence of which I only discovered by chance!} but to no effect. A fuller port scan with both firewalls set at medium security, reveals that port 51005 is open all the time, so at least this works. The NAT maplist is below. Items 2 to 4 are TCP protocols. xxx.xxx.xxx.xxx. is my fixed IP.
Is Plusnet blocking ports 80 and 8068?Huh
{admin}[nat]=>maplist
Idx Type Interface      Outside Address                Inside Address                Use
  1 NAT  Internet        xxx.xxx.xxx.xxx                        127.0.0.1                          0
  2 NAPT Internet        xxx.xxx.xxx.xxx:80                192.168.1.200:80                0
  3 NAPT Internet      xxx.xxx.xxx.xxx:8068            192.168.1.200:8068          0
  4 NAPT Internet        xxx.xxx.xxx.xxx:51005          127.0.0.1:51005                  0
  5 NAPT Internet        xxx.xxx.xxx.xxx                unmapped                              30
9 REPLIES
TBag
Grafter
Posts: 74
Registered: ‎06-03-2013

Re: Port forwarding prevented

p99t
Newbie
Posts: 4
Registered: ‎07-04-2013

Re: Port forwarding prevented

Quote from: TBag
This might help

Thanks TBag, I am indeed using the Heatmiser WiFi stat and ports 80 and 8068 are the ones that I have tried to forward. Some ISPs block certain ports but I don't think Plusnet do. Perhaps it's time to try another Router.
Community Veteran
Posts: 5,472
Thanks: 292
Fixes: 4
Registered: ‎11-08-2007

Re: Port forwarding prevented

When you disabled the Plusnet firewall, did you restart your connection ?
as that is not very clear from the settings page, but does appear in the help !
Quote
Remember! If you change your firewall setting, you must restart your Internet connection for the change to take effect.

https://portal.plus.net/support/security/firewalls/broadbandfirewall.shtml

and is mentioned in the page following hitting the "UPDATE SETTINGS" button -
Quote
Settings updated
For your new settings to take effect, please disconnect and reconnect your broadband connection.
p99t
Newbie
Posts: 4
Registered: ‎07-04-2013

Re: Port forwarding prevented

Yes I did and I have tried it several times.
I can still access port 51001 from outside at all times, but this is forwarded to the loopback address 127.0.0.1 rather than the internal device addresses.
dick:quote
Plusnet Help Team
Plusnet Help Team
Posts: 13,536
Thanks: 251
Fixes: 69
Registered: ‎27-04-2007

Re: Port forwarding prevented

Let me bounce this over to a member of our products team so to see what we can suggest.
We'll get back to you ASAP.
Adam
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
p99t
Newbie
Posts: 4
Registered: ‎07-04-2013

Re: Port forwarding prevented

After much meddling and resetting the TG582n router, I set it up with the simplest possible port forwarding configuration to 198.162.1.200. Using DHCP, I have not specified any ports to be static. Now my thermostsat finally does appear in the list of devices (It didn't before) and it appears at that address. Also port 80, scanned remotely, is open and 8068 is open some of the time.
Strangely, the router software shows 192.168.1.200 as a static address even though I didn't specify it. Anyway there are signs that the system might work now. Thanks to all.
ianh100
Newbie
Posts: 2
Registered: ‎03-05-2014

Re: Port forwarding prevented

Hi, Just wondering how you are getting on with the Heatmiser. I have one that was rock solid with a SKY router, I then switched to Plusnet and it configured OK but the Heatmiser seems to drop the WiFi link after a few days. This is a real pain as I am 150 miles away. The router is only about 3m from the heatmiser and there are almost no other wifi signals so it is not interference.
Superuser
Superuser
Posts: 12,722
Thanks: 3,976
Fixes: 26
Registered: ‎22-08-2007

Re: Port forwarding prevented

Ian,
Is your router set to wifi auto channel or a manual fixed channel?
I would suspect that the wifi thermostat is not following wifi auto channel swaps.  I found the same problem with my Samsung printer; with the router set to auto channel, the printer kept disappearing from the network.  When set to a fixed (manual) channel connectivity is rock solid.
By default TG582m uses auto channel selection - it is possible the sky router did not.
HTH,
Kevin
Plusnet Help Team
Plusnet Help Team
Posts: 13,536
Thanks: 251
Fixes: 69
Registered: ‎27-04-2007

Re: Port forwarding prevented

I've just bounced this thread over to our resident router expert I'll make sure one of us comes back with more info ASAP.

UPDATE:
Quote
I have one that was rock solid with a SKY router, I then switched to Plusnet and it configured OK but the Heatmiser seems to drop the WiFi link after a few days. This is a real pain as I am 150 miles away. The router is only about 3m from the heatmiser and there are almost no other wifi signals so it is not interference.

We think the DHCP lease might be expiring.
It might be worth assigning a static IP to that device with an address outside the usual DHCP range.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team