cancel
Showing results for 
Search instead for 
Did you mean: 

Poor fibre speeds (5.18mbps) on new service

Woody12
Newbie
Posts: 4
Registered: 24-11-2013

Poor fibre speeds (5.18mbps) on new service

I have just upgraded to Plusnet Fibre on Thursday, I have come to use the service today and found I am only receiving '5.18mbps' - a ticket has been raised with plusnet, whilst I appreciate the std 48-72hr response time is the industry standard as sternly quoted by a plusnet employee in a similar thread- it's very poor and somewhat lacking, it seems that for myself and the previous post that this is a provisioning issue and not a fault.
I would have naturally and I believe justifiably expected the service I ordered to have been fully tested at the point of provision as well as customer care follow up from PlusNet to ensure that the provision had been successful without me having to discover for myself.
Let us see how plusnet are able to rise to the challenge of turning a very dissatisfied customer into a plusnet champion!
4 REPLIES
Community Veteran
Posts: 26,637
Thanks: 868
Fixes: 10
Registered: 10-04-2007

Re: Poor fibre speeds (5.18mbps) on new service

What does https://portal.plus.net/my.html?action=data_transfer_speed say for your current line speed?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Woody12
Newbie
Posts: 4
Registered: 24-11-2013

Re: Poor fibre speeds (5.18mbps) on new service

hi Jelv..
Link doesn't work!
BTW website, Speed test etc all relay 5.18mps....
Community Veteran
Posts: 26,637
Thanks: 868
Fixes: 10
Registered: 10-04-2007

Re: Poor fibre speeds (5.18mbps) on new service

Sorry about that - not sure how I managed to mess it up. Try again now.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Plusnet Help Team
Plusnet Help Team
Posts: 12,994
Thanks: 142
Fixes: 46
Registered: 27-04-2007

Re: Poor fibre speeds (5.18mbps) on new service

@Woody12
Hi there,
Sorry to see you've having problems with slow speeds at the moment. I've checked and can confirm there are no provisioning issues which could have caused this so we do need to look at this as a fault for you.
Our faults team will be replying back to ticket 77654948 ASAP for you.
Adam
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team