cancel
Showing results for 
Search instead for 
Did you mean: 

PlusNet TG582n Network Icons

oren
Newbie
Posts: 2
Registered: 14-04-2013

PlusNet TG582n Network Icons

As PlusNet's TG582n on ADSL does not have a USB port is there any way to disable the MediaServer icon & the TECHNICOLOR network place icon in Win7-64 as they both represent nothing useful ?
(I would have thought that this was something that would be suppressed in the PlusNet firmware as they chose to take the USB port off the ADSL routers)
9 REPLIES
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: PlusNet TG582n Network Icons

good question - I wish I knew the answer
Superuser
Superuser
Posts: 6,781
Thanks: 862
Fixes: 55
Registered: 30-07-2007

Re: PlusNet TG582n Network Icons

Login to the TG582 , go to Home->Content Sharing and click on Configure, uncheck the 'Server Enabled' boxes for both the Network File Server & UPnP AV Media Server and then click Apply.
That should disable all the Content sharing functions and they should no longer appear ( may need to restart the PC and/or the router )
Hope that helps
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: PlusNet TG582n Network Icons

That link isn't there
Community Veteran
Posts: 26,718
Thanks: 931
Fixes: 10
Registered: 10-04-2007

Re: PlusNet TG582n Network Icons

Also the contentsharing command is disabled in the CLI.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Superuser
Superuser
Posts: 6,781
Thanks: 862
Fixes: 55
Registered: 30-07-2007

Re: PlusNet TG582n Network Icons

Thanks Jelv, I was just looking at that.
Fancy disabling that, how stupid !!
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: PlusNet TG582n Network Icons

Is contentsharing shown in the user.ini file ?
If so try disabling it there and restoring the file.--
eg:
[ contentsharing.ini ]
cifs config state=disabled
Alternatively try running the cli command as a script, this sometimes works with commands which refuse to run.
eg:
script add name=icon command="cifs config state=disabled"
script run name=icon pars=""
saveall
Superuser
Superuser
Posts: 6,781
Thanks: 862
Fixes: 55
Registered: 30-07-2007

Re: PlusNet TG582n Network Icons

I've just looked at a user.ini file from f/w 10.2.2.9 ( presumably the one with no USB ) and it has
Quote
[ contentsharing.ini ]
ftp config state=disabled
cifs config state=disabled workgroup="" name="" comment=""
upnp config state=disabled friendlyname=""
upnp radiostation config state=disabled
whereas 8.4.4.J has
Quote
[ contentsharing.ini ]
ftp config state=disabled
cifs config state=enabled workgroup=WORKGROUP name=Technicolor comment="DSL Gateway"
upnp config state=enabled friendlyname="Technicolor TG582n"
upnp radiostation config state=disabled

So it would appear that not only is it possible to use the content sharing commands in user.ini BUT that all the services are already disabled...
oren
Newbie
Posts: 2
Registered: 14-04-2013

Re: PlusNet TG582n Network Icons

Thanks for the interest and suggestions.  I'll try editing the *.ini when I've had time to research any possible down-side.
Just for the record, as I happen to also have a "vanilla" TG582n (Software Release:8.4.4.I) as well as the PlusNet one (Software Release:8.4.4.J), I can confirm that MisterW was on the right track, if PlusNet's "wisdom" hadn't got in the way and removed the option - see attached capture of the "vanilla" tools page.
The bits from the *.ini from the "vanilla" and the "PlusNet" boxes are below - with the "vanilla" USB working as a USB file server:
[ contentsharing.ini ] "vanilla" Release:8.4.4.I
ftp config state=enabled
cifs config state=enabled workgroup=MYWORKGROUP name=TG582USB comment="USB Files"
upnp config state=enabled friendlyname="Technicolor TG582n"
upnp radiostation config state=disabled
[ contentsharing.ini ] PlusNet Release:8.4.4.J with no USB
ftp config state=disabled
cifs config state=enabled workgroup=WORKGROUP name=Technicolor comment="DSL Gateway"
upnp config state=enabled friendlyname="Technicolor TG582n"
upnp radiostation config state=disabled
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: PlusNet TG582n Network Icons

I can see I shall have to investigate this a bit Wink