cancel
Showing results for 
Search instead for 
Did you mean: 

Please help - can't connect devices to router via ethernet (wifi works fine)

mistergee
Newbie
Posts: 5
Registered: 28-04-2013

Please help - can't connect devices to router via ethernet (wifi works fine)

Hello,
My router (Thomson 585v8, provided by plusnet) has been set up correctly for many months and I've had no issue with connecting wired, ethernet devices in this time.
Recently the router plug became disconnected. So I reconnected, but I was having issues accessing the internet. After resetting the router to factory settings (via the small button in the hole) and restarting the router, I was able to connect to the internet but only with wireless devices.
Now when I try to connect something via an ethernet cable (internet-enabled TV, previously working fine), the router will not assign an IP address via DHCP. I tried setting the IP address manually on the TV network settings but still no luck. My desktop PC will not connect either, it constantly says "acquiring IP address" on connection until it times out.
Just to reiterate, everything was working fine (ethernet & wifi), now only wifi works, wired devices do not.
Thanks.
8 REPLIES
Community Veteran
Posts: 4,867
Thanks: 126
Fixes: 24
Registered: 14-07-2009

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

I would do another factory reset of the router then try again.  If wired Ethernet still does not work then your router has become faulty.
mistergee
Newbie
Posts: 5
Registered: 28-04-2013

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

I can give the factory reset another go but is there anything else I can try, configuration-wise?
Community Veteran
Posts: 1,294
Thanks: 30
Fixes: 4
Registered: 22-06-2012

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

I would report it as a fault to PN & they'll probably send you a replacement router foc.
Highlighted
mistergee
Newbie
Posts: 5
Registered: 28-04-2013

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

Thanks, but I reported the issue to plusnet and the router is out of warranty, they want £40 for a new one. Thomson kit is pretty mediocre anyway, so I just bought a new TP-Link cheaper. Would still like to try and resolve this issue while it's being delivered though, it may well be a configuration problem as I think the ethernet was ok before the factory reset.
Community Veteran
Posts: 1,294
Thanks: 30
Fixes: 4
Registered: 22-06-2012

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

Sorry, I didn't realise that it's out of warranty. I agree about the quality, I binned mine ages ago.
mistergee
Newbie
Posts: 5
Registered: 28-04-2013

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

Sorry, nevermind. One of my homeplugs packed in, coincidentally at the same time that the router plug was knocked out. I swapped my homeplugs around and I can now connect with the remaining ones. It is still probably worth upgrading the router though.
Plusnet Help Team
Plusnet Help Team
Posts: 13,482
Thanks: 246
Fixes: 68
Registered: 27-04-2007

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

FYI, I use home plugs and find that if I need to unplug one I have to reset both of them once or twice before they'll begin to work again.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
mistergee
Newbie
Posts: 5
Registered: 28-04-2013

Re: Please help - can't connect devices to router via ethernet (wifi works fine)

Cheers, yeah I tried every reset option and every combination several times but I could only ever get 2 of 3 to work so I sent it back for a replacement.