cancel
Showing results for 
Search instead for 
Did you mean: 

PCLOS file sharing problem

waldron
Grafter
Posts: 348
Registered: ‎28-07-2007

PCLOS file sharing problem

I hope someone can help me with this one. I'm fairly new to PCLOS (about one week). I've tried to join the PCLOS forum but can't get the confirmation email to activate the account, so I can't post on there.  My problem is trying to access networked Windows/NTFS files from PCLOS. All the threads on the other forum relate to the other way round - they just say that Windows to PCLOS should work "out of the box".
I have a dual boot pc running Windows/XP and PCLOS, and another running Vista (with the files I want to access). I believe the NTFS sharing is set up correctly as it works successfully between XP and Vista. PCC/Security says smb is running, and if I type smb://192.168.1.4 in the home folder I can see all the NTFS files. From Vista I can also see the PCLOS files, so the Workgroup is set up correctly.
PCC/Mount Points/Set Samba Mount Points - if I Search Services, I only get the PCLOS server shown, not the Vista one.
My Computer/Remote Places/Samba Shares shows the Workgroup, and then the two servers in the workgroup (including the Vista one). But when I double-click on the Vista server, nothing happens at first, then I get "Timeout on Server".
Obviously I am missing something, but I have no idea what.
7 REPLIES
Waldo
Grafter
Posts: 473
Registered: ‎01-08-2007

Re: PCLOS file sharing problem

Little more than a guess, but....
I think the problem may be that Vista’s default security policy is to only use NTLMv2 authentication which may not be supported by the version of samba  you're using.
Assuming you have the latest Samba from the PCLOS repositories, changing Vista's policy to use NTLM is probably the easiest option.
Community Veteran
Posts: 1,850
Registered: ‎11-08-2007

Re: PCLOS file sharing problem

do you have smb4k installed?  that, apparently, makes it easier to set up.  what user name are you using on pclinuxos.com?
waldron
Grafter
Posts: 348
Registered: ‎28-07-2007

Re: PCLOS file sharing problem

@artificer
I do have smb4k installed (v 0.9.5-1)
Thanks - I now have access to the PCLOS forum
@Waldo
I have the latest samba (v 3.0.30-3).
I am currently reconfiguring a network drive for RAID on my Vista pc, so I'm reluctant to make any changes while that is ongoing, but I'll try NTLM later.
Maybe I'm misunderstanding it, but isn't the NTLMv2 issue more where Vista can't access files on other platforms, eg Linux? My problem is the other way round. I can access all the PCLOS files from Vista.
On PCLOS, by navigating to the IP address of the Vista pc from my browser, I can see access all the NTFS files. The problem is that I can't see them in Remote Places (in Konqueror).
Community Veteran
Posts: 1,850
Registered: ‎11-08-2007

Re: PCLOS file sharing problem

good to see you over there waldron.  you could usefully copy paste post 290 from here, adding a complete spec of your hardware as that will aid people in advising you.  networking is the logical spot.  come and have a lot of fun.
waldron
Grafter
Posts: 348
Registered: ‎28-07-2007

Re: PCLOS file sharing problem

@artificer
Thanks for the welcome. I've just found what might be a relevant post over on the PCLOS forum. The thread was about a Vista problem, but seems relevant and supports Waldo's theory. I'm going to try changing from NTLMv2 to NTLM shortly. I've also changed Samba settings from CIFS to SMBFS a per the other thread.
I'll post back when I know whether or not it has worked.
waldron
Grafter
Posts: 348
Registered: ‎28-07-2007

Re: PCLOS file sharing problem

Update....
I changed NTLMv2 in the registry as per the above post.
I currently have online four 'servers' - two pcs running Vista, one running PCLOS and a network (NAS) drive, which I believe is Linux based. All are in the same workgroup.
From the Vista pcs I can access everything on all the other servers.
On the PCLOS pc - using smb4k I can see all four servers and their disks, and access files on all of them (except for one of the Vista pcs, where I haven't yet changed NTLMv2).
Using My Computer/Remote Places/Samba Shares I can see the workgroup name. But when I double click on it, it hangs for a while then gives an error message "Timeout on server".
If I type the IP address of the Vista pc in the Location bar, there is an error message "Could not connect to host 192.168.1.3".
It looks as if the problem lies between Konqueror and Samba.
Community Veteran
Posts: 1,850
Registered: ‎11-08-2007

Re: PCLOS file sharing problem

your talking gobbledygook to my ears.  i did try setting up samba back in the days when i kept a windows machine about, but i had so much hassle that it was just another nail in the coffing for xp.  once i was all linux, i set up nfs in a trice.