cancel
Showing results for 
Search instead for 
Did you mean: 

OpenWRT /etc/config/network file

geforce
Dabbler
Posts: 13
Registered: 30-10-2013

OpenWRT /etc/config/network file

I'm using a custom openwrt rom that doesn't have the allow me to set a username for the connection setting. I need to place this into /etc/config/network manually. I've got the following so far but I know it's not right, I've searched the forum and can't find similar settings. Any ideas?
config 'interface' 'loopback'
       option 'ifname' 'lo'
       option 'proto' 'static'
       option 'ipaddr' '127.0.0.1'
       option 'netmask' '255.0.0.0'
config 'interface' 'lan'
       option 'ifname' 'eth0.1'
       option 'type' 'bridge'
       option 'proto' 'static'
       option 'netmask' '255.255.255.0'
       option 'ipaddr' '192.168.1.1'
config 'interface' 'wan'
       option 'ifname' 'eth1 ppoe-wan'
       option 'proto' 'ppoe'        
       option 'type' 'bridge'                    
       option 'username' 'username@plusdsl.net'
       option 'auto' '1'
       option '_orig_ifname' 'br-wan'
       option '_orig_bridge' 'true'
       option 'ifname' 'eth1 ppoe-wan'
config 'switch'                
       option 'name' 'rtl8366s'
       option 'reset' '1'        
       option 'enable_vlan' '1'
       option 'blinkrate' '2'    
                                 
config 'switch_vlan'              
       option 'device' 'rtl8366s'
       option 'vlan' '1'          
       option 'ports' '0 1 2 3 5t'
                                 
config 'switch_port'              
       option 'device' 'rtl8366s'
       option 'port' '1'
       option 'led' '6'
                                 
config 'switch_port'              
       option 'device' 'rtl8366s'
       option 'port' '2'
       option 'led' '9'
9 REPLIES
Community Veteran
Posts: 6,395
Thanks: 511
Fixes: 46
Registered: 30-07-2007

Re: OpenWRT /etc/config/network file

The settings are described here http://www.plus.net/support/broadband/hardware/broadband-connection-settings.shtml . You will need to configure with both username and password.
geforce
Dabbler
Posts: 13
Registered: 30-10-2013

Re: OpenWRT /etc/config/network file

According to the Fibre Settings (http://www.plus.net/support/broadband/hardware/broadband-connection-settings.shtml#fibreConnectionSettings) I don't. Just says username and PPOE Always on.
adie:quote
Community Veteran
Posts: 6,395
Thanks: 511
Fixes: 46
Registered: 30-07-2007

Re: OpenWRT /etc/config/network file

I know it doesn't say you need a password BUT you do, I can assure you!. What the connection settings Help  is really saying is that Fibre is PPPoE whereas ADSL is PPPoA
Community Veteran
Posts: 1,136
Thanks: 2
Registered: 30-07-2007

Re: OpenWRT /etc/config/network file

From the OpenWRT wiki:
The package ppp-mod-pppoe must be installed to use PPPoE.
Check you've got that installed?
Also
Quote
option 'proto' 'ppoe'
should probably be  
option 'proto' 'pppoe' 
F9 member since 4 Sep 1999
F9 ADSL customer since 27 Aug 2004
DLM manages your line the same way DRM manages your rights.
Look at all the pretty graphs! (now with uptime logging!)
geforce
Dabbler
Posts: 13
Registered: 30-10-2013

Re: OpenWRT /etc/config/network file

Thanks guys, I will try this out.
Does anyone have a similar entry that I could copy verbatim just in case?
geforce
Dabbler
Posts: 13
Registered: 30-10-2013

Re: OpenWRT /etc/config/network file

Quote from: avatastic
From the OpenWRT wiki:
The package ppp-mod-pppoe must be installed to use PPPoE.
Check you've got that installed?
Also
Quote
option 'proto' 'ppoe'
should probably be  
option 'proto' 'pppoe' 


Other than that - do you think the file looks correct?
Community Veteran
Posts: 6,395
Thanks: 511
Fixes: 46
Registered: 30-07-2007

Re: OpenWRT /etc/config/network file

geforce
Dabbler
Posts: 13
Registered: 30-10-2013

Re: OpenWRT /etc/config/network file

ppp-mod-pppoe is definitely installed, here's my config - it's still not working unfortunately. Any ideas?
config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'
config 'interface' 'lan'
option 'ifname' 'eth0.1'
option 'type' 'bridge'
option 'proto' 'static'
option 'gateway' '192.168.1.254'
option 'broadcast' '192.168.1.255'
option 'ipaddr' '192.168.1.254'
option 'dns' '8.8.8.8'
option 'netmask' '255.255.255.0'
config 'interface' 'wan'
option 'type' 'bridge'
option 'proto' 'pppoe'
option 'username' 'myusernname@plusdsl.net'
option 'password' 'xxxxxxxxx'
option 'auto' '1'
option '_orig_ifname' 'br-wan'
option '_orig_bridge' 'true'
option 'ifname' 'eth1 pppoe-wan'
config 'switch'
option 'name' 'rtl8366s'
option 'reset' '1'
option 'enable_vlan' '1'
option 'blinkrate' '2'
config 'switch_vlan'
option 'device' 'rtl8366s'
option 'vlan' '1'
option 'ports' '0 1 2 3 5t'
config 'switch_port'
option 'device' 'rtl8366s'
option 'port' '1'
option 'led' '6'
config 'switch_port'
option 'device' 'rtl8366s'
option 'port' '2'
option 'led' '9'
config 'switch_port'
option 'device' 'rtl8366s'
option 'port' '5'
option 'led' '2'
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: 26-11-2012

Re: OpenWRT /etc/config/network file

This is the file from my router running Gargoyle
I think the issue may be that you're putting single quotes around the parameter as well as the value?  Also you're setting the WAN to 'bridge'?

config interface 'loopback'
       option ifname 'lo'
       option proto 'static'
       option ipaddr '127.0.0.1'
       option netmask '255.0.0.0'
config interface 'lan'
       option ifname 'eth0.1'
       option type 'bridge'
       option proto 'static'
       option netmask '255.255.255.0'
       option ipaddr '192.168.5.254'
       option dns '208.67.222.123 208.67.220.123'
config interface 'wan'
       option ifname 'eth0.2'
       option peerdns '0'
       option proto 'pppoe'
       option username 'xxxxxxxxxxx@plusdsl.net'
       option password 'xxxxxxxxxxx'
       option keepalive '3 5'
       option dns '208.67.222.123 208.67.220.123'