cancel
Showing results for 
Search instead for 
Did you mean: 

Oh no, what have I done, speeds terrible!

BurntToast
Grafter
Posts: 32
Registered: 18-02-2015

Oh no, what have I done, speeds terrible!

I've only just joined Plusnet.  Earlier today speed of 14mb which was fine.  Now, it's 0.5 and I can't do anything.  Pages take ages to show, no chance of using iplayer or youtube.  It's just useless.  I know they say to wait ten days but why would the speed change so radically?  I can't do this for a whole year's contract.
4 REPLIES
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: Oh no, what have I done, speeds terrible!

Please post the information requested here http://community.plus.net/forum/index.php/topic,96155.0.html preferably wired and not wireless
Plusnet Help Team
Plusnet Help Team
Posts: 5,445
Thanks: 505
Fixes: 190
Registered: 01-01-2012

Re: Oh no, what have I done, speeds terrible!

Your line is testing fine and I can't see any issues.
You should be getting speeds around 16 to 17mbps.
Are you connecting over a wired or wireless connection?
If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
BurntToast
Grafter
Posts: 32
Registered: 18-02-2015

Re: Oh no, what have I done, speeds terrible!

I know.  It was fine this morning when I tested it.  Last night it was awful.  Hopefully just a blip and not going to be terrible every evening.  Will see.  Am now at work so can't do anything more until tonight.  Thank  you.
Plusnet Help Team
Plusnet Help Team
Posts: 1,897
Thanks: 12
Fixes: 2
Registered: 24-07-2014

Re: Oh no, what have I done, speeds terrible!

Please keep an eye on it and let us know if we can assist further.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team