cancel
Showing results for 
Search instead for 
Did you mean: 

Not recieving any outside mail since the Postini 'Update'

TheChallenger
Grafter
Posts: 41
Registered: ‎05-10-2007

Not recieving any outside mail since the Postini 'Update'

Quote
Incoming Email Problems (49477) - RESOLVED
This is an update to the previously reported problem resulting in email sent to PlusNet customers being rejected with a 554 server error. A copy of the original announcement can be seen here:-


If resolved means you won't get any email at all, then this is an interesting definition of resolved.
I am here out of desparation to get this resolved.
Cry It seems to have got worse every time the support team do something, and they haven't let me know what they are doing.
Since I updated support of the differences between mydomain.co.uk and username.plus.com I've now lost all incoming mail to both, the only mail I can recieve is from plusnet users..... where the mail is obviously routed internally, anything from outside isn't getting in.
It's only a few months since the srew up over RDNS when I also lost all my incoming emails.
Any ideas anyone?
40 REPLIES
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Not recieving any outside mail since the Postini 'Update'

Hi there,
I've had a look at your mail records and your domain appears to point to an SMTP server which means none of the mail should be going through postini. I think I can see the issues with the username.plus.com address:
mjtaylor@pvs-csctools:~$ dig mx username.plus.com
; <<>> DiG 9.2.4 <<>> mx username.plus.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3540
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 6
;; QUESTION SECTION:
;username.plus.com.              IN      MX
;; ANSWER SECTION:
username.plus.com.        86400  IN      MX      10 mx-postini.core.plus.net.
username.plus.com.        86400  IN      MX      20 mx-postini.last.plus.net.
;; AUTHORITY SECTION:
plus.com.              33128  IN      NS      ns2.force9.net.
plus.com.              33128  IN      NS      ns1.force9.net.
;; ADDITIONAL SECTION:
mx-postini.core.plus.net. 1401  IN      A      64.18.4.13
mx-postini.core.plus.net. 1401  IN      A      64.18.4.14
mx-postini.core.plus.net. 1401  IN      A      64.18.4.10
mx-postini.core.plus.net. 1401  IN      A      64.18.4.11
ns1.force9.net.        33155  IN      A      195.166.128.16
ns2.force9.net.        33651  IN      A      195.166.128.17
;; Query time: 17 msec
;; SERVER: 212.159.6.9#53(212.159.6.9)
;; WHEN: Sun Jan 20 16:48:55 2008
;; MSG SIZE  rcvd: 244

The above was taken from our own DNS server at 212.159.6.9. Conversely:
orbrey@loudmouthharry:~$ dig mx username.plus.com
; <<>> DiG 9.4.1-P1 <<>> mx username.plus.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8154
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
;; QUESTION SECTION:
;;username.plus.com.              IN      MX
;; ANSWER SECTION:
username.plus.com.        86400  IN      MX      20 mx.last.plus.net.
username.plus.com.        86400  IN      MX      10 mx.core.plus.net.
;; ADDITIONAL SECTION:
mx.core.plus.net.      48610  IN      A      84.92.2.1
mx.last.plus.net.      247    IN      A      212.159.11.64
;; Query time: 164 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Sun Jan 20 16:47:38 2008
;; MSG SIZE  rcvd: 121

was taken from an external connection so there's a conflict there that might be causing the issue. I'd expect this to change when the DNS changes propagate, though I'm currently trying to confirm that everything on your account has been added correctly to the postini trial.
I'll post back when I've any more information, sorry about the hassle.
TheChallenger
Grafter
Posts: 41
Registered: ‎05-10-2007

Re: Not recieving any outside mail since the Postini 'Update'

Matt,
Many thanks for the response, it's been difficult to get anyone to acknowledge there was a problem. Your diligence is appreciated.
For your info, mydomain.co.uk is : "edited out by the challenger ", perhaps a check on that will reveal similar challenges.
Gordon
ChrisL
Grafter
Posts: 734
Thanks: 4
Registered: ‎13-12-2007

Re: Not recieving any outside mail since the Postini 'Update'

Gordon, I'd get that id information off the public forum if I were you....  You can send a personal message to orbrey using the button under his avatar.
TheChallenger
Grafter
Posts: 41
Registered: ‎05-10-2007

Re: Not recieving any outside mail since the Postini 'Update'

Thx Chris,
Appreciate the concern, I think Orbrey's changed it so it's just generic stuff so others can see the problem.
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Not recieving any outside mail since the Postini 'Update'

Oops - sorry, thought I'd dropped a reply in here to say I'd removed the offending bits. Sorry about that, and thanks for the heads up.
TheChallenger, our network guys will be looking into this tomorrow morning when they get into the office.
Hope that helps,
mikeb
Grafter
Posts: 367
Registered: ‎10-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Quote from: orbrey
... was taken from an external connection so there's a conflict there that might be causing the issue. I'd expect this to change when the DNS changes propagate ....

There is just as much 'conflict' between the authoritative DNS servers and caches so it's hardly surprising that external DNS is like that.
212.159.6.9, 212.159.13.50, 195.166.128.16, 212.159.13.150 have new records (*)
212.159.6.10, 212.159.13.49, 195.166.128.17, 212.159.11.150 have old records
(*) for the now deleted username.plus.com
I've just sent a couple of innocent and very obvious Test Messages (so please don't report me a a spamer, abuser or potential hacker as I'm only trying to help !) and:
postini: Accepts the message without errors or rejection.
mx-core: Accepts the message without errors or rejection.
So the big question Mr.TheChallenger is have you just got a couple of Test Messages from me ?  They were addressed to testmessage@username.plus.com BTW in case you automatically blackhole anything other than specific named mailboxes.
I was kinda expecting one or other server to reject them but apparently not although external mail will (should !) pretty randomly be coming in via either route of course depending which MX records get picked up.
TheChallenger
Grafter
Posts: 41
Registered: ‎05-10-2007

Re: Not recieving any outside mail since the Postini 'Update'

Quote
So the big question Mr.TheChallenger is have you just got a couple of Test Messages from me ?
They were addressed to testmessage@username.plus.com BTW

They will have been blackholed, use bill@username.plus.com that will do the long route! and I'll reply with the email header in the message.
thx
mikeb
Grafter
Posts: 367
Registered: ‎10-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Both messages resent and were accepted by the servers again. I also note that someone's been tweaking the DNS as they all seem to have the old (non-postini) entries now.
mikeb
Grafter
Posts: 367
Registered: ‎10-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Interesting. I have a reply from you to the SECOND Test Message but not the FIRST. 
So, assuming that you didn't get the FIRST Test Message (and I very much doubt that you did), the bad news is that mail to postini is simply being eaten because I have no rejection and you have no message. Anyone trying to send you mail who just so happened to pick up the postini MX record would have experienced exactly the same.
The good news is that mail bypassing postini is getting through and as the authoritative DNS appears at least to have consistent records pointing to mx-core now, all mail should be getting through.  However, there is a possibility that some cached MX records still contain the postini info so you could expect to see a few problems until the DNS changes propagate - for around 24 hours or so after the last change so up until this evening or thereabouts.
I'm pretty sure I can see exactly what the problem is here but I need to think a little bit more about it first. Watch this space ! But at least mail should be getting through just so long as it's sent via mx-core and NOT via postini Smiley
mikeb
Grafter
Posts: 367
Registered: ‎10-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Right then, I guessed yesterday that this was quite probably the reason for your problems and I'm pretty d@mn sure that it is now but I don't think you're going to like it one little bit ! It's because you're redirecting mail from PN to elsewhere and back again.  Mail CANNOT pass through postini twice so when it hits postini for the second time it is lost Sad 
It should actually be rejected but some servers don't always pass that rejection back to the original sender of course.  I believe that the rejection would have been a #451 "temporary local problem please try again later" but it wasn't ever passed back to me. It wouldn't have made any significant difference if it had been mind you because after 'n' attempts and getting the same error, the server would have given up in any case. The end result is that (some, maybe most if not all) senders will believe that their message has been accepted and delivered when it's actually been dumped.
Mail sent via mx-core has a routing something like this:
[source] -> [PN] -> [3rd party] -> [postini] -> [PN] -> [username]
but mail sent via postini would have a routing something like this:
[source] -> [postini] -> [PN] -> [3rd party] -> [postini] -> [PN] -> [username]
and that simply CANNOT ever work because it attempts to pass the same message through postini twice.
I'm not sure what (if anything) you can do about it though because it's yet another 'feature' of postini that customers haven't been made aware of. postini apparently eats messages that have passed through it more than once - it's just another example of postini taking 'the easy option' by making a rash and uninformed decision rather than establishing if it is in fact the 'right' decision.
I may be wrong here but I wouldn't expect any solution to the problem that doesn't involve you from stopping using your 3rd party processing or not using postini at all.
Community Gaffer
Community Gaffer
Posts: 13,477
Thanks: 1,197
Fixes: 95
Registered: ‎04-04-2007

Re: Not recieving any outside mail since the Postini 'Update'

Quote from: mikeb
Right then, I guessed yesterday that this was quite probably the reason for your problems and I'm pretty d@mn sure that it is now but I don't think you're going to like it one little bit ! It's because you're redirecting mail from PN to elsewhere and back again.  Mail CANNOT pass through postini twice so when it hits postini for the second time it is lost Sad 

Absolutely spot on Mike however I suspect the server response would be a 571. The Challenger has redirects set up that are forwarding messages here. They are then getting sent back through the loop which I don't suspect Postini likes.
@Challenger, we've removed you from the Postini system for the time being which is why Mike has noticed the change in your DNS records. The hosted domain on your account hasn't changed back yet though. I'll try and force this to happen in the next hour or two after which all your mail should be getting through again.
Have you got the headers from an email you received before you were moved to Postini? We might then be able to do something so the system can work with the other third party scanning you have in place.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

mikeb
Grafter
Posts: 367
Registered: ‎10-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Quote from: Bob
... however I suspect the server response would be a 571.

Nope, results from one of my tests ages ago resulted in a #451 "temporary local problem - please try again" and although that particular test wasn't quite the same scenario as for Mr.TheChallenger, I think I would expect the same result somehow.  #571 is a refusal and should have resulted in an immediate bounce not a delay eventually (maybe) followed by a bounce.
Either way, going round the loop twice is a big no-no unless postini learns to do a more thorough and accurate job when testing incoming messages in general. Some form of whitelisting of Mr.3rd_Party might possibly help in that respect but the backdoor it creates is significant and rather defeats the object of using the 3rd party ! ... although there may well be other solutions of course so over to you guys Smiley
Community Veteran
Posts: 3,789
Registered: ‎08-06-2007

Re: Not recieving any outside mail since the Postini 'Update'

Actually, I have to agree with mikeb here - looping a mail back into postini results in:
Delay reason: SMTP error from remote mailer after end of data:
    host ob.fusc.ated.s5b2.psmtp.com [64.18.4.14]:
    451 Temporary local problem - please try later
These are retried for at least 48 hours, depending on the outgoing relay (in my case ptb-relay01.plus.net)
The end user isn't likely to get a 'bounce' until the first retry period is exceeded - again this is a relay-host setting and not configurable by the end user.  However, I would expect them to eventually get an NDR.
I discovered this when trying to discover what happens when you send a mail through postini that already has postini headers in - I inadvertantly copied in a duplicate message-id to an outbound mail.
In "normal" circumstances passing a message through Postini twice wouldn't happen, but obviously this special case has highlighted that there is an issue.
I do think it's worthwhile investigating whether Postini are able to justify this behaviour.  IMHO, I can't think of any offhand reason why a second pass through Postini is rejected?
B.
Community Veteran
Posts: 26,720
Thanks: 934
Fixes: 10
Registered: ‎10-04-2007

Re: Not recieving any outside mail since the Postini 'Update'

Does that mean that you can't set up a redirect in Manage My Mail to forward a particular email address to another PN user account?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)