cancel
Showing results for 
Search instead for 
Did you mean: 

No connectivity after a house-move; no response from Customer Service

MarkusLaker
Newbie
Posts: 1
Registered: 21-12-2015

No connectivity after a house-move; no response from Customer Service

I phoned Plusnet on 5th December to tell them about a house-move on the 17th December.  I had to wait an hour and ten minutes on hold before speaking to a human being.
So the 17th came... and the 18th came... and we still had no connection to the Internet.  I phoned Plusnet on Friday evening and spent two hours on hold before finally giving up.  I added a comment to the question that they'd opened for the house-move, on Friday evening, saying that I had no connectivity, and added a further comment on Saturday morning.  It's now Monday afternoon, and Plusnet still hasn't bothered to respond.  I can't reach them by email, because they don't have a support email address.  I can't reach them by phone, because they don't answer.  I can't reach them by commenting on an open question, because they ignore it.
How the hell do I stir Plusnet into action and get the Internet connectivity that they're charging me for?
The most galling thing is that, in order to complete the house move without paying a lump sum, I had to renew my contract with them.  Even though they're not providing me with any service whatsoever, if I move to another ISP, they'll expect a payment of £50 for early termination of contract.  It might be worth paying £50 just to be rid of Plusnet.  I miss the old days of Force9!
1 REPLY
Community Gaffer
Community Gaffer
Posts: 17,665
Thanks: 658
Fixes: 162
Registered: 05-04-2007

Re: No connectivity after a house-move; no response from Customer Service

Sorry for the lack of responses you've received. I've taken a look over your account and can see that when we tested broadband it was indicating a fault on the phone service, which would need resolving by the phone provider rather than ourselves. It does also look as though you've been able to connect this morning.
If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff