Showing results for 
Search instead for 
Did you mean: 

New Account Activated But No Internet On Any Device

Posts: 1
Registered: ‎08-06-2021

New Account Activated But No Internet On Any Device

Hi everyone, hope you're all in good health.


My new fibre connection was activated yesterday however I have no internet connection on any device. On both my mobile and laptop in wi-fi settings I am being told that sign in is required and, clicking on that link will only take me to the router admin page. (I did originally login to the wi-fi using the required password on both devices) I have tried the usual troublshooting stuf like turning on/off devices and router as well as resetting the Hub2 router. I am also plugged into the master socket with the front cover removed but I still end on the router admin page and can't connect anything to the internet. My TV shows as connected as well however if I try to connect to, say Youtube, I get a notification saying "No Internet". The Hub2 is displaying blue lights and I'm beginning to wonder if the issue is with my devices.

Incidentally, i've also noticed that when I try to connect to wi-fi on my phone it connects to next doors B/Band and that has a much weaker signal.

It's probably human error (mine) but can anyone tell me how to solve this please, I am extremely grateful for any input.


Thanks and regards


Posts: 11,114
Thanks: 4,905
Fixes: 398
Registered: ‎30-06-2016

Re: New Account Activated But No Internet On Any Device

@stevepeet  Welcome to the community forum.

The first thing to try is a factory reset of the Hub push a paperclip or similar in the reset hole in the back. Keep the switch closed until you get a green light.

If that doesn't work:

1. Log in to the Hub by opening a web browser and type in to the address field (not the search bar if you have a separate one). This should give you access to the hub.

2. Select Status

3. See if this says Disconnected. If so select it and see if it will connect.

4. If it says Connected select it to Disconnect. When it is Disconnected select Home then Advanced Settings.

5. Select Broadband. You will then be asked for the Admin password, which you will find on the pull out tab on the side of the Hub.

6. Check that the Broadband name is your account name in the form <accountname> If its <setup> then it hasn't auto configured

7. If it's not configured then insert your account name in place of setup. Enter your account password in the next box. Select save.

8. Return to the Status page.

9. Select Disconnected and see if it will change to connected.

10. If that doesn't work then report a fault. See

To connect your phone you need to go to the phone available wireless networks setting, select the Hub 2 SSID then enter the wireless password. Both bits of information are again on the pull out tab.


Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Plusnet Help Team
Plusnet Help Team
Posts: 16,776
Thanks: 853
Fixes: 217
Registered: ‎27-04-2007

Re: New Account Activated But No Internet On Any Device

Hi there Stevepeet, I'm really sorry about the poor start with us, I've checked your account and can see an engineer is due to visit tomorrow so I hope it's all sorted then for you.

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team