cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with content sharing ip address on TG582n

lotrjw
Grafter
Posts: 64
Registered: ‎11-09-2013

Issue with content sharing ip address on TG582n

My issue is the IP address is stuck at 192.168.56.103 and the rest of my network uses 192.168.255.0-255.
I just upgraded the routers firmware to the latest and before it was being dynamically assigned something like 192.168.255.248
Is there any way to change it whether in the web interface or via telnet? I would like to give it a static IP if possible as thats what I do with all other PCs and devices on my network.
42 REPLIES
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Issue with content sharing ip address on TG582n

Hi there,
Could be the lease was cached on either the router and PC (or both). Either way, deleting the lease from the router then disconnecting the PC then rebooting and reconnecting should help?
nanotm
Pro
Posts: 5,724
Thanks: 122
Fixes: 2
Registered: ‎11-02-2013

Re: Issue with content sharing ip address on TG582n

lotrjw
couldn't you set the routers ip range to be giving out 1 or 2 addresses then set all your devices above it, I have mine set so the router dhcp range is 192.168.1.100~192.168.1.101 and then manually give each item an ip above that (which makes the firewall rules easier to manage)
iirc so long as the static ip's are above the dynamic ones they are fully visible on the network and certainly homegroups work
I know it takes some doing as you need ot go to each device and manually configure it in settings but it makes things easier in the long run
just because your paranoid doesn't mean they aren't out to get you
Dan_the_Van
Rising Star
Posts: 330
Thanks: 8
Fixes: 1
Registered: ‎25-06-2007

Re: Issue with content sharing ip address on TG582n

It is possible to make a device to use the same IP address via the GUI
Home Network >Device> {select the required device} > Configure. You should see an option "Always use the same IP address:" make this Yes.
This saves you visiting every device on the network to configure the IP address details
If you want to setup static addresses on each device just use any IP address from 192.168.1.1 to 192.168.1.63, this way you do not need to reconfigure your router.
Hope this helps
Dan
nanotm
Pro
Posts: 5,724
Thanks: 122
Fixes: 2
Registered: ‎11-02-2013

Re: Issue with content sharing ip address on TG582n

@dan are they still visible to each other as a network when below the ip range ? i have to say i used the tg582 for less than a week, it kept crashing when one of the kids used a tablet so its been sitting in a cupboard ever since, the idea behind setting the static ip on each device is so you don't have all the messing about on the router so each time a tr069 update comes down the pipe everything still works (when i was with bt and using a home hub they always reset the sodding thing to factory settings every 2nd Friday as it checked for updates) 
i was just thinking that whilst its a bit of messing about to start off with it makes things a lot easier in the long run.
as for forcing the ip to reset its a lot easier than all that messing about, on the pc open the network adaptor properites page, in the middle where it shows all the tick boxes highlight ipv4 then click properties, change the radial from automatic to "use following ip" and type in the desired ip
click ok and bingo its changed, after the adaptor is restarted check its got the right ip assigned, and no more worries about it
just because your paranoid doesn't mean they aren't out to get you
Dan_the_Van
Rising Star
Posts: 330
Thanks: 8
Fixes: 1
Registered: ‎25-06-2007

Re: Issue with content sharing ip address on TG582n

The network address for the router is 192.168.1.0/24, that gives a IP address range 192.168.1.1 to 192.168.1.254. So any IP address in that range can use the default gateway address of 192.168.1.254 to access the Internet.
I've not heard of the issues you describe  with regular factory defaulting of the router with Plus Net. I recommend making a backup of the router configuration as a precaution, this way I can restore my preferred options including the static IP addresses I assigned via the GUI.
Dan.
lotrjw
Grafter
Posts: 64
Registered: ‎11-09-2013

Re: Issue with content sharing ip address on TG582n

Thanks for the replies, I have been using static IPs ever since I set up a windows server last year. Im sure some of you will know that a windows server requires static IPs on devices connected to it to work properly. Also I have a BTEC level 3 in IT so I know my networking stuff.
It just an issue with this router, that the content sharing has stuck on that particular IPHuh
I tried to see if any settings in the telnet interface could change the IP address for content sharing, but it looked like no joy.
Is the content sharing only assignable by the DHCP on this router?
I set up the DHCP on the tg582n as follows:
Assignable IP range 192.168.255.199-192.168.255.248
Subnet 255.255.255.0
Gateway 192.168.255.254
DNS 1: 192.168.255.2 (my windows server)
DNS 2: 8.8.8.8 (backup DNS)
WINS 192.168.255.2
Most other devices are static IPs as, like I said, its needed for the Windows server to work, with the only devices assigned IPs but the DHCP are guest equipment ect, I even set my phones up with static IPs so I know whats what!
When I was using my last router (Thompson TG585 vCool, I had things set up exactly the same and Ive had no issues, but that router didnt have content sharing ether!
I guess this is partly as the kit is cheap.
nanotm
Pro
Posts: 5,724
Thanks: 122
Fixes: 2
Registered: ‎11-02-2013

Re: Issue with content sharing ip address on TG582n

if your running whs then why not disable dhcp in the router hand have the server handle that ?

as for the stuck ip address, the only way to release it without unplugging all connected devices and powering them down for 20 mins (including any switches ) is to manually assign an ip address via the ipv4 protocol properties + set a dns server (8.8.8.8, backup 4.4.4.4 ) click ok, let it restart the adaptor then re open properties and change back to auto for both ip + dns entries click ok + let it restart, it will then acquire the correct ip you assigned in the router ....well maybe not if you have more than 8 devices because like most cheap low end routers here not designed to handle that many devices.... so your still better off assigning dhcp via a server (well so long as the server has a dual nic and uses 2 lan slots on the router) otherwise you need to lookinto a decent so-ho router that's designed to handle the number of devices you have.
just because your paranoid doesn't mean they aren't out to get you
lotrjw
Grafter
Posts: 64
Registered: ‎11-09-2013

Re: Issue with content sharing ip address on TG582n

Thanks, I didnt think about setting the DHCP via my Windows server, like I said in the other thread though I will sort it tomorrow.
Also its not home server its actually server 2008r2! But that really shouldnt make too much difference to the networking issues! Wink
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Issue with content sharing ip address on TG582n

I thought the content sharing IP could be edited from the same config page as the DHCP groups are on? Is that not working?
lotrjw
Grafter
Posts: 64
Registered: ‎11-09-2013

Re: Issue with content sharing ip address on TG582n

the router has stopped working I called up and a replacement is on its way @nanotm thanks for the idea of using DHCP on my server its a much better DHCP server than what these routers have! Im thinking about getting my own router as Im fed up with tech thats not working today! (my new phone isnt working ether!) Oh and before the phone stopped working its wifi IP on my network was stuck on 192.168.56.101! strange how that ended up on the same subnet! I really cant get my head around it as I dont use the subnet 192.163.56.0-192.168.56.255!
Matt as Im now using my Windows server for DHCP, will the content sharing on the new router (when it arrives), pick up a lease from my DHCP, as IM guessing it would?
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: ‎18-07-2007

Re: Issue with content sharing ip address on TG582n

Good question. It's not something I've ever done so couldn't tell you, but it certainly should do - I'll check with hardware guru Matt when he gets in.
Superuser
Superuser
Posts: 6,807
Thanks: 873
Fixes: 56
Registered: ‎30-07-2007

Re: Issue with content sharing ip address on TG582n

Quote
Matt as Im now using my Windows server for DHCP, will the content sharing on the new router (when it arrives), pick up a lease from my DHCP, as IM guessing it would?
I've got a TG582n which I use as a Wireless access point, so it's got DHCP disabled. It does seem to pick up the content sharing IP from the primary DHCP server. I've only ever tried to use it for printer sharing and failed I'm afaid. Whether that is due to an IP problem or not I wasn't sure and haven't had time to investigate further yet...
nanotm
Pro
Posts: 5,724
Thanks: 122
Fixes: 2
Registered: ‎11-02-2013

Re: Issue with content sharing ip address on TG582n

no,
you have to disable DHCP in the router (its a check box) or you will effectively have two servers competing against each other to offer a connection and nothing will work ....
just because your paranoid doesn't mean they aren't out to get you
Superuser
Superuser
Posts: 6,807
Thanks: 873
Fixes: 56
Registered: ‎30-07-2007

Re: Issue with content sharing ip address on TG582n

@natotm, Was that addressed at my post ?
Quote
I've got a TG582n which I use as a Wireless access point, so it's got DHCP disabled