cancel
Showing results for 
Search instead for 
Did you mean: 

How to Delay re-Synchronisation on a TG582N

EnglishMohican
Aspiring Pro
Posts: 306
Thanks: 48
Fixes: 1
Registered: 08-04-2009

How to Delay re-Synchronisation on a TG582N

Twice a day at about 17:00 and again at say 21:00, there is a sharp burst of noise on my telephone line (broadband noise, not audible noise) that lasts about 4 minutes. If my TG582N is running at 6db noise margin, then the noise is enough to make it lose synchronisation. It then proceeds to reconnect within lets say a minute of losing sync, while the noise is still present, at what it considers to be 6db noise margin. However, this means that it reconnects at 4Mbps rather than 6Mbps. A few minutes later, the noise disappears so the SNR increases to 11 db but the TG582 has no way of responding to that so continues to run at 4Mbps.
The noise does not come from my house, I know when things turn off or on here, it is probably a television or somesuch in one of the neighbours properties but there are a lot of them, some friendly, some not, it is daily but not always at the same time and does not last long enough to track down without very special equipment so I doubt that it is worth getting Openreach involved.
What I would like to do is to persuade the TG582 to wait a bit longer before it re-synchronises. If it waited say 5 minutes, then I would be without a connection for those 5 minutes but when it did reconnect the noise would have disappeared and it would reconnect at 6Mbps. So i would have a better connection for 23 hours and 50 minutes each day at the cost of 10 minutes off the air. I would consider that to be a better bargain than at present (probably!) I can do it manually (restart the TG582N after it has resynched) but that is a Pain.
Does anybody know a way to persuade the TG582N not to try to re-synchronise quite so quickly? (Telnet command to change a setting?)
Alternatively, is there a way to tell the TG582N to reconnect at 7db noise margin rather than 6db in which case, it would struggle during the noise burst but probably not lose synch and I would permanently have maybe 5.7Mbps which would be not too bad. (I would have to reconnect it at 7db when there was no noise present of course).
Yes, I know the noise might get worse and the basis for this idea might collapse but it also might not Smiley
18 REPLIES
198kHz
Seasoned Pro
Posts: 3,241
Thanks: 271
Fixes: 7
Registered: 30-07-2008

Re: How to Delay re-Synchronisation on a TG582N

IF your line is one of those that is significantly noisier during the hours of darkness -
- and you manually re-synced at about 1 or 2am, maybe it would be running at around 7dB or more during the day? 
Not young enough to know everything
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: How to Delay re-Synchronisation on a TG582N

I have a fibre connection so can not test this:
The following telnet command may just do what you ask, it's listed as "freeze showtime (no auto retrain)"
xdsl qual freeze-showtime state=enabled
The command to resync after you think the noise has gone:
system reboot
Command to disable freeze-showtime - return to default:
xdsl qual freeze-showtime state=disabled
Please let us know the result if you try it.

EnglishMohican
Aspiring Pro
Posts: 306
Thanks: 48
Fixes: 1
Registered: 08-04-2009

Re: How to Delay re-Synchronisation on a TG582N

Thank you both.
I am afraid I have a line that is really pretty good most of the time (given its length). So if anything, the margin is higher during the night than during the day. I might try the principle of restarting when the noise is just a little higher if I can identify a suitable time though. I do have some Routerstats plots so I might find a suitable time with any luck.
I will also try the command npr suggests but I will do it tomorrow when my brains are at their best! Yes, I will let you know what happens, though from your description it looks as if I need to intervene to set the system re-synching again while I had hoped for one that timed an interval and then set itself going.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: How to Delay re-Synchronisation on a TG582N

Yes you will need to intervene to set the restart.
You could restart by running a telnet script from the PC's desk top
Info on telnet scripting:
http://npr.me.uk/scripting.html
Community Veteran
Posts: 26,551
Thanks: 797
Fixes: 9
Registered: 10-04-2007

Re: How to Delay re-Synchronisation on a TG582N

Quote from: EnglishMohican
I am afraid I have a line that is really pretty good most of the time (given its length). So if anything, the margin is higher during the night than during the day. I might try the principle of restarting when the noise is just a little higher if I can identify a suitable time though. I do have some Routerstats plots so I might find a suitable time with any luck.

You've got that the wrong way round. You need to resync when the noise margin is at it's lowest. It will resync at 6db with a lower sync speed and during the day it will rise above 6db.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 26,551
Thanks: 797
Fixes: 9
Registered: 10-04-2007

Re: How to Delay re-Synchronisation on a TG582N

As you are running RouterStats here's another tip:
In the RouterStats directory create the following two script files with the commands shown:
Drop PPP and Sync.sh
ppp ifdetach intf=Internet
xdsl config status=down
Raise Sync and PPP.sh
xdsl config status=up
ppp ifattach intf=Internet
When you want to force a resync, instead of rebooting the router, go in to RouterStats. On the Summary tab at the top right you'll find a button with an icon looking like a piece of paper with a red arrow pointing right. That lets you run the scripts. It's a lot cleaner and a lot quicker than rebooting the router.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
EnglishMohican
Aspiring Pro
Posts: 306
Thanks: 48
Fixes: 1
Registered: 08-04-2009

Re: How to Delay re-Synchronisation on a TG582N

Well, I spent a happy couple of hours playing round with npr's scripts last night. Eventually I got them working - it took time mostly because I managed to get an extra LF or CR in there despite the warnings.The get info script works very nicely and the concept might allow me to run a tiny alternative to routerstats on my NAS system (Linux on ARM so not a trivial job) which  has long been an objective of mine.
I have now issued the freeze-showtime command and await some line noise to see what effect it has. Two comments immediately:- the qual sub-command does not appear in the menu structure on my TG582N or not where you would expect it at any rate but typing the command in at the command prompt does produce a sensible response. I also think that giving that command causes the modem to resync which I was not expecting. I will confirm that when I have issued the command a few times and can be sure about it. I will report back further as events unfold.
Thank you jelv for the routerstats scripts. I will try those out as well. While routerstats is running they could be handy. So far I have been restarting the router each time from the web interface and it takes ages so any improvement in getting a resync is welcome.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: How to Delay re-Synchronisation on a TG582N

Glad you enjoyed the scripts  Cheesy
If the "freeze-showtime" commands doesn't work out I'm sure you could do what you need with a batch file and telnet script. -- just need loads of time to get it worked out.
"freeze-showtime is a hidden command, doesn't show in technicolors documents.
Have a look at the references at the bottom of my telnet web page.
Or download the Modem-Help version of the  cli reference for the TG582n from here.
Shows all the hidden commands.
http://download.modem-help.co.uk/mfcs-A/Alcatel/Modems/TG582n/v1/Manuals/CLI-Reference/
EnglishMohican
Aspiring Pro
Posts: 306
Thanks: 48
Fixes: 1
Registered: 08-04-2009

Re: How to Delay re-Synchronisation on a TG582N

Confusions abound!!!
At 11:07 today, I lost the ppp connection but as far as I can tell, the modem did not lose synch with the exchange. So probably nothing to do with this thread but just in case......
I was using the web at 11:07 when suddenly it stopped loading pages. Checking Routerstats showed a sudden increase in noise (reduction in noise margin) but initially only a small increase (1db?). Checking the web interface on the router contradicted that and showed the internet was still connected at a good synch speed but admitted to a loss of ppp. Who do I believe - don't know - if it happens again I might try to investigate more intelligently.
Tried reconnecting on the ppp web page section but it refused - cannot bring link up seemed to be the reason. Tried several times - no success. Restarted the router and after a while all was well again.
As I say, it could be a genuine loss of ppp somewhere up the line, or it could be a burst of noise had knocked the connection out but in that case why did the web page say it was all OK.
I am going to assume that the freeze-showtime command has been lost by the restart but we will see what happens later. I will resend that command once I have a few more clues as to what happened.
No system status message showing it to be a general problem at this time.
Community Veteran
Posts: 4,983
Thanks: 376
Fixes: 16
Registered: 10-06-2010

Re: How to Delay re-Synchronisation on a TG582N

As you should expect from the name of the command, the freeze-showtime command stopped the modem automatically re-syncing. It doesn't surprise me that the web interface still showed the last sync speed the ADSL was connected at.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: How to Delay re-Synchronisation on a TG582N

I agree with ejs, it look as thought the freeze-showtime command did what you would expect.
I would expect the freeze-showtime command is lost, sorry I should have added a saveall command to that suggestion. Wink
The next question is which is the best command to make it reconnect?
Will this work?
xdsl qual freeze-showtime state=disabled
or do you need?
system reboot
Superuser
Superuser
Posts: 10,477
Thanks: 1,931
Fixes: 19
Registered: 22-08-2007

Re: How to Delay re-Synchronisation on a TG582N

Quote from: npr
I agree with ejs, it look as thought the freeze-showtime command did what you would expect.

@npr
Said expectation depends upon what EM believes this command does.  I suggest that it takes a leap of knowledge (not expressly referenced in this thread) to understand (and I'm guessing here) that "showtime" is something to do with "synchronisation".  I've seen many references to "showtime" in router logs etc., but I have not got a clue what it means.  In which case I guess I had better do some internet research!
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: How to Delay re-Synchronisation on a TG582N

Quote from: Townman

@npr
Said expectation depends upon what EM believes this command does.  I suggest that it takes a leap of knowledge (not expressly referenced in this thread) to understand

I think "no auto retrain", in my first post, is clear enough.
What we didn't know is whether it actually worked, some of these hidden commands don't work.
EnglishMohican
Aspiring Pro
Posts: 306
Thanks: 48
Fixes: 1
Registered: 08-04-2009

Re: How to Delay re-Synchronisation on a TG582N

Well we are still not sure whether it works. Smiley
A typical noise event has just happened but because of this afternoons event, freeze-showtime was not enabled. Note that the router's response to the sync loss was very different to this afternoons, it recorded the loss of sync in the event log and then the loss of ppp. The web interface acknowledged the loss of sync. So if this afternoons event was just another noise event, then freeze-showtime had more detrimental effects than I think it should have. However, I tend to believe that nothing is proven yet.
So as freeze-showtime was not set, the router reconnected of its own accord and as usual it did so at a poor speed and a minute later the noise disappeared and the noise margin shot up to 12.1db. So at that point I used one of npr's scripts - well I used one of his as a model into which I inserted the enable freeze-showtime command - to send that command to the router. And shortly afterwards it resynced quite nicely at a much better speed and a margin of 6.1db -  so just what the doctor ordered.
I notice that the router responds with "The freeze-showtime test is enabled". I wonder if the word "test" has any significance.
I now assume that with freeze-showtime enabled, the next noise pulse later this evening should tell us something useful. I will report back then.