cancel
Showing results for 
Search instead for 
Did you mean: 

Help with wifi printer please

thomasnelson
Newbie
Posts: 2
Registered: ‎03-10-2014

Help with wifi printer please

I have had the above printer for a year or so, and it was working fine over the wireless LAN.  Having changed to plusnet (and their router) the printer doesn't appear to work. 
- Printer is Canon Pixma MG5450 printer / scanner / copier.  I am keen to preserve the wireless scanning because I use that feature a lot.  This connects via WiFi
- The laptop (Macbook Pro 2011 running OS X 10.9)
- The router is the Technicolor TG852n
The laptop just can't see the printer over the network; can't print, can't scan wirelessly at all.  All works fine via USB.  I've tried another laptop, and an iPad.  All previously worked wirelessly without any problems.The WPS seems to 'pair' nicely with the printer.  The printer knows it's connected and has an appropriate IP address.  Also, I can access the online services (printing stationery etc) through the printer's little screen.  I.e. it's connected.  I have also tried the manual setup and inputting the WPA code by hand, and I've used the Canon IJ Network Tool which copies the network settings via USB to the printer.  Each time, the printer connects to the router (and internet) but the computer can't 'see' the printer.  Plusnet themselves won't offer any help. 
I know a bit of computery stuff but I have tried everything I can think of and I'm out of ideas.  I've set a static IP address.  Interestingly although the router says all communication within the LAN zone is open, I am unable to ping anything on the network besides the router itself. 
Please help! 
6 REPLIES
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Help with wifi printer please

Hi and welcome Smiley
Sounds like the printer is on the network just fine but that you haven't reconfigured the printer driver on your PC?  Any software is probably still pointing at the old address.
Can you ping the printer from the PC?
Superuser
Superuser
Posts: 12,759
Thanks: 4,019
Fixes: 26
Registered: ‎22-08-2007

Re: Help with wifi printer please

Hi Thomas,
Welcome to the forums.
If you look here - http://192.168.1.254/cgi/b/lan/?be=0&l0=4&l1=-1 - does it list your printer?
There are two angles to this problem...
1. Is the printer actually attached to the network?  One assumes that you have reconfigured the printer's wifi settings to connect to the new SSID?
2. The printer is more than likely to have a new IP address and therefore you might need to change the PC's configuration for the network connected printer interface configuration

Also I have seen some printers fail to follow wifi Auto channel switching - do you know if your old router used auto channel switching?  I fixed my issue by using manual wifi channel selection in the router.
Kevin
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Help with wifi printer please

Point 1 - Read the question Smiley
Point 2 - There's an echo Smiley
Community Veteran
Posts: 5,177
Thanks: 482
Fixes: 20
Registered: ‎10-06-2010

Re: Help with wifi printer please

Try setting the 582n to WPA2 only. Even if it doesn't solve the problem, that's the best setting anyway.
Community Veteran
Posts: 1,294
Thanks: 30
Fixes: 4
Registered: ‎22-06-2012

Re: Help with wifi printer please

It's a common fault with Canon wireless printers. (I speak from bitter experience!)
I've found that the only way to permanently maintain my Canon Pixma MG 7150's connection is to use an ethernet cable between the printer & the router. if you can't do this then uninstall all of your printer's software, drivers etc. & then reinstall them & set up a new connection. This is the advice given to me, MANY TIMES, by Canon customer support. It always worked, for a few weeks.  Sad
thomasnelson
Newbie
Posts: 2
Registered: ‎03-10-2014

Re: Help with wifi printer please

Thanks for the suggestions everyone.  Sorry for the delay in getting back to you - I just haven't had the time/energy to want to sit down and sort this out.  But I've done it!
Quote
Try setting the 582n to WPA2 only. Even if it doesn't solve the problem, that's the best setting anyway.

I think that was the answer.  I did also reinstall the software, so it's possible that made the difference although I strongly suspect it was a router setting, and changing the security settings seems to have done the trick.
It also *should* make the router run a bit faster, since WPA2 is a faster protocol and isn't limited to 54kbps.  Winner.
Thanks all.