cancel
Showing results for 
Search instead for 
Did you mean: 

Help adding 2nd router to extend signal from TG582n

RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Help adding 2nd router to extend signal from TG582n

Hi There
I have just got setup with TG582n router located upstairs and connected to telephone.
However, due to thick stone walls, the signal will not reach downstairs.
Please can anyone suggest how I might be able to get the signal downstairs.
I do have available:
Netgear Powerline WGX102
Linksys D Link ADSL router
Could I make use of this kit, which might give WAN and LAN I think.
If anyone has any advice as to the correct ip configuration and router defaults I would greatly appreciate.
Thanks
12 REPLIES
taras
Grafter
Posts: 226
Registered: 22-08-2008

Re: Help adding 2nd router to extend signal from TG582n

simplest way is to turn off the dhcp server in the Linksys D Link ADSL router and give the linksys the same ssid and password (but different channels) as the tg582n. oh and use either a long cat5e cable or go via a homeplug to homeplug bridge to connect the two boxes Smiley
RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Re: Help adding 2nd router to extend signal from TG582n

Can you help with the correct IP configuration to set this up
and what mode setting for the 2nd router is required.
Can anyone guide me on this.
Thanks
bill888
Seasoned Pro
Posts: 866
Thanks: 122
Fixes: 24
Registered: 18-10-2008

Re: Help adding 2nd router to extend signal from TG582n

What is the model number of your Linksys router?
Were you previously successfully using the Linksys router with the Netgear wifi extender to provide wifi coverage around the house?
Community Veteran
Posts: 1,841
Thanks: 102
Fixes: 6
Registered: 21-01-2013

Re: Help adding 2nd router to extend signal from TG582n

The wgx102 is a wireless range extender and should do what you require.
see http://www.downloads.netgear.com/files/WGX102_RM_21Mar2007.pdf
RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Re: Help adding 2nd router to extend signal from TG582n

Hi ZZZ
Yes I previously had no problem, however I can not remember how it was confgured.
The Linkys router is a :
GSL-604T
Hope you can help
bill888
Seasoned Pro
Posts: 866
Thanks: 122
Fixes: 24
Registered: 18-10-2008

Re: Help adding 2nd router to extend signal from TG582n

Do you mean DSL-G604T?  This is the model number for a Dlink ADSL router.

Re-edited:
The WGX102 appears to be a powerline (homeplug) with wireless kit comprising of 2 items according to the link to the user manual provided by npr.
Was one part (XE102) of the kit wired to your former Dlink router, and the other 'wifi' part (WGX102) perhaps located on the ground floor ?
Did you previously have 2 separate wifi networks?  One for the Dlink and the other for the Netgear ?
RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Re: Help adding 2nd router to extend signal from TG582n

Hi Again ZZZ
Yes you are correct to first two questions.
I think I only hade 1 wifi network and gave all the parts the same channel and SSID, but not too sure.
Sorry to be vague
bill888
Seasoned Pro
Posts: 866
Thanks: 122
Fixes: 24
Registered: 18-10-2008

Re: Help adding 2nd router to extend signal from TG582n

Did you previously use the DSL-G604T with Plusnet ?
I presume your previous wifi network had a security key (wifi password) set.
I've had a quick look at the user instructions for the DSL-G604T and the WGX102.
The default IP address for the G604T is 192.168.1.1
The default IP address for the WGX102 is 192.168.0.101
(A google search suggests the G604T's DHCP server issues IP addresses from 192.168.1.2 through to 192.168.1.254.)
'If' you had followed the original WGX102 instructions (page 3-9), I would make an educated guess you may have just changed the WGX102 IP address to 192.168.1.101.

As a 'simple test', can I suggest you connect the XE102 to the TG582N.  Make sure both the XE102 and WGX102 are switched on.  
Then using a web browser, go to      http://192.168.1.101/     and see if you are prompted to log into the Netgear WGX102.    The default username is 'admin' and the default password is 'password'.
You can also wonder downstairs and see if you can connect to your old wifi network name, and can surf the internet.
If neither works, unplug the XE102 and WGX102.

Edit: Default IP address of WGX102 ends in .101 not .102.  Above text corrected.
RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Re: Help adding 2nd router to extend signal from TG582n

Hi ZZZ
Thanks for your help - This is driving me nuts.
I am going to start from scratch.
The TG582n has a default ip 192.168.1.254
with a range 192.168.1.64 - 252
I can access the setups for the G604T i& the WGX102 - what I need to know is what ips to give them/what mode these need to be in.
What channel to use for each
What SSID is needed for each.
I think this is where I am struggling
Also what wifi settings I need on each connected laptop (ie ip address(fixed or auto) the correct subnet mask and default gateway to use.
Really appreciate your time.
bill888
Seasoned Pro
Posts: 866
Thanks: 122
Fixes: 24
Registered: 18-10-2008

Re: Help adding 2nd router to extend signal from TG582n

You can set the WGX102 to any address between 192.168.1.1 and 2.168.1.63.  Or just leave it on 192.168.1.101 for the time being as it is not important as it is only used for managing the WGX102.  It just needs to be in default 'Access Point' mode.
Did you try connecting the XE102 to the TG582N and confirm you can connect to internet via the old wifi network name?
It should work if your laptops are not using static IP settings.

Regarding the wireless settings, this is where we may have a possible issue.
The TG582N supports wireless N and both WPA-PSK and WPA2-PSK with TKIP or AES key encryption.
The WGX102 only supports wireless G, and with WPA-PSK with probably TKIP key encryption. (No AES)
So try this:
Log into the TG582N and make the SSID the same for both the TG582N and WGX102.  ie. perhaps use your old wifi network name on the TG582N.
For wifi channel number, only use 1, 6 or 11 on both boxes.  The TG582N and WGX102 must use different channels numbers.
I'm not currently using a TG582N but you need to set the wifi security so it only uses WPA-PSK (ie without WPA2-PSK) on both TG582N and WGX102.
Make sure the security key (wifi password) are the same for both TG582N and WGX102.

Update:  I just fired up my fibre TG582N (firmware 8.C.M.0).  It does Not seem to allow WPA-PSK on its own.

Regarding your laptops, just leave them set to 'auto' for the moment.
If you choose to set static IPs on your laptops, then use
IP address between 192.168.1.1 to 192.168.1.63
subnet mask 255.255.255.0
dns 192.168.1.254
gateway 192.168.1.254

If using the same SSID on TG582N and WGX102 does not work, then you will have to use different SSIDs and set up the laptops to be able to connect to both SSIDs.  
RCN
Dabbler
Posts: 10
Registered: 08-10-2013

Re: Help adding 2nd router to extend signal from TG582n

Hi Again ZZZ
I'm getting there but I think the security compatibility is the issue.
I still can't get the signal downstairs.
I have set up as prescribed but am not sure of the correct settings for each laptop.
Options are open/shared/WPA/WPA-PSK. which is the correct option to use?
As an alternative, we have a spare Linkys WRT150n Router at work I could use.
Would this be of use and perhaps take out the WGX102 ?
Any comments.
Again, I really do appreciate your time and effort.
bill888
Seasoned Pro
Posts: 866
Thanks: 122
Fixes: 24
Registered: 18-10-2008

Re: Help adding 2nd router to extend signal from TG582n

Quote from: RCN

I still can't get the signal downstairs.


Silly question, but where is the WGX102 plugged into a power socket?   I presume it is on the ground floor.
The only other reason I can think of why you may not be able to see the wifi from the WGX102 using a wireless device on ground floor is if you have set disabled 'SSID Broadcast' making it 'invisible'.  (page 5-3 of manual)

Normally when you click on the newly discovered wifi network name if using Windows, it will prompt you to enter the security key(wifi password) and determine the correct WPA settings to use.  Otherwise, use WPA-PSK (TKIP encryption) like the example in this link if you are using Windows XP and having to set it up manually as a last resort.
http://i.technet.microsoft.com/dynimg/IC87207.gif
Otherwise, delete the wifi network perhaps stored on the computer if you are using Windows for example.  Then try connecting again to the wifi network from ground floor.
Can you also answer these questions if problem still persists:
Q. How old are the laptops and what version (XP, 7?) if you are running Windows ?
Q. Were you previously using WEP or WPA security when using DSL-G604T/WGX102 ?
Q. With the WGX102 switched off, can the laptop when upstairs connect to TG582N wifi ?
Q. With the TG582N switched off, can the laptop see the strong wifi signal from the WGX102 when placed near to it, and will it successfully connect to it with valid wifi key/password (internet won't be accessible) ?

To use the WRT150n instead of the WGX102, you would need to install a network cable between floors or buy a pair of regular powerline adapters.   However, you could try the WRT150n upstairs as an Access Point to see whether it provides a stronger wifi signal than the TG582N, then worry about moving it downstairs later.