cancel
Showing results for 
Search instead for 
Did you mean: 

Google Chromecast - IGMP and AP/Client settings

markinapub
Newbie
Posts: 2
Registered: ‎19-06-2014

Google Chromecast - IGMP and AP/Client settings

Since switching to PN Fibre, my Google Chromecast has struggled to maintain a connection with my network. The device can see the Internet, but often 'loses' connection with host devices such as my Android phone. More often than not I have to go through a protracted exercise of shutting down the router, waiting for a few minutes, and then rebooting it, at which point the phone and Chromecast will see each other across the network again. But by the time I've watched, say, a hour long programme on Netflix, which streams perfectly, the phone can't see the Chromecast again.
Google's suggestion is that I need to make sure AP/Client Isolation is disabled on the router and that I have to enable IGMP but disable the IGMP Proxy.
This is alien to me. Also, I cannot find anywhere on the router any setting that reflects any of the above. My router is a Technicolor TG582n FTTC.
Can somebody help guide me through the process of configuring my router so that I can get the Chromecast working again?
Below is the text Google sent to me and a link to the page they reference.
Thank you,
Mark.
https://support.google.com/chromecast/troubleshooter/2995236?#ts=3090411,3222292,4509863
Ensure you have the latest firmware update for your router on the manufacturer's website.
Chromecast only works with 2.4 GHz networks. For dual band routers, ensure you are connecting to the 2.4 GHz network for Chromecast and use separate names for the 2.4GHz and 5Ghz network.
If you want to use a hidden Wi-Fi network, select Other in the drop down for network selection during setup and enter your network's name and password.
If you have a router with MAC address filtering, add the MAC address of your Chromecast to the list of filtered devices. The MAC address of your Chromecast is listed at the bottom of the Chromecast setup app.
Disable Access Point/Client isolation on your router..
Disable IGMP Proxy on your router.
Disable any Virtual Private Networks (VPNs) or proxy servers, on your router and/or computer.
Disable auto channel selection on the 2.4 GHz band on your router and assign a fixed channel (1, 6, or 11). If you have an Android phone or tablet you may want to install WiFi Analyzer to assist in picking the channel with the least interference.
Enable UPnP/Multicast on your router.
Enable IGMP on your router.
2 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 13,664
Thanks: 262
Fixes: 76
Registered: ‎27-04-2007

Re: Google Chromecast - IGMP and AP/Client settings

Hi, I've flagged this post to our products team so look out for another reply either from myself or one of my colleagues later.

UPDATE:
I've spoken to our products team who advised that as your router has the latest firmware it should be compatible with multicast services like Chromecast.
We're really not sure why Google advised you to disable IGMP, it doesn't seem relevant to this, in fact we'd advise you to keep that enabled.
We're wondering if this is simply an issue with wireless connectivity, that could manifest in the symptoms you've mentioned.
I'd try changing to a fixed WiFi channel, this guide shows you how to do that: http://www.plus.net/support/broadband/wireless_broadband/wireless_signal.shtml and you may find using inSSIDer the easiest way to find a channel that isn't being used by neighboring networks (if there are any) http://www.metageek.net/products/inssider/
Hope that helps.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
Community Veteran
Posts: 5,187
Thanks: 486
Fixes: 21
Registered: ‎10-06-2010

Re: Google Chromecast - IGMP and AP/Client settings

Well I suppose it's easy to say everything about the technicolor should work perfectly.
Anyway, disabling igmp snooping is listed here: http://npr.me.uk/telnet.html#dlna
A lot of the igmp commands are listed in this technicolor configuration manual: http://www.technicolorbroadbandpartner.com/getfile.php?id=6699