cancel
Showing results for 
Search instead for 
Did you mean: 

Good connection speed but pages very slow to load at times.

custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Good connection speed but pages very slow to load at times.

For the last few weeks I have been suffering from intermittent very slow page loading.
I have a good and consistent connection speed of around 7000 kbps down and 448 kbps up and a ping rate of 20-30 ms. Speetest shows between 5000 - 6000 kbps and file downloads are fast and I have no problem with audio/video streaming or Skype but page loading often takes so long that time-out occurs.  This can happen at any time of the day or night and is really annoying. Any ideas as to what might be causing this problem?
8 REPLIES
jojopillo
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Good connection speed but pages very slow to load at times.

Hi custos,
Have a look here for some tips on troubleshooting that.
Jojo Smiley
custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Re: Good connection speed but pages very slow to load at times.

I can't find any information that deals with my particular problem, which is the intermittent slow loading of pages. As I said in my post I do not have a problem with the connection or download speed even when pages are taking ages to load.
dick:quote
jojopillo
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Good connection speed but pages very slow to load at times.

Hi custos,
Is it just particular sites? If it's intermittent it could well be a program/Antivirus/Windows update running in the background. Maybe use something like the tbb meter which will let you see in real time what's being used. So, next time you notice the slowdown you can see if there's anything causing that. Is it wired or wireless? If it's wireless it may be interference. You can use something like inSSIDer to find the best channel to use.
Hope that helps.
Jojo Smiley
custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Re: Good connection speed but pages very slow to load at times.

Hi Jojo,
It can be any site, even Plusnet! I have three systems using a common Router (a Netgear DG834G with latest firmware installed) connected by Wireless but only one computer is on when I do the test. When the pages are loading slowly the connection speed, download speed and ping are not effected and although the Plusnet speed test page can take ages to load, once it starts the test  everything looks normal.
I am using Linux on two of the machines and there is no other activity on it when the problem occurs. However I get the same problem with another PC  running Vista. I have tried changing channels by the way.
Perhaps I should try another Router although I can't see why only page loading would be effected by any problem with the wireless connection. However as I expect to be changed over to the 'up to 20Mb' service any day now perhaps it would be a good idea to take up the offer of a new Router just to rule it out? I guess I could also try a direct connection from the Router to the Ethernet port although it will require a rather long extension phone lead.
Meanwhile I will have a look at the applications you suggest.
Many thanks......
jojopillo
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Good connection speed but pages very slow to load at times.

Hi custos,
thanks for the reply. Let me know how you get on.
Jojo Smiley
custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Re: Good connection speed but pages very slow to load at times.

'inSIDERer' shows two other local networks and using the graphical display of the bandwidth of each signal I have chosen a channel that is 'in the clear'. However I am not in as good a wireless location (in the loft) as my router is so it might not be a complete picture of what the router is receiving. However it will take 24 hours or so to see if any improvement results from the channel change.
Meanwhile I think I will request a new router 'just in case' :-)
custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Re: Good connection speed but pages very slow to load at times.

At the moment all seems well after the router channel change although it might just be a coincidence of course. I still find it very odd that only page loading was slowing down and would be interested to know if anyone can explain that. Anyway, I have ordered a new router 'just in case'  :-)
custos
Aspiring Pro
Posts: 315
Thanks: 49
Fixes: 2
Registered: ‎28-06-2007

Re: Good connection speed but pages very slow to load at times.

New router now in use and working well.