cancel
Showing results for 
Search instead for 
Did you mean: 

Forwarding the FTP port

alan659882
Grafter
Posts: 68
Thanks: 4
Registered: 04-02-2011

Forwarding the FTP port

Just had FTTC installed, everything is fine apart from port(21) forwarding for FTP.
I had a search around this forum and it seems to be a common problem but I don't seem to see an obvious solution.
The TG582n won't let me assign port 21 to a new "game or application" as it says it's already allocated.
And indeed, it already is: it seems to connect to the TG582's own FTP server and I can  then login using the router's admin password, something I'm not at all happy about from a security point of view.
I can't see any way to un-assign port 21 or to disable the internal FTP server.
Any ideas?
11 REPLIES
bytemaster
Newbie
Posts: 4
Registered: 18-04-2013

Re: Forwarding the FTP port

No Idea, but I do have exactly the same problem.
PeeGee
Aspiring Pro
Posts: 1,086
Thanks: 47
Fixes: 3
Registered: 05-04-2009

Re: Forwarding the FTP port

This page may be of help.
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link TD-W9980 modem-router.
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: Forwarding the FTP port

By default there's a port forward rule assigned to the routers media server on IP 192.168.1.253. port 21
Ensure this rule has been unassigned.
May also be a good ideal to disable the ftp server in the routers "content sharing" section.
alan659882
Grafter
Posts: 68
Thanks: 4
Registered: 04-02-2011

Re: Forwarding the FTP port

I've done both of those things, doesn't seem to make any difference.
If I don't have a specific rule forwarding port 21 to a local machine, FTP is directed to the TG582n's own server.
If I do set a specific rule, the request just hangs and then times-out.
I see the following message in the event log which suggests the port forwarding should be working, but nothing ever gets through to the local machine ...
"FIREWALL rule : Protocol: TCP Src ip: 87.112.135.159 Src port: 52883 Dst ip: 192.168.1.70 Dst port: 21 Chain: forward_host_service Rule Id: 13 Action: accept"
bytemaster
Newbie
Posts: 4
Registered: 18-04-2013

Re: Forwarding the FTP port

I have tried all of the above suggestions, but the system still refuses to allow me to assign a port forward for FTP. The system errors with:
"The port configuration of the game or application conflicts with an already assigned game & application. Assigning this game or application is not possible."
BTW npr thanks for those information pages.
alan659882
Grafter
Posts: 68
Thanks: 4
Registered: 04-02-2011

Re: Forwarding the FTP port

Quote from: bytemaster
I have tried all of the above suggestions, but the system still refuses to allow me to assign a port forward for FTP. The system errors with:
"The port configuration of the game or application conflicts with an already assigned game & application. Assigning this game or application is not possible."


I did at least get past that, if you go to [Toolbox > Game & Application Sharing > Assign a game or application to a local network device], you can unassign FTP-Server from the internal server then re-assign it to one of your local machines. Not that it helped!
bytemaster
Newbie
Posts: 4
Registered: 18-04-2013

Re: Forwarding the FTP port

I had un-assigned FTP, but system still would not let me assign a new forward.
However I have now solved the problem.
Telnet into the router adn issue the following command.
service system modify name=FTP state=disabled
Then restart the router.
I can now set the forward for FTP, and have tested from external IP. HTH
Plusnet Help Team
Plusnet Help Team
Posts: 12,982
Thanks: 141
Fixes: 46
Registered: 27-04-2007

Re: Forwarding the FTP port

Glad to hear you've resolved that and thanks for bringing this to our attention in as I'm sure others might have issues when trying to do this.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
alan659882
Grafter
Posts: 68
Thanks: 4
Registered: 04-02-2011

Re: Forwarding the FTP port


D'OH! - All my fault (Well, maybe Microsoft), can't blame the TG582n.
The machine that I'm running my FTP server on had the 192.168.1.nnn subnet set as a "public" network in the Windows Network sharing centre, it's firewall was blocking incoming connections. Once I set it to "Home" everything started working.
Windows pop's-up a choice when you first connect to a new network, but if you ignore it, it must default to "Public" after a while.
Of course, all that happened while I was messing around with the new router and I never realized.
Sorry about that.
Riaz
Newbie
Posts: 1
Registered: 01-05-2013

Re: Forwarding the FTP port

Quote from: bytemaster
I had un-assigned FTP, but system still would not let me assign a new forward.
However I have now solved the problem.
Telnet into the router adn issue the following command.
service system modify name=FTP state=disabled
Then restart the router.
I can now set the forward for FTP, and have tested from external IP. HTH

Thanks was pulling my hair our with this and had done everything apart from reboot the dem router Cheesy
ianeon
Dabbler
Posts: 12
Registered: 12-12-2010

Re: Forwarding the FTP port

Hi,
Not sure if it will be any help but I had a problem with forwarding my FTP but I follow the instruction to
setup the ftp forwarding in the router and it still would not work until I noticed that the intruder log in the router
said that that port 21 was being forwarded.
I then checked my FTP server (linkstation LS-WXL723) and found that the return address was set to 192.168.1.1
as was my original router after changing it to the address o f the current Router which is 192.168.1.254 it now works fine.
So check the return address on your nas or ftp server.
Cheers Friends.