cancel
Showing results for 
Search instead for 
Did you mean: 

Fixed IP fail on Technicolor TG582n FTTC - Sleep?

Eserim
Rising Star
Posts: 379
Thanks: 17
Registered: 01-08-2007

Fixed IP fail on Technicolor TG582n FTTC - Sleep?

HI
In the interests of power saving, I'm having my PC sleep more often.  But I do want to wake it remotely using Magic Packets and Wake On LAN.
I've set the relevant rules and stuff on the router and it all worked.
The next day it failed.  On checking my desktop had been given a different IP by the router, despite me telling the router to always allocate the same one.  Of course this meant the rule failed.
I've now set the same IP against the network card in windows, so this shouldn't happen again, but I am curious as to what has gone wrong.
Eserim
3 REPLIES
Superuser
Superuser
Posts: 12,211
Thanks: 3,527
Fixes: 22
Registered: 22-08-2007

Re: Fixed IP fail on Technicolor TG582n FTTC - Sleep?

Hi,
Exactly how did you set the fixed IP address rule?  Through the GUI or CLI?
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fixed IP fail on Technicolor TG582n FTTC - Sleep?

If you used the CLI, did you remember the saveall command? If you reset the router at any point, that would lose any customised configuration.
It doesn't matter whether you've used the GUI and/or CLI, it's good idea to Save any configuration that you are happy with which you can reload after a reset.  http://192.168.1.254/backup.lp?be=0&l0=1&l1=1&tid=BACKUP_RESTORE should take you (via login) to the relevant page.
You can change the name of the saved file, you don't have to use the default.
The format of the CLI command I've used and works fine (10.2.5.2.EO firmware) is
dhcp server lease add clientid=<mac address of device> pool=LAN_private addr=192.168.1.x lifetime=0 leasetime=0 allocation=manual
where x is the specifc address in the range 64-252
Eserim
Rising Star
Posts: 379
Thanks: 17
Registered: 01-08-2007

Re: Fixed IP fail on Technicolor TG582n FTTC - Sleep?

Hi
I set the fixed IP in the router via the front end, it reports all is OK.  But I think you've hit on it.
As I had to restart the router to set the rule, following these instructions
http://npr.me.uk/wol.html
It may have lost that setting.  I can't see it mentioned anywhere in the ini file that gets saved, so that may well be it. 

Many thanks