cancel
Showing results for 
Search instead for 
Did you mean: 

Fibre - Normal Upload Speed, Unusable Download...

scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Fibre - Normal Upload Speed, Unusable Download...

Had fibre installed on the 10th May and the Plusnet router was faulty. Finally got everything working on the 15th and had very fast internet for 3 days. When I got back from holiday on the 20th the internet had slowed to a crawl (to the point of being unusable). I tried resetting everything and plugging directly into the BT modem with the same results, could barely load a webpage.
The main reason for posting is I have just tried uploading something to dropbox which managed to upload a 45MB file in around 30s, so it appears there is nothing at all wrong with my upload speeds, only download. I guess there could be many reasons for this but I was a bit surprised to see upload speeds of 16Mb and yet a browsing experience that makes 56k dial-up seem nippy. Any thoughts or guesses as to what it could be?
I have a BT engineer coming out tomorrow so hopefully the issue will be sorted  Smiley
28 REPLIES
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Log in to the Modem/Router, in the Internet box, click Disconnect to drop the PPP Internet session (this is not the sync), wait 30 seconds then click Connect. This should ensure the relevant servers are updated with the current sync speeds.
Then run the BTw Performance test (ignore the red preamble except make sure no other programs are using the Internet) and at the end of the first run, click the Further Diagnostics button, enter just your Phone number and Run the Further Diagnostics Test.
Do a Copy and Paste of the results and post here (no need to grab an image).
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

Thanks for the reply, however, when I say the download speed is bad, what I mean is I can hardly load a webpage let alone run any sort of speed test. I tried loading the BTW speed test but it times out before fully loading the page unfortunately. Upload seems to be unaffected however...
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Oh that's really bad news. Try to check your Current Line speed (Login required) and see what that says.
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

Line speed is reported to be 78 Mb, the test which was done on the line earlier also reported no faults and good sync speed. I can only assume it must be BT modem related or something to do with the line between my house and the cabinet. Still find it strange that upload speed is normal though...
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Ah, has any one asked you to try a PPPoE Dialler connection, Computer to Modem direct with an Ethernet cable - I assume you are connected by Ethernet cable at present to the Router - if not try that first?
See http://community.plus.net/library/broadband/fibre-help-how-to-set-up-a-pppoe-dialler-in-vistawindows...  or
http://community.plus.net/library/broadband/fibre-help-setting-up-a-pppoe-dialler-for-windows-xp/  for some guidance. If you are on a MAC there is something similar but I'm not familiar with it.
Before you power down the Router to do that, log into it and click Disconnect in the Internet Box to drop the PPP session.
Likewise, log out of the Dialler before disconnecting that. When/if you reconnect the Router you'll probably need to log in and click Connect.
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

I have tried connecting direct to the modem and dialling up on the laptop with exactly the same results. The modem is situated right by the master socket and I have tried a different ADSL cable so I think I am out of things to try my end.
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Yes, I think you are, sorry I couldn't find anything that has helped, let's hope it's a trivial job of a faulty Modem which will only take a few minutes to fix.
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

Fingers crossed  Smiley Thanks for the suggestions, much appreciated!
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

No problem, let us know how it goes. Let's hope it's not an issue at the Cab, or if it is, the engineer that comes is skilled to sort it!
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

Well, the BT engineer came and installed a new filter plate which seemed to sort the issue. However, interestingly, if I connect using the Plusnet router all is fine, but if I dial-up from my laptop connected direct to the modem, download is slow and upload is fast. The same goes for if I connect from any other router other than the Plusnet router. So it looks as though it was probably just coincidence that the engineer changed the filter and got me to test the Plusnet router at the same time (I use a TP-Link router normally).
Can anyone think of a reason why only the Plusnet router gives me full download speed? My TP-Link router worked fine for a few days and I have also connected direct to the modem from my laptop before with no speed issues but every time I try now the internet is unusable... It's baffled the hell out of me! Still, connected up using the Plusnet router and getting 72Mb down and 16Mb up, so all is fine. I can't think of any reason why only the Plusnet router is connecting correctly. Could it be MAC related?
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Is the TP-Link set to PPPoE?  It's a very odd situation I've got to say - head scratch.
scooter1556
Dabbler
Posts: 22
Registered: 10-05-2013

Re: Fibre - Normal Upload Speed, Unusable Download...

TP-Link is set to PPPoE and connects fine using my plusnet username and password, but once it is connected download speed is terrible, same when I connect with my laptop direct to the modem and do a PPPoE DSL connection. As soon as the Plusnet router is connected to the modem and connects it's all back to normal... The main reason I was using the TP-Link is because the Plusnet router seems to disconnect quite frequently from the modem which is frustrating.
The BT engineer did a line test and sync test which all came back with very good results. Only 1 CRC error over a 5 minute period which apparently is good so I don't think the line can be blamed at all.
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

Disappointing that no-one has come up with any bright ideas, Chris Parr suggested to me have a look at your MTU settings.
Community Veteran
Posts: 26,686
Thanks: 910
Fixes: 10
Registered: 10-04-2007

Re: Fibre - Normal Upload Speed, Unusable Download...

I was wondering about MTU, but while I could see that halving the throughput, I can't see it decimating it!
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)