cancel
Showing results for 
Search instead for 
Did you mean: 

Everything fast except YouTube?

AndyMcPandyface
Hooked
Posts: 5
Registered: ‎27-08-2019

Everything fast except YouTube?

Hi everyone. This is driving me crackers.

 

Basically everything is fast, except YouTube.  It will spin and spin and eventually start. Sometimes even the ads take 30+ seconds to load and then it will pause and buffer mid way through.

 

Let's skip all the nonsense, this is nothing to do with wifi channel selection etc.  Speedtest.net on the same device will give me 70+meg down and 20+meg up. I left a ping to google running all night and there was absolute zero packet loss.

 

Also interesting, if I connect to my work VPN, i can watch the videos fine at 4K or 1080p and they start instantly.  Which suggests it is a Plusnet routing/throttling problem to me.

 

So what's going on?  Are PlusNet throttling Youtube? 

11 REPLIES 11
jab1
Legend
Posts: 17,032
Thanks: 5,453
Fixes: 254
Registered: ‎24-02-2012

Re: Everything fast except YouTube?

So what's going on?  Are PlusNet throttling Youtube? 

I doubt it, otherwise there would be lots of complaints. I seem to recall one other poster with this issue, but don't know what if anything has been said or done on that topic.

Afraid this is out of my area, but maybe other Community members may have thoughts on the subject. When did it start?

John
AndyMcPandyface
Hooked
Posts: 5
Registered: ‎27-08-2019

Re: Everything fast except YouTube?

Thanks for the reply. It's been going on a few weeks I'd say.

 

I forgot to mention, I tried two different routers and two different DNS servers also just to rule those things out.

 

It's an intermittent fault though, so it's difficult to debug.

jab1
Legend
Posts: 17,032
Thanks: 5,453
Fixes: 254
Registered: ‎24-02-2012

Re: Everything fast except YouTube?

OK. As I rarely use YouTube, and am on a different ISP, with completely different routing, it is pointless me trying to replicate it, but my thoughts, if you have tried different routers/different DNS is that it could possibly be a YT issue.

John
battlemetal
Newbie
Posts: 2
Thanks: 1
Registered: ‎23-04-2023

Re: Everything fast except YouTube?

I'm having the EXACT same issues. I have 2 android devices and both are behaving exactly as you describe when using YouTube and it started happening on both at the same time. WiFi signal is super strong at around 73mb/s, yet when I switch and use 4g phone signal, it works perfectly.

I use YouTube a lot and this is driving me insane. I haven't figured out a solution yet but I joined the forum so I could follow this thread and let you know that I feel your pain
battlemetal
Newbie
Posts: 2
Thanks: 1
Registered: ‎23-04-2023

Re: Everything fast except YouTube?

Update: I'm still having issues on certain videos. This one https://youtu.be/KSwZWbqiG5M was unwatchable on YouTube on any quality, so I opened it in chrome (as a new tab, otherwise it just opens in the YouTube app) and it works perfectly, which might suggest the app, BUT it works perfectly in the app when on 4G phone signal, which would suggest the WiFi.
AndyMcPandyface
Hooked
Posts: 5
Registered: ‎27-08-2019

Re: Everything fast except YouTube?

Thanks for your replies mate, good to know I'm not alone!

 

I should have said that my issues are mostly in the android app also.  But it's not app specific, because NewPipe also chokes on the same videos. Also same as you - switching to 4G or using my VPN makes the video load instantly.

 

May I ask what DNS server you are using? The standard PlusNet one?

bobpullen
Community Gaffer
Community Gaffer
Posts: 16,887
Thanks: 4,979
Fixes: 316
Registered: ‎04-04-2007

Re: Everything fast except YouTube?

Interesting thread on the BT forums over here, which suggests it may be something to do with the caching equipment out on the network.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

AndyMcPandyface
Hooked
Posts: 5
Registered: ‎27-08-2019

Re: Everything fast except YouTube?

Thanks @bobpullen - that's very interesting. Next time if occurs I will try and capture a trace!

bobpullen
Community Gaffer
Community Gaffer
Posts: 16,887
Thanks: 4,979
Fixes: 316
Registered: ‎04-04-2007

Re: Everything fast except YouTube?

@AndyMcPandyface - I've also set up some monitoring, in case it helps should things deteriorate again.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Townman
Superuser
Superuser
Posts: 23,016
Thanks: 9,605
Fixes: 160
Registered: ‎22-08-2007

Re: Everything fast except YouTube?


@bobpullen wrote:

Interesting thread on the BT forums over here, which suggests it may be something to do with the caching equipment out on the network.


@bobpullen 

Could this also account for slow performance of ITVX and at times slow FB videos?

Sometimes ITVX takes for ever to load (have 51mbps over 5GHz), but other wise plays fine once a programme starts.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

bobpullen
Community Gaffer
Community Gaffer
Posts: 16,887
Thanks: 4,979
Fixes: 316
Registered: ‎04-04-2007

Re: Everything fast except YouTube?

@Townman - Facebook uses Akamai I think, unsure about ITVX.

Hard for me to comment on relation as I'm not close to the actual cause of the problem.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵