cancel
Showing results for 
Search instead for 
Did you mean: 

Engineer Gone - No Internet

daz1107
Grafter
Posts: 60
Registered: ‎05-08-2014

Engineer Gone - No Internet

I've just had the Openreach engineer here to set up my new fibre connection, which he quickly did.
He's now left but I have no internet connection.  The internet light was initially red, but is now green, although it does keep flashing.  The engineer said I needed to phone Plusnet to get them to "release' my connection.  Is this normal that they leave when it doesn't work?
Been on hold for 20 minutes now with no answer from customer service!
Is anybody out there??    Angry
3 REPLIES
Community Veteran
Posts: 6,824
Thanks: 1
Registered: ‎27-10-2012

Re: Engineer Gone - No Internet

Are you using your Plusnet TG582N router plugged into the Openreach modem with the correct login details (username@plusdsl.net) ?
Plusnet might need to activate your account (if this is a new account).
caravanj
Aspiring Pro
Posts: 234
Thanks: 42
Fixes: 2
Registered: ‎31-07-2014

Re: Engineer Gone - No Internet

As I understand it, BTOR make the physical connection for your broadband but Plusnet have to activate it & there can be several hours between the two.
daz1107
Grafter
Posts: 60
Registered: ‎05-08-2014

Re: Engineer Gone - No Internet

Finally got it activated after a chat with a helpful advisor. As I was a new customer the account needed to be made live.
Thanks for the replies on here and I'll be back if I need anymore help!!  Grin