Showing results for 
Search instead for 
Did you mean: 

Connected but no Internet access on multiple devices.

Posts: 2
Registered: ‎20-12-2019

Connected but no Internet access on multiple devices.

We've been with Plusnet for 2+ years now and have never had any issues apart from an intermittent problem with my laptop. It would connect to the Hub but could not access the Internet. It would say "Connected, no Internet." As this only affected my laptop and all other devices connected fine we assumed it was an issue with the laptop.

However over the last 2 months it has begun to affect more and more of our devices; laptops, phones, PlayStations, smart tvs ect. While on some of the devices it is an intermittent issues lasting a few days at a time, on others like our smart TV it has been completely unable to access the Internet for over a month despite being connected to the hub.

We've tried connecting the devices via ethernet cable but get the same error saying the ethernet cable is connected but there is no Internet access. The devices that are connected but aren't receiving Internet access also don't appear in the device list in the hub management, while the devices that are connected and recieve access do.

Weve restarted and reset the hub to factory settings and it hasn't made any difference.

I'm confused as to why multiple devices can recieve access while at the same time others can't? For example my phone, laptop and ps4 can connect right now no problem but my TV and my flatmates ps4 can connect but aren't receiving Internet.

I'd be grateful for any help, it's very frustrating!