cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring the internal interface on the Technicolor TG582n

iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Configuring the internal interface on the Technicolor TG582n

We are in the process of moving to Plusnet and have been provided a TG582n which I need to configure for our network. It's a little different to working with a Cisco IOS device!
The box comes pre-setup as 192.168.1.254, however, we use a 10.10.10.x Class C and I don't really want to have to go updating printers and NAS and virtual IP printer ports etc., so I want to update the 582 to work with our addressing scheme. So the good news first...
1. I have added 10.10.10.1 as an additional internal interface
2. I can communicate with the router on 10.10.10.1
3. I have updated the DHCP 'LAN_private' pool to issue addresses in the 10.10.10.100-254 range
4. When I connect to the router it does indeed give me 10.10.10.100 as the first lease in the pool
All excellent, but...
1. In the DHCP setup, while I can set the server to be 10.10.10.1 and this is accepted - no error - on going back the server's address has reverted to 192.168.1.254
2. On checking my IP config:
  a. My address is fine as mentioned - 10.10.10.100
  d. My default gateway is 10.10.10.1 as it should be
  c. I have picked up the PlusNet 212.159.13.49/50 DNS correctly
3. But...
  a. The DHCP server is sat as 192.168.1.254...not really an issue as the client will broadcast a BOOTP and not require a server address
  b. The router has prepended it's own address (192.168.1.254) to the DNS server list, no doubt because it's intending to act as a caching DNS proxy, but of course 192.168.1.254 won't be found on a 10.10.10.0/24 network, meaning the request will be forwarded to the default gateway (which is of course the router), but then a 192.168. address is a private non-routable address under RFC 1918 so will go nowhere. Maybe the router will intercept the port 53 traffic anyway...or will DNS resolution fail?
So I've attached some screenshots and my questions are:
1. Should I/is it safe to delete the 10.0.0.138/24 and 192.168.1.254/24 default addresses off the internal interface (10.10.10.1 is working to talk with the router)
2. What is the purpose of the 'LAN_VIRT' DHCP pool with the single address 192.168.1.253 and why can't I edit or remove this pool? What is using it and what is its purpose? Indeed, what is the purpose of a pool of just one address?
3. Why can I not update, or at least have an update stick, the 'Server' under the DHCP pool config? If I delete the default 192.168.1.254 internal interface will that make the router look for an alternative server address and use that? Why offer me the option to update this setting but then ignore my input?
4. Will the router intercept port 53 traffic and so DNS work even if the primary DNS IP is a 192.168 address or will primary DNS always fail and fall back to secondary?
My hope is to get the inside of the router sorted so I can swap out our Cisco 827 and swap in the Technicolor...
17 REPLIES
Superuser
Superuser
Posts: 6,971
Thanks: 1,001
Fixes: 61
Registered: ‎30-07-2007

Re: Configuring the internal interface on the Technicolor TG582n

Quote
What is the purpose of the 'LAN_VIRT' DHCP pool with the single address 192.168.1.253 and why can't I edit or remove this pool? What is using it and what is its purpose? Indeed, what is the purpose of a pool of just one address?
It's for the builtin media & ftp server.
TBH when I wanted to change the IP configuration from 192.168.1.x to 192.168.5.x I found that the simplest way was to save the factory configuration, edit the saved INI file to replace all the 192.168.1.x addresses and then restore from the new file.
iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Re: Configuring the internal interface on the Technicolor TG582n

Quote
I found that the simplest way was to save the factory configuration, edit the saved INI file to replace all the 192.168.1.x addresses and then restore from the new file

Ah ha, now that sounds a trick. Can I do this via the browser GUI or is this a CLI operation?
What did you do about the 10.0.0.138 interface? Leave it or remove it? Presumably you altered the default 192.168.1.254 address to you 192.168.5.x address and so in my terms deleted the default address and added the new?
Thx for the ideas  Smiley
Superuser
Superuser
Posts: 6,971
Thanks: 1,001
Fixes: 61
Registered: ‎30-07-2007

Re: Configuring the internal interface on the Technicolor TG582n

Quote
Can I do this via the browser GUI or is this a CLI operation?
You can save and restore via the GUI. go to Advanced Options->Techicolor Gateway->Configuration and you should see a 'save or restore configuration' option. You can just edit the file with any old text editor.
Quote
What did you do about the 10.0.0.138 interface? Leave it or remove it? Presumably you altered the default 192.168.1.254 address to you 192.168.5.x address and so in my terms deleted the default address and added the new?
I've just checked my saved config and I left the 10.0.0.38 alone. You're correct , I just changed all the 192.168.1.x to 192.168.5.x . It's slightly different in your case in that from what I can see you want , you need to change most of the 192.168.1.x to 10.10.10.x BUT you need to change any 192.168.1.254 to 10.10.10.1 since you want the router on .1 rather than .254
iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Re: Configuring the internal interface on the Technicolor TG582n

Many thnka MisterW...will give is a go :-)
iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Re: Configuring the internal interface on the Technicolor TG582n

Oh dear, now I have a broken router. It didn't like that at all. I can't speak to it on 10.10.10.1, 10.0.0.138 or 192.168.1.254 and pressing the reset doesn't seem to do anything for it either. Even trying to add the router MAC into the ARP table manually fails due to a permission error in dear old Windose. My router appears to be deceased, gone to meet it's maker etc...
Key pieces of the modified config...
[ ip.ini ]
ifadd intf=LocalNetwork dest=bridge
ifconfig intf=loop mtu=65535 group=local symmetric=enabled
ifconfig intf=LocalNetwork mtu=1500 group=lan linksensing=disabled primary=enabled
ifattach intf=LocalNetwork
config forwarding=enabled redirects=enabled netbroadcasts=disabled randomdatagramids=disabled ttl=64 fraglimit=64 defragmode=enabled addrcheck=dynamic mssclamping=enabled acceleration=enabled
config checkoptions=enabled
config natloopback=enabled
config arpclass=12
config arpcachetimeout=900
# ipadd intf=LocalNetwork addr=10.0.0.138/24 addroute=enabled
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
# ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
#ipconfig addr=192.168.1.254 preferred=enabled primary=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled
rtadd dst=255.255.255.255/32 gateway=127.0.0.1
[ dhcs.ini ]
debug traceconfig state=disabled
policy verifyfirst=enabled trustclient=disabled rtbehaviour=traditional ackinform=disabled
# pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 server=192.168.1.254 primdns=212.159.13.49 secdns=212.159.13.50 leasetime=864000 lockouttime=180
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.253 netmask=24 gateway=10.10.10.1 server=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 leasetime=864000 lockouttime=180
# pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=10.10.10.254 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 server=10.10.10.1 leasetime=86400 lockouttime=180
# lease add clientid=01:9e:97:26:0f:b0:91 pool=LAN_VIRT addr=192.168.1.253 lifetime=0 macaddr=9e:97:26:0f:b0:91 allocation=manual
lease add clientid=01:9e:97:26:0f:b0:91 pool=LAN_VIRT addr=10.10.10.254 lifetime=0 macaddr=9e:97:26:0f:b0:91 allocation=manual
[ dhcr.ini ]
ifconfig intf=LocalNetwork relay=enabled
add name=LocalNetwork_to_127.0.0.1
# modify name=LocalNetwork_to_127.0.0.1 addr=127.0.0.1 intf=LocalNetwork giaddr=192.168.1.254
modify name=LocalNetwork_to_127.0.0.1 addr=127.0.0.1 intf=LocalNetwork giaddr=10.10.10.1

Is there any whizz from PN who can give advice on how to resusitate a Technicolor TG582n and get it to operate assomething other than 192.168.1.254. I can see me updating the Cisco and carrying on with that and sending this thing back :-(
Community Veteran
Posts: 26,746
Thanks: 959
Fixes: 10
Registered: ‎10-04-2007

Re: Configuring the internal interface on the Technicolor TG582n

If you have a Cisco that you can use and that you are happy with, why on earth would you want to try to use the Plusnet supplied one?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Superuser
Superuser
Posts: 6,971
Thanks: 1,001
Fixes: 61
Registered: ‎30-07-2007

Re: Configuring the internal interface on the Technicolor TG582n

@iain, You should be able to resusitate it with a factory reset. Looking at your modified config, I thought there wrere more changes than that!. I'll check mine when I get home, but as I said, I'm pretty sure I left the 10.0.0.138 active on mine. As Jelv says, is there an actual problem with using the Cisco ?
Dan_the_Van
Rising Star
Posts: 340
Thanks: 10
Fixes: 1
Registered: ‎25-06-2007

Re: Configuring the internal interface on the Technicolor TG582n

Did you give up on the TG582 ?
Sure you've tried this, reset instructions.
While the unit is on, hold down a thin object such as a paper clip into the reset hole at the back next to the power button until the power light on the unit goes off. Release the reset button.
If I have read your modified config correctly you can only connect to it on 10.10.10.1
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled
10.0.0.138 and 192.168.1.x network lines are #'ed out so the will not be enabled.
If you are still trying to connect try giving your PC a fixed IP address, say 10.10.10.10 /24
Dan.

iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Re: Configuring the internal interface on the Technicolor TG582n

Okay, Q&A :-)
@jelv: Why not stick with the Cisco?
Well the Cisco has no WiFi and this would be useful for phones wanting to update themselves more than anything else. The unit is also a fews old, memory is limited and it can't run the newest IOS builds with IDS etc. Cisco did actually give me a shiny 800 series WiFi router, but it's Ethernet-Ethernet and so while I could nicely segment my network with a 'dirty' segment between the ADSL and Ethernet router and then run a clean segment and WiFi from the second router, do I really want to play network engineers that badly? So for £5 I was willing to be slobby and see if I could use the provided router. But I could indeed end up keeping the Cisco and maybe even get the second unit into play too
@MisterW: Reset instructions
Yes I did do a reset but no I don't think I held in the button long enough which is probably why it didn't seem to work.
Yes there is (a lot more) of the user.ini config, but these are the only pieces with changes and I thought rather than post the whole thing, I'd stick to what I'd altered. Would be interested to know which pieces you altered :-)
@Dandroid: 10.10.10.1 is working and use a static IP
No, sadly 10.10.10.1 *was* working prior the applying the updated config, but the new config seemed to break the router. So yes I've been having to set static IPs as there's no response to the BOOTP, but setting the laptop in any of the three networks including 10.0.0.138/10.10.10.1/192.168.1.254 all fail to get any response out of the router. It's not happy with me
So all-in-all, haven't given up yet
machare
Grafter
Posts: 141
Thanks: 2
Registered: ‎13-01-2011

Re: Configuring the internal interface on the Technicolor TG582n

I have a 582n and I use the ADSL connection (i.e.no FTTC / VDSL)
The local network address is 10.0.0.139.  It does DHCP and the pool is 10.0.0.1  to 10.0.0.24  The mask is 255.255.255.0
The firmware version is 8.4.4.I 
In the user.ini file I have:
[ ip.ini ]
ifadd intf=LocalNetwork dest=bridge
ifconfig intf=loop mtu=65535 group=local symmetric=enabled
ifconfig intf=LocalNetwork mtu=1500 group=lan linksensing=disabled primary=enabled
ifattach intf=LocalNetwork
config forwarding=enabled redirects=enabled netbroadcasts=disabled randomdatagramids=disabled ttl=64 fraglimit=64 defragmode=enabled addrcheck=dynamic mssclamping=enabled acceleration=enabled
config checkoptions=enabled
config natloopback=enabled
config arpclass=12
config arpcachetimeout=900
ipadd intf=LocalNetwork addr=10.0.0.139/24 addroute=enabled
rtadd dst=255.255.255.255/32 gateway=127.0.0.1

[ dhcs.ini ]
debug traceconfig state=disabled
policy verifyfirst=enabled trustclient=disabled rtbehaviour=traditional ackinform=disabled
pool config name=LAN_private state=enabled allocation=automatic intf=LocalNetwork poolstart=10.0.0.1 poolend=10.0.0.24 netmask=24 gateway=10.0.0.139 lockouttime=180
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 leasetime=86400 lockouttime=180
lease add clientid=01:0a:76:ff:b5:f0:fc pool=LAN_VIRT addr=192.168.1.253 lifetime=0 macaddr=0a:76:ff:b5:f0:fc allocation=manual
lease add clientid=01:f0:7b:cb:35:e0:4a pool=LAN_private addr=10.0.0.1 lifetime=0 macaddr=f0:7b:cb:35:e0:4a allocation=automatic
etc for other leases:
The LAN_VIRT stuff does not show on my GUI.

Superuser
Superuser
Posts: 6,971
Thanks: 1,001
Fixes: 61
Registered: ‎30-07-2007

Re: Configuring the internal interface on the Technicolor TG582n

@machare, I would have thought the LAN-VIRT lines should be something like
Quote
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=10.0.0.253 poolend=10.0.0.253 netmask=24 gateway=10.0.0.139 leasetime=86400 lockouttime=180
lease add clientid=01:0a:76:ff:b5:f0:fc pool=LAN_VIRT addr=10.0.0.253 lifetime=0 macaddr=0a:76:ff:b5:f0:fc allocation=manual
Taht will at least put it in the same subnet as the router and give it the correct gateway.
machare
Grafter
Posts: 141
Thanks: 2
Registered: ‎13-01-2011

Re: Configuring the internal interface on the Technicolor TG582n

I have posted what I found in my file.  I configured my 582n to use a 10.0.0.x network  using the GUI.  My GUI does not show LAN-VIRT so I was not aware of it until just before I posted the previous message.
iain
Dabbler
Posts: 19
Registered: ‎26-10-2013

Re: Configuring the internal interface on the Technicolor TG582n

I’ve been too consumed on other issues to work on this for a while and meantime PN are still making an utter mess of my ADSL migration and so I am still not migrated (hey, I only ordered the connection on 1-Oct!), but migration is threatened for this coming Fri, meaning I need to get the … router working, so starting from a complete fresh slate and hard resetting the router I…
1. Connected the router to my laptop and was assigned 192.168.1.64
2. Could see the laptop WiFi also on the connected devices
3. Could connect my Android phone to the WiFi
Then via the router GUI I:
1. Added an internal interface 10.10.10.1 okay
2. Added a dhcp_pool_1 using the pool I wanted (10.10.10.100 --> .254).
In this configuration I could ping 10.10.10.1, so the new interface was there and responding. An attempt to refresh my DHCP settings left everything unchanged on 192.168.1.64 and a restart of the router had no impact either, and so I downloaded the router and config and compared what had been created from my GUI ‘fiddling’ with the information very kindly provided by @machare (so many thanks by the way :-) ). What I then found was:
[ ip.ini ] identical except:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled

The only difference is the address as @machare was working from 10.0.0.139.

My ip.ini has two additional lines missing from @machare’s config:
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled

So these are also adding the default 192.168.1.254 interface and also (in the second line) marking it as preferred. This therefore explains why I continue to get 192.168 addresses via DHCP. So my options were:
1. Delete both of these two additional lines
2. Keep the lines, but change the ‘preferred=enabled’ line to quote my desired and new 10.10.10.1 interface
3. Delete just the first line adding the default 192.168 interface and change the second line to mark my preferred range as being preferred
Given I’d killed the router on previous ‘hacks’ of the config file, I opted for option 2 and so ended up with:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled

Obviously the adding of the default 192.168 should be redundant and not used, but is left in to keep the router ‘happy’.
Now, going on and comparing the [ dhcs.ini ] sections I have three differences (plus the actual device leases). So I have:
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.64 poolend=192.168.1.252 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=dhcp_pool_1 state=enabled allocation=automatic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 lockouttime=180

Picking these apart;
First line:
I show: allocation=dynamic
@machare shows: allocation=automatic
- maybe a difference in the .i to .j firmware levels? Probably not worth changing and dynamic/automatic might be synonymous, but there’s no documentation to this level and seems to be no expertise within PN
Second line:
Identical excepting ‘my line’ includes: server=192.168.1.254 which is probably insignificant
Third line:
This is my new pool which I added and so obviously doesn’t match an equivalent line, but comparing this with @machare’s equivalent line configuring the default LAN_private pool the two lines are identical (other than quoting different poolstart/end and gateway addresses) excepting ‘my line’ also includes:
primdns=212.159.13.49 
secdns=212.159.13.50

So I see no real issue/conflict here
So my thinking is:
1. Simply alter the ip.ini to quote my desired internal interface as preferred=enabled
2. Leave the dhcs.ini section in the hope that the router will be bright enough to use the new dhcp_pool_1 pool to match the preferred internal interface rather than use the LAN_private pool
So here goes with ‘Change set 1’…
Well, the router restarts (which is good), but:
IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0

Which is bad.
So the differences now between my config and @machare’s are:
1. I have added a second DHCP pool via the GUI and tried to point the router to use that
2. @machare’s config changes the start and endpool addresses on the default LAN_private pool
So the obvious thing is to match more closely @machare’s config and so change:
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.64 poolend=192.168.1.252 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=dhcp_pool_1 state=enabled allocation=automatic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 lockouttime=180

to read:
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
pool config name=LAN_private state=enabled allocation=automatic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 lockouttime=180

So loading ‘Change set 2’, soft restarting the box and doing an ipconfig /renew I still get…
IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0

So my ip.ini shows:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled

Lines 2 and 3 are extra to @machare’s, so let’s first remove the line adding the 192.168 interface and leave the last line marking 10.10.10.1 as preferred to give myself:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled

This therefore makes ‘Change set 3’. Load, soft restart and no change. What’s more looking at the LocalNetwork interface in the UI Is see:
IP Address/Mask             Type	
10.10.10.1/24              Static
192.168.1.254/24            Static
DHCP Pools
DHCP Pool Name      Address Range                    Gateway
LAN_private          192.168.1.64 - 192.168.1.252      192.168.1.254
LAN_VIRT            192.168.1.253 - 192.168.1.253    192.168.1.254
dhcp_pool_1          10.10.10.100 - 10.10.10.254      10.10.10.1

Which is remarkable given the default LAN_private was overwritten with the dhcp_pool_1 settings. There is another reference the added pool in the config:
[ dhcspool.ini ]
pool add name=LAN_private
pool add name=LAN_VIRT
pool add name=dhcp_pool_1

But the actual definition of the pool has now been renamed in ‘Change set 2’ to LAN_private and the original LAN_private removed, so the updated config doesn’t seem to be in place. Maybe hard restart is required, but before that, let’s redownload the running config to see what’s in there…
Well, the running config still includes in ip.ini:
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled

These are the lines removed in ‘Change set 3’ and so it seems ‘Change set 2’ is in place, but not ‘Change set 3’, so let’s reapply ‘Change set 3’, soft restart, check the running config and then hard restart and check the running config.
So after a soft restart the running config says:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled

while the config uploaded twice now reads:
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled

So a power off, wait and restart of the router, then check of the running config shows me back on:
IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0

And downloading the running config and comparing to the config uploaded it shows the same additional lines, e.g.
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled

So it’s as if the router is simply ignoring the uploaded ‘Change set 3’ change.
So the next test was to add an extra line to the config:
[ extra ]

This creates ‘Change set 4’ which was uploaded. The intent was to see whether this section header that did nothing would come back in the running config to show whether ther config was being loaded, e.g. was the router actively altering the sections of ip.ini included in Change set 3, or was the config somehow not being loaded and saved?
This tests indeed shows that ‘Change set 4’ was NOT applied to the machine. A second upload (restore) of the config with hard restart yielded the same result, and so for some reason the config is being ignored and not applied to the router.
So I then went back to ‘Change set 3’ as the router seemed to accept that and made the sole change of adding after the [ip.ini] section:
 [ change set 5 - 201311171430 ]

I then restored this config to the router, hard restarted and downloaded the running config. No-go…the added comment does not show up and so the revised config is being ignored, so try instead by altering the mock section head with a comment line:
; change set 5 – 201311171444

(making a guess here as semicolon being for a comment. Hash might be another option to try). Results: The ; comment config was not loaded and the same with # comments, so an alternative means of tracing uploaded configs was tried…altering the endpool parameter in the dhcs.ini section. So this created another change set (timed at 1500) with an endpool value of .253. Loading this and hard restarting the change file *still* was not coming back as the running config!
So I therefore took the config that had come back from the router, and so which the router presumably ‘liked’, and so made just one change…to alter the endpool address on the 10.10 pool to .253, e.g.
pool config name=dhcp_pool_1 state=enabled allocation=automatic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.253 netmask=24 gateway=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 lockouttime=180

So loading this (1510) config, hard restarting and the downloading the running config showed that again, the config was not being applied. The config that came back still had .254 in place, meaning I have a bit of a problem in that the router isn’t accepting changed configs I am loading to it. What has also now occurred is the following:
Request: 
http://192.168.1.254/
Response:
HTTP/1.1 302 Moved Temporarily
Location: http://192.168.1.254/login.lp
Request:
http://192.168.1.254/login.lp
Response:
HTTP/1.1 302 Moved Temporarily
Location: http://192.168.1.254/login.lp

Note that’s an endless loop, although I can communicate with the box on 10.10.10.1 without this ‘feature’ of the firmware!

I then experimented with the ‘Setup your router’ option under the GUI and ‘Configuration’. This took me to an ‘Easy wizard’, but that failed with a timeout to the router! This was because it attempts to connect to a host named <dsldevice.lan> which seems to be name created by the router for itself and which resolves to 192.168.1.254. However, attempts to login to the router via the URL http://dsldevice.lan/login.lp using the router’s admin credentials fails and attempts to connect to 10.10.10.1 redirect to <dsldevice.lan> where the login fails. Connecting instead via the 192.168.1.254 IP address does though work. WTF! The ‘Easy wizard’ has obviously done something though as the 10.10 interface and DHCP pool are both gone. In effect it’s done a reset.
Now attempting to restore *any* config to the router is rejected – or rather it appears to work, gives no error, but when checked hasn’t been applied. So if I go back to the config I first uploaded right at the beginning of this long ‘experiment’ and upload/restore the config that was accepted and worked earlier today, even though the restore apparently completes, on restarting and then downloading the config, it’s back to the wizard-created config. It would seem I’m going to need to go for a hard reset and go right back to the beginning… I am starting to think that if I’m going to keep this … router, it would actually be easier to reconfigure every device on the network – printers, NAS, network printing ports etc. – because it seems impossible to configure this router!
So having done a hard reset of the machine and confirmed it as being reset by downloading and checking the config, I went back to Change set 3 (141Cool are loaded that. This set only included the following pieces in the respective section (other settings omitted for clarity):
[ ip.ini ]
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipconfig addr=10.10.10.1 preferred=enabled primary=enabled
[ dhcs.ini ]
pool config name=LAN_private state=enabled allocation=automatic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 primdns=212.159.13.49 secdns=212.159.13.50 lockouttime=180

e.g. ip.ini has no reference to 192.168.1.254 and dhcs.ini redefines LAN_private with my desired range in the same was @machare’s config does.
After reloading and restarting; no change. Looking at the LocalNetwork interface in the UI Is see:
IP Address/Mask             Type	
10.0.0.138/24              Static
192.168.1.254/24            Static
DHCP Pools
DHCP Pool Name      Address Range                    Gateway
LAN_private          192.168.1.64 - 192.168.1.252      192.168.1.254
LAN_VIRT            192.168.1.253 - 192.168.1.253    192.168.1.254

In others word; the default setup. The loaded/restored configuration is simply being ignored.
So as another test, I simply replaced by ip.ini and dhcs.ini with the exact-same details as @machare’s (only omitting the DHCP leases). This might not be the ranges I want, but it a known working config from @machare’s machine. So this became the 1736 config image. The result? Absolutely nothing. The LocalNetwork interfaces look the same, the box is simply refusing any uploaded config. It doesn’t report a failure, just doesn’t alter the config.
So at this point I tried one last test. I downloaded the working config and altered:
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.64 poolend=192.168.1.252 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180

To read:
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.64 poolend=192.168.1.250 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180

e.g. the poolend address was altered from .252 to .250. This must *surely* be a config acceptable to the router and which it should load? The change is just to see; Can I get this router to load *any* config? So reload, hard restart and … The LAN_private range ends on .252, or in other words, the router simply does not accept a updated config.
I then went back to the GUI and by disabling DHCP managed to get myself to this happy place:
IP Addresses
IP Address/Mask      Type
10.10.10.1/24        Static
192.168.1.254/24    Static
DHCP Pools
DHCP Pool Name      Address Range                  Gateway
LAN_private          10.10.10.100 - 10.10.10.254    10.10.10.1
LAN_VIRT            192.168.1.253 - 192.168.1.253  192.168.1.254

So a soft restart and my laptop reports…
IPv4 Address. . . . . . . . . . . : 10.10.10.100(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 17 November 2013 17:57:05
Lease Expires . . . . . . . . . . : 01 December 2013 17:58:28
Default Gateway . . . . . . . . . : 10.10.10.1
DHCP Server . . . . . . . . . . . : 192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 234890937
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-14-DE-45-00-26-B9-EB-BD-DF
DNS Servers . . . . . . . . . . . : 192.168.1.254
                                    212.159.13.49
                                    212.159.13.50

Halleluiah! Somehow this seems to have worked, despite GUI configuration not working before. So I have a DHCP address starting at the beginning of the pool, the gateway is set correctly and I have DNS servers. It’s rather odd to see the DHCP and primary DNS as the default 192.168.1.254 address and not the 10.10.10.1 gateway address, but the client forwards that to the router which responds…I can ping 192.168.1.254 okay and so there’s an outside chance this might all work!
So my ip.ini and dhcs.ini sections now read:
[ ip.ini ]
ifadd intf=LocalNetwork dest=bridge
ifconfig intf=loop mtu=65535 group=local symmetric=enabled
ifconfig intf=LocalNetwork mtu=1500 group=lan linksensing=disabled primary=enabled
ifattach intf=LocalNetwork
config forwarding=enabled redirects=enabled netbroadcasts=disabled randomdatagramids=disabled ttl=64 fraglimit=64 defragmode=enabled addrcheck=dynamic mssclamping=enabled acceleration=enabled
config checkoptions=enabled
config natloopback=enabled
config arpclass=12
config arpcachetimeout=900
ipadd intf=LocalNetwork addr=10.10.10.1/24 addroute=enabled
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled
rtadd dst=255.255.255.255/32 gateway=127.0.0.1
[ dhcs.ini ]
debug traceconfig state=disabled
policy verifyfirst=enabled trustclient=disabled rtbehaviour=traditional ackinform=disabled
pool config name=LAN_private state=enabled allocation=dynamic intf=LocalNetwork poolstart=10.10.10.100 poolend=10.10.10.254 netmask=24 gateway=10.10.10.1 server=192.168.1.254 primdns=212.159.13.49 secdns=212.159.13.50 leasetime=1209600 lockouttime=180
pool config name=LAN_VIRT state=enabled allocation=dynamic intf=LocalNetwork poolstart=192.168.1.253 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 leasetime=86400 lockouttime=180
lease add clientid=01:9e:97:26:0f:b0:91 pool=LAN_VIRT addr=192.168.1.253 lifetime=0 macaddr=9e:97:26:0f:b0:91 allocation=manual

Anyway, I post all this information in the hope it might help some other poor unfortunate, looking to configure their router and similarly getting zero assistance from PN. Happy configuring!
Maybe I'll have some success to report once the ADSL line gets migrated. Here’s hoping!
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: ‎13-07-2012

Re: Configuring the internal interface on the Technicolor TG582n

@iain
Just on a side note, we'll be picking your complaint ticket up shortly.