cancel
Showing results for 
Search instead for 
Did you mean: 

Citrix VPN Issue

Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Citrix VPN Issue

Hi
I am trying to use CITRIX on my work laptop at home.
I have been told i need the following  VPN ports opened 443, 1723, 1494
Tried on a number of different friends broadband connections and the VPN works absolutely fine.  Try it at home on my plusnet connection and nothing seems to work.  Rang up plusnet who said change firewall setting on router to low/off  tried both and restarted router but no luck
Then i got PortQry  to check if the ports were listening/open  and they still come up as not listening/filtered.
I tried port forwarding under the router setting for game/application sharing but no luck.
Is this a router issue and how do I resolve it. dint find the plusnet chat very useful in resolving this as they dont do much with VPN stuff so they tell me and its not a normal residential service ( are you for real plusnetHuh)
router is the infamous technicolor 582 n plsunet supplied me with

Any help would be appreciated
17 REPLIES
Community Veteran
Posts: 6,419
Thanks: 531
Fixes: 48
Registered: 30-07-2007

Re: Citrix VPN Issue

You don't need to forward any ports, you do need to check that your PlusNet firewall ( not the router one ) https://portal.plus.net/my.html?action=firewall is set to LOW or OFF though.
If that's not the problem then there have been some issues with certain firmware versions of the TG582 , this thread might help http://community.plus.net/forum/index.php/topic,136706.0.html
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

Hiya
The plusnet firewall you mentioned is set to off so not sure whats going on
Community Veteran
Posts: 26,657
Thanks: 883
Fixes: 10
Registered: 10-04-2007

Re: Citrix VPN Issue

Was the Plusnet firewall already off or didi you change it? If you changed the setting did you disconnect/connect as it needs you to do this to apply the changed setting.
I've had no issues using Citrix using a TG582 router.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

The plusnet firewall has been set to off for the last week or so trying to get the VPN to work
The router has been restarted a number of times trying various things.
Currently there is no plusnet firewall, no firewall on router setting  and windows telling me i have no firewall.

Port query showing  the three required ports as not listening/filtered despite trying various things.  worked fine on my firends talktalk boradband connection without changing anything and one other connection cant remember what ISP it was though
Community Veteran
Posts: 6,419
Thanks: 531
Fixes: 48
Registered: 30-07-2007

Re: Citrix VPN Issue

What firmware version is the TG582n running ?
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

Hi
Not entirely sure will have to check at home tonight although my package started in march 2015 and i  was sent a router in the post
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

its software release 10.2.2.B
Community Veteran
Posts: 6,419
Thanks: 531
Fixes: 48
Registered: 30-07-2007

Re: Citrix VPN Issue

IIRC Citrix is an IPSec VPN so I'd try the IPSec fix described here http://npr.me.uk/vpnissue.html . If not you might try rolling back to an earlier f/w and applying the fix as suggested in the thread I linked to earlier.
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

The telnet script didn't seem to work as it only appears to be for a version 8.4... not sure how you rollback the firmware but are there any knwon issues on firmware 8.2.2.b
Community Veteran
Posts: 6,419
Thanks: 531
Fixes: 48
Registered: 30-07-2007

Re: Citrix VPN Issue

I'm surprised that the script doesn't work on later versions. Can you save the configuration file as described in my link and then post the connection.ini section.
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

Checked the firmware again its 10.2.2.b 
Tried the IKE and port unbinding via telnet which showed as not binded after restarting router which in another post someone had tried and it fixed the issue but that was for cisco vpn i think not citrix.
I am however having no luck is the router doing/blocing something?
Do i need to try a diff router and use that to see if it is a router issue and ifso what is a good cheap router to get that would work
Community Veteran
Posts: 26,657
Thanks: 883
Fixes: 10
Registered: 10-04-2007

Re: Citrix VPN Issue

I'm on FTTC using 10.2.5.2.EO firmware. I used to be on 20CN using 10.2.2.B.
In both cases I've been able to use Citrix without any modifications/tweaks to the router.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 6,419
Thanks: 531
Fixes: 48
Registered: 30-07-2007

Re: Citrix VPN Issue

Quote
I am however having no luck is the router doing/blocing something?
I don't think so, as Jelv says, it really should just work with f/w 10.2.2.b. Seeing as it's a work laptop I suspect you probably need to get your IT support people to diagnose the problem. They ought to be able to either get logs from the server end or talk you through getting logs at your end and sending them.
Rashid6567
Newbie
Posts: 8
Registered: 17-08-2015

Re: Citrix VPN Issue

Thanks Guys
Will ask IT and see what they say