cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco router DSL configuration, CISCO877W

UD
Newbie
Posts: 2
Registered: 15-06-2014

Cisco router DSL configuration, CISCO877W

Hi Guys,
after some thoughts I decide to post my CISCO877W DSL cofig here:

Cisco877-W-K9
15 June, 2014
Building configuration...
Current configuration : 5682 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec
service password-encryption
!
hostname HomeCisco877W
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
!
!
!
!
aaa session-id common
clock timezone EET 2
clock summer-time EET recurring last Sun Mar 2:00 last Sun Oct 4:00
!
dot11 syslog
!        
dot11 ssid MyWLAN
authentication open
authentication key-management wpa
wpa-psk ascii XXXXX
!
ip source-route
!
!
ip dhcp excluded-address 172.25.1.1 172.25.1.5
!
ip dhcp pool LAN
  network 172.25.1.0 255.255.255.0
  default-router 172.25.1.1
  dns-server 212.159.6.10 212.159.6.9
!
!
ip cef
ip domain name plus.net
ip name-server 212.159.6.10
ip name-server 212.159.6.9
ip inspect audit-trail
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!        
!
!
archive
log config
 logging enable
!
!
ip ssh version 2
!
bridge irb
!
!
!
interface ATM0
description DSL
no ip address
no ip unreachables
no ip proxy-arp
atm vc-per-vp 128
no atm ilmi-keepalive
pvc 0/38
 oam-pvc 0
 encapsulation aal5mux ppp dialer
 dialer pool-member 1
!
hold-queue 224 in
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers aes-ccm
!
ssid MyWLAN
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxx@plusdsl.net
ppp chap password xxx
ppp pap sent-username xxx@plusdsl.net xxx
hold-queue 224 in
!
interface BVI1
description Home LAN
ip address 172.25.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
hold-queue 200 in
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
ip nat inside source list NAT interface Dialer0 overload
!
!
ip access-list extended NAT
permit ip 172.25.1.0 0.0.0.255 any
!
no logging trap
no cdp run
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
exec-timeout 0 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
exec-timeout 15 0
logging synchronous
transport input ssh
!
scheduler max-task-time 5000
end

I have upgraded ADSL firmware on CISCO877W  to: AMR-4.0.015.bin
noise margin became from -7.1 dB to:   3.0 dB
New DSL cisco firmware:
site: http://software.cisco.com/download/release.html?mdfid=281993180&softwareid=282821763&release=0.0.026...
need cisco.com login to download it.
upgrade procedure:
http://oasysadmin.com/2011/08/17/upgrading-the-adsl-modem-firmware-on-cisco-877w-router/
Now everything works smooth !
Cheers, UD, CCIE R&S