cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 1701 on ADSL

euancampbell
Newbie
Posts: 1
Registered: ‎04-02-2008

Cisco 1701 on ADSL

Hi all I have been looking though some of the forum posts but to no avail, here is my problem. I have a Cisco 1701 router set up and it is working on the ADSL, DHCP is configured as well as NAT, everything is working nicely, but none of the PCs in the house will be able to look up the DNS server to access the likes of Google etc. The PCs will get the DHCP from the import all command, but still not working. if you type ping google.com on the router in the IOS then it will work but nothing past the router will get ay DNS query reply. If anyone has had experience working with Cisco IOS then any help would be very helpful. The sh run config is below:
Building configuration...
Current configuration : 1991 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_Aberdeen
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.15
!
ip dhcp pool DATA
  import all
  network 192.168.100.0 255.255.255.224
  default-router 192.168.100.1
!
!
!
!
username *username* privilege 15 secret 5 *password*
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no snmp trap link-status
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet0
no ip address
speed auto
!
interface FastEthernet0.10
encapsulation dot1Q 10
ip address 192.168.100.1 255.255.255.224
ip nat inside
ip virtual-reassembly
no snmp trap link-status
!
interface FastEthernet0.20
encapsulation dot1Q 20
ip address 192.168.100.33 255.255.255.240
ip nat inside
ip virtual-reassembly
no snmp trap link-status
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname *username*@plusdsl.net
ppp chap password 0 *password*
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
interface Dialer1
no ip address
!
ip route 0.0.0.0 0.0.0.0 195.166.128.101
!
!
ip http server
no ip http secure-server
ip nat inside source list NATACL interface Dialer0 overload
!
ip access-list standard NATACL
permit 192.168.100.0 0.0.0.31 log
!
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
login local
line aux 0
line vty 0 4
login local
transport input ssh
!
end

Thanks
2 REPLIES
Community Veteran
Posts: 14,469
Registered: ‎30-07-2007

Re: Cisco 1701 on ADSL

You could manually configure the DNS on each PC to use any of the following PlusNet DNS servers:
212.159.6.9 & 6.10
212.159.13.49 & 13.50
or a public DNS server from OpenDNS
208.67.220.220
208.67.222.222
notheruser
Grafter
Posts: 139
Registered: ‎08-01-2008

Re: Cisco 1701 on ADSL

or if you want to use DHCP for everything, you can assign the DNS servers using the router. As far as I am aware, this router cannot act as a dns server, it just sets up the clients to use an external one.
The command is
dns-server x.x.x.x
(after the 'default router' line)
and you can put more than one in if you want.