cancel
Showing results for 
Search instead for 
Did you mean: 

Change IP address on Technicolor 582n

seffles
Newbie
Posts: 4
Registered: 05-08-2012

Change IP address on Technicolor 582n

I'm having my ADSL2 line upgraded to FTTC next week, and I received the Technicolor 582n router in the post yesterday.  I connected to the router last night to configure it but it doesn't seem to have the ability to change the default IP address of 192.168.1.254.
This is going to be a bit of a problem for me as I frequently work from home using VPN into the office whose IP range is 192.168.1.x.  My home network used to be setup to use 192.168.1.x and it caused no end of problems, so I moved over to 192.168.0.x.  I really have to setup this new router to use this range to be able to work from home.
Is there any way to change it?  Perhaps using the telnet console?
I can understand that hardwiring the IP address makes things easy for Plusnet and simplifies tech support, but I think completely locking it down like this is inappropriate.  Sad
3 REPLIES
Superuser
Superuser
Posts: 9,131
Thanks: 535
Fixes: 46
Registered: 06-04-2007

Re: Change IP address on Technicolor 582n

The router isn't locked to any particular address and its IP and subnet can be changed using the web interface. I haven't tried this myself but I think doing it the right way is the key. The router will not let users make changes to a DHCP pool that has active leases.
Take a look at the post here for guidance but please also look at my comment in the reply that follows concerning address ranges to use. 192.168.0.x should be fine in that respect.
Though written for the TG585v7 the procedure should work on the TG582n.
David
seffles
Newbie
Posts: 4
Registered: 05-08-2012

Re: Change IP address on Technicolor 582n

Thanks very much, sprayxt.  There are differences for the 582n, but I managed to stumble my way through it and now have the router set to 192.168.0.254 and the DHCP range set to 192.168.0.x.  Smiley
The procedure wasn't entirely straightforward, so I'll try to highlight the problems I had for anyone attempting the same...

  • First of all, although I'd changed the wifi SSID, passphrase and admin password yesterday, they were all set back to Plusnet provided defaults today.  I'm guessing that's because the router was only powered up for a short while yesterday and has been unplugged since.  I'm hoping that it's a battery charge issue and that once charged it'll retain my settings.

  • I had to power cycle the router every time I changed the static IP address of my laptop, or if I set it back to 'obtain an IP address automatically'.  This wasn't surprising, but might not be obvious to others following the procedure.  The router is very slow to boot and it takes a good few minutes before you're able to see the login screen again.

  • I didn't have to remove the old DHCP pool, you can simply edit the existing one(s).  Go to "Home network > Interfaces > Local network > Configure" and there's an "Edit" button next to each pool that lets you reassign it instead of deleting it and creating a new one.

  • On my first attempt, I changed the router's IP address first, but this caused a few problems.  I changed my laptop's static IP address into the router's new range, power cycled the router and waited to log back in.  The login was successful, but I had to re-enter the username and password several times.  I also had to re-enter them every time I clicked on any link.  I tried to change the DHCP pool's IP range and it kept looping between asking for the login details and then showing me the edit page with the original details.  Eventually I set the router's back to 192.168.1.254, reset my laptop's static IP and tried again.

  • My second attempt worked.  This time, I worked from the bottom of the page upwards, editing the two listed DHCP pools first (a private one and a virtual one, if I remember rightly) and setting them to the 192.168.0.x range.  Then I set the router's IP address to 192.168.0.254, set the laptop to obtain an IP address automatically, and power cycled the router.  Everything's now working correctly in the 192.168.0.x range, except for one thing...

  • There's one IP address you don't seem to be able to change as it doesn't have an edit button, and that's the "content sharing".  I figure this is for the USB socket on the side of the router that lets you connect USB drives, etc.  This is no big deal as my NAS already does this and I have no use for it.


So, to sum up, it all seems to be working.  Thanks again, sprayxt.  Hopefully the settings will stick after I've unplugged it and there won't be any adverse side-effects.  I'm still incredibly disappointed at how difficult this basic feature has been to perform.  But as long as it's working, it'll do.  I'll just have to save some pennies and buy a 'proper' router instead of this 'toy' one.  It's a shame none of my old ADSL routers are compatible with FTTC.
Superuser
Superuser
Posts: 9,131
Thanks: 535
Fixes: 46
Registered: 06-04-2007

Re: Change IP address on Technicolor 582n

Thanks for that feedback and glad you managed to achieve the objective. Smiley
The router might appear slow to boot because it is "stand alone" until your fibre is installed (hope that goes well for you), possibly having to time out trying to connect before it lets you do anything.
I've changed the wireless SSID and interface type (but not the admin password and security key) on my TG585v8. Those remain changed through restarts. However my router has never been powered off for more than an hour.
David