cancel
Showing results for 
Search instead for 
Did you mean: 

Broadband not working & no support!

rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Broadband not working & no support!

Our broadband has been deteriorating for the past month or so. Slow and frequent drops. Now we can barely connect (drops within a minute) and whle it is connected it is soooo very slow... about 1 min and BBC news page loads text but no images, then connection will usually drop.

Its getting worse - just spent 5 mins with about a drop after 10 secs, 1 min to reconnect, then drops.

This is not acceptable! I logged a support issue 3 days ago, 72 hours later and no reply. How many weeks/months do we have to be ignored. How do we leave when plusnet won't even talk to us? Should we just cancel the DD and 'see you in court'?

Terribly poor service is barely excusable, but making it impossible to talk to you is way out of line!

Please advise what a paying customer should do?

 

14 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 3,992
Thanks: 844
Fixes: 206
Registered: 21-04-2017

Re: Broadband not working & no support!

Hi there,

 


rsd wrote:

Our broadband has been deteriorating for the past month or so. Slow and frequent drops. Now we can barely connect (drops within a minute) and whle it is connected it is soooo very slow... about 1 min and BBC news page loads text but no images, then connection will usually drop.

My tests aren't detecting any issues. The connection from the exchange to the router is stable:

Are you using a wireless or wired connection?

 


rsd wrote:
This is not acceptable! I logged a support issue 3 days ago, 72 hours later and no reply. How many weeks/months do we have to be ignored.

You've logged a complaint online. That's not a fault ticket.

We aim to pick up online complaints within 5 working days.

 

Anoush

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Superuser
Superuser
Posts: 9,974
Thanks: 1,504
Fixes: 20
Registered: 22-08-2007

Re: Broadband not working & no support!

This rather looks as though it is a connection between device and the router issue. How is that device (TV / PC / Tablet?) connected to the router?

What other devices are connected? What concurrent use is being made of the internet connection?
rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

I logged a complaint because I couldn't find out how to log a fault ticket. Where is it? I looked for a while, and checked again now, but no luck!

There is a chat option. When I tgried to connect, it took 10 mins, then told me I was 40th in line. After a 10 min wait I had moved up to 35th in line! So, I gave up, I'm not going to wait an hour and a half or more!

Same with calling, the phone system said that there was over an hour of waiting.

So, the only way to contact was via a complaint form. It did say I'd get a response within 24 hours, so after waiting 72 hours with no response, you can understand why I'm thoroughly hacked off.

So, before telling me I did it all wrong, consider that you are impossible to get hold off!

 

 

rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

And as for the picture - looks nice, but doesn't reflect our user experience - poor (v. slow) connection, frequently dropping.To answer the question - wireless.

We've had plusnet for well over a year (possibly two now), and none of our devices that have problems have changed recently, and they all connect just find on other wireless connections, so it does seem to be the plus net broadband.

 

 

rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

Townman,

Thanks for the reply.

It happens on all devices (TV, 2 phones, 1 tablet, 2 laptops). All of which have been working over the connection for quite a while, all are suffering identical deterioration symptoms.

Concurrent use - not much, given that the connection is so poor, we can';t use Internet at home for about the past month. So, there's usually only one device connected at a time.

 

Superuser
Superuser
Posts: 9,974
Thanks: 1,504
Fixes: 20
Registered: 22-08-2007

Re: Broadband not working & no support!

Whatever it is, it does not appear to be a connection stability issue. That helps to eliminate potential issues. Sight of your router stats would be useful please. Links to phone and broadband fault reporters can be found below.

Note that in respect of wifi, whilst there's no change to your set up a change in a neighbourhood could impact the performance of your wifi. Ideally neighbourhood networks work best when not overlapping which is why only channels 1, 6 and 11 are recommended. Someone deciding to pick something else could foul up things for everyone. Stations coming and going can cause your wifi to channel hop it set to auto. When the wifi does channel hop, it can take a while for connected devices to track the change and reconnect.

Which router are you using? The 2704n can misbehave on wifi when it's been running for weeks on end without a restart.

Edit: channel no typo corrected.
Plusnet Help Team
Plusnet Help Team
Posts: 3,992
Thanks: 844
Fixes: 206
Registered: 21-04-2017

Re: Broadband not working & no support!


I logged a complaint because I couldn't find out how to log a fault ticket. Where is it? I looked for a while, and checked again now, but no luck!

You can raise a fault ticket at http://faults.plus.net which is found from our connection troubleshooting pages here: https://www.plus.net/help/broadband/connection-troubleshooting/

 

And as for the picture - looks nice, but doesn't reflect our user experience - poor (v. slow) connection, frequently dropping.To answer the question - wireless.

We can check you connection from the exchange to the router. It's likely the problem is caused by your wireless connectivity beyond the router.

 

We've had plusnet for well over a year (possibly two now), and none of our devices that have problems have changed recently, and they all connect just find on other wireless connections, so it does seem to be the plus net broadband.

I'd recommend to first try a wired connection. If that works fine, the next step is to run through wireless diagnostics by changing the WiFi channel in your router settings. If you're unsure how to do that, you can find a guide Here

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Anonymous
N/A

Re: Broadband not working & no support!

@Townman

It is channels 1, 6 & 11 that should be used, NOT 2, 6 & 11.

The upper end of the frequency range for channel 2 is 2428 MHz, the lower end of channel 6 is 2426 MHz, so there would still be some overlap. The top of 1 is 2423 MHz so avoiding overlap.

rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

Hi,

It's been a couple of weeks now and despite being told by various people that I don't have a problem, I still do.

It improved to normal speed/reliability after the 'line test' for a few days, then degraded to slow and unstable again. Just got back after being away for a couple of days and its completely down - no connection at all.

So, please don't reply/call me to tell me that its ok. Please fix it. And since its been a couple of weeks now, please fix it quickly, its getting really annoying not having broadband (I notice that you still see fit to charge us!), being told that its ok (when its not) and spending lots of time posting here, talking to people on the phone, running diagnostics, etc, etc!!!

 

 

 

 

Superuser
Superuser
Posts: 2,579
Thanks: 966
Fixes: 8
Registered: 10-04-2007

Re: Broadband not working & no support!

Sight of your Router stats as requested by @Townman in post #7 would help us to help you diagnose the problem. 

rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

How do I get those?

Superuser
Superuser
Posts: 9,974
Thanks: 1,504
Fixes: 20
Registered: 22-08-2007

Re: Broadband not working & no support!

Follow the advice in the speed issues topic - see the link below.
rsd
Dabbler
Posts: 17
Thanks: 1
Registered: 03-08-2015

Re: Broadband not working & no support!

 

Speed issues topic? Today its not a speed issue, the connection is just completely not there. This is off the back of a couple of months of reliability issues (i.e. service dropping on a regular basis).


Anyway, I just got off a 40 mins call with 'customer services'. Either this is incorrectly named or I caught someone on a very bad day - every thing I said was cause for him to argue and talk over me!! A very annoying conversation. It even got so ridiculous that when I referred to the PlusNet engineer that was sent round as a 'plusnet engineer' we had to argue for 10 mins that PlusNet don't have engineers 'and don't pay engineers'. In the end we agreed on a term for the person, I apologised for my error in calling them a 'PlusNet employee' when they were really employed by Openreach and the PlusNet customer service advisor (if that's the correct term - if not, please don't call me and shout at me - I apologise for my insolence and stupidity in advance!). In return I pointed out that I had taken out a contract with PlusNet to install the broadband line and modem and that I cared less about how PlusNet chose to subcontract that responsibility.


I could go on, but I just want to highlight how the 40 mins went - in the end I 'begged' for us to return to the issue I had, in that my broadband isn't working! But, he just wanted to argue every point.


I was told to pay £199, buy a now modem or sign up for a 2 year contract - none are acceptable when I'm paying £££££ a month for a service (that was supposed to include a modem, which didnt get provided!).


By the way, today's incident is resolved.... here's what happened....


- When the individual subcontracted by PlusNet (I hesitate to call him an Engineer, a PlusNet employee or anything else as I'm tired of being told off for using the wrong terminology!) came to install the line and modem, they couldn't use the modem they brought with them as it was 'broken' and I was told that my existing BT Homehub 5 was better and that I should continue to use it. The 'Engineer' (I know that is the wrong name for them, but please bear with me). then set up the homehub modem, all was good and they left


- Now I'm told that the modem is at fault, but the way I see it is that it's my modem anyway, so none of Plusnet's business and they can just provide a working modem as per the contract in the first place.


- Anyway, todays problem is that the password got changed on the modem. I couldn't have been me as I didn't know how to connect to it! I pointed out that since the 9th Aug, PlusNet have claimed that they can connect to it, so have they changed it, or have they changed the password - apparently not. So its a mystery.


I've been away for a few days, so lets just assume that some devious criminal came round to the house, hacked into the modem, changed the password and left! I'm tired of that argument, so lets move on!


- So, I figured out how to connect to the IP of the modem. The password, overreide details, etc, doesn't work and the wireless key (that all my devices use) is different to that printed on the modem, so clearly the modem config has been fiddled with fairly extensively. A factory reset in the end, and then configuring it to work with my PlusNet account and I'm back online.


- Whether a bad modem config really is the cause of all this pain or not is a mystery as I'm getting different stories from PlusNet on each contact, and today was a lesson in terrible customer service - I didn't call for an endless and pedantic argument, I just wanted my broadband to work!


For the last 10 mins of the call I requested that I be able to raise a complaint. I won't bore you with the details, but suffice to say, he assigned the complaint to himself, then told me that he wasn't going to resolve it - I could look up your Code of Practice (which I stated to him several times, that I wanted to file a complaint under the code of practice - I assume you have one somewhere), but to no avail.


So, my broadband is working, lets see if it stays stable, if not I won't call again, its not worth the stress, the argument and the time I'll never get back!


By the way, your contact details page doesn't show in Internet Explorer, your 'live chat' doesn't load (in IE or Chrome).


If you're not a PlusNet customer already - avoid them like the plague! All I want is for my broadband to work, but instead you employ people (or not, again please don't tell me I'm wrong again for using the wrong term - I don't care, so keep it to yourself!) that seem to like to argue with customers rather than just help them.


Now, since I left BT because of the terrible customer service and so I'm not going back to them, can anyone recommend a broadband provider with half-decent customer service (I'd settle for mild incompetence, I just don't want dial-an-argument)?

 

 

 

 

 

 

 

 

 

 

 

 

 

Plusnet Help Team
Plusnet Help Team
Posts: 110
Thanks: 29
Fixes: 9
Registered: 24-04-2017

Re: Broadband not working & no support!

Hi there, sorry to hear you've been having connection issues and I'm sorry the ordeal has been dealt with so poorly.
Having checked into the issue I have responded to you via a ticket on your account and email being that there are account specifics I cannot mention over the Community Forums due to data protection which can be accessed here:

https://www.plus.net/wizard/?p=view_question&id=156737410

I hope this answered your query raised and I'm sorry to hear you're thinking of leaving.

Kind regards,

Ben

 Ben Devine
 Plusnet Help Team