cancel
Showing results for 
Search instead for 
Did you mean: 

BT Home Hub 3

jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

BT Home Hub 3

Hi, Not sure if this is the right area to post but here goes, My daughter gave me a BT home hub 3 router, I've set it up using the help page posted on this site and all is well (touch wood) but when I checked in my account area I had no usage to see and this message

Sorry, there's nothing to show at the moment.

This might be because your account is new, or your usage has been reset for a new billing period.

It can take up to 4 hours for your usage to show up - please try again later.

If you have any questions about your usage, please see our View My Broadband Usage FAQ or contact our Support Team.

Does anyone know if this is a problem associated with the BT hub or is there a problem with plusnet I dont know about ?

any help would be appreciated

regards

Jono

 
3 REPLIES
RealAleMadrid
Seasoned Pro
Posts: 512
Thanks: 176
Fixes: 9
Registered: 07-07-2009

Re: BT Home Hub 3

Usage reporting has been intermittent or not working at all for some customers, it is a known problem but no idea when it may be fixed. There are a number of threads about it on the forum.

Jonpe
Seasoned Pro
Posts: 1,285
Thanks: 339
Fixes: 2
Registered: 05-09-2016

Re: BT Home Hub 3

Put "usage" or "usage meter" into the search bar at the top of the page and you'll find you are not alone.

jono
Grafter
Posts: 237
Thanks: 2
Registered: 24-01-2008

Re: BT Home Hub 3

Hi thanks, I thought I had set something up wrong.
I'll wait and see, I've never had an issue with usage before as far as I can remember.
Regards
Jono