cancel
Showing results for 
Search instead for 
Did you mean: 

Awful upload

Nyxanna
Grafter
Posts: 46
Registered: 16-05-2013

Awful upload

My estimated download speed is 48 mb/s and upload is 8 mb/s
The BT speedcheck says that I am getting around 35 mb/s which is really not bad and that my upload is 1.5 mb/s which is really awful.
I had to have the service re-provided to the same address and before that I had 25 mb/s download and 7 mb/s upload. The upload there was a lot closer to the estimate but the download was pretty far.
I know I am expected to link all those things and the diagnostic function from the BT check didn't work for some reason.
But that isn't really my question.
I had to get the service re-provided after 2 days and my "first 10 days" ran out while I had no broadband. I saw an email today that the first 14 days had gone past and that my speeds should be more stable now so basically the speeds are inaccurate now. Is it possible that because of this the upload is too low? And if yes, is there a way for plusnet to restart the 10 days since I only got it today again?
2 REPLIES
Community Veteran
Posts: 1,613
Thanks: 22
Registered: 29-06-2010

Re: Awful upload

If you are getting less than 2Mb upstream, you have probably been provided on the 40/2 product (40 down, 2 up) in error. Someone from the DCT should pick up on this in the morning and rectify it.
Plusnet Help Team
Plusnet Help Team
Posts: 13,401
Thanks: 243
Fixes: 68
Registered: 27-04-2007

Re: Awful upload

@Nyxanna
I can't see any obvious causes for this but at the same time it's not worth assuming the cause or a potential fix so I'd strongly suggest raising a fault about that:
http://faults.plus.net
let us know how you get on.
Adam
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team