cancel
Showing results for 
Search instead for 
Did you mean: 

Any Cisco experts around?

David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Any Cisco experts around?

I'm stumped and would pull my hair out if I hadn't already.  The problem is this.  I have an 877W and it's connected to the internet perfectly fine, I'm using it now in fact.  DNS isn't really working for LAN however.  On the Wireless side it's great, gets a connection, resolves names and works, but using Ethernet I have to put Plusnet's DNS servers in Windows to get it to work properly.  For some reason my router isn't forwarding DNS requests on the ethernet side, just the wireless side.  My config looks like so:

Building configuration...
Current configuration : 3044 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CiscoRouter
!
boot-start-marker
boot-end-marker
!
enable password ~
!
username ~ privilege 15 password 0 ~
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.4
!
ip dhcp pool sdm-pool1
  network 192.168.0.0 255.255.255.0
  domain-name CiscoRouter
  default-router 192.168.0.1
!
!
ip name-server 192.168.0.1
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no ip mroute-cache
atm vc-per-vp 128
no atm ilmi-keepalive
pvc 0/38
  oam-pvc 0
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
hold-queue 224 in
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid Cisco 877W
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 ~
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ~
ppp chap password 0 ~
ppp pap sent-username ~ password 0 ~
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp route default
hold-queue 224 in
!
interface BVI1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat pool pool1 192.168.0.0 192.168.1.0 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 102 interface Dialer0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
access-list 102 permit ip 0.0.0.0 255.255.255.0 any
dialer-list 1 protocol ip permit
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
privilege level 15
login local
transport preferred all
transport input ssh
transport output all
!
scheduler max-task-time 5000
end

Anyone see anything glaringly obvious?
10 REPLIES
Community Veteran
Posts: 1,101
Registered: 10-09-2010

Re: Any Cisco experts around?

Given the number of problems like this I can find on Google http://www.google.com/search?client=ubuntu&channel=fs&q=877W+cisco+80710102&ie=utf-8&oe=utf-8#hl=en&... it seems a common problem.  I expect one of the search results will give you the solution you need.
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: Any Cisco experts around?

I've looked at pretty much all of them.  I don't have a problem with DNS itself, DNS works perfectly.... on the router, I can traceroute www.google.com (well, not anymore, I've done something and broke DNS but I digress) but it's not umm, forwarding properly or something unless I configure my PC manually, I'm missing some kind of "forward dns" setting.
/edit - ok, if I set Windows up to use 192.168.0.1 as my DNS server.... it works, this is quite insane  Crazy
Community Veteran
Posts: 1,101
Registered: 10-09-2010

Re: Any Cisco experts around?

Doesn't that imply that the DHCP inst giving DNS settings outs?
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: Any Cisco experts around?

Dunno, my mobile is able to surf the net over wi-fi (3g turned off) so it is sending out the required information over wi-fi, although I had to set my laptop up with dns 8.8.8.8 to get it to work properly on that now, so I'm puzzled, it's working but it's not working.  I didn't have this problem on my 857W so yeah, I'm lost in a world of IOSness.
win2003
Grafter
Posts: 27
Registered: 05-08-2007

Re: Any Cisco experts around?

As fourfourdevon has said... don't you have to enter the dns-server  addresses in the dhcp pool section of your config?
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: Any Cisco experts around?

Nope, in Dialer0 there is:
ppp ipcp dns request
Which requests the DNS servers from PlusNet, you can configure them manually if you want and have PlusNet, OpenDNS and Google all at once (not sure why).  Anyhow, something went wrong with the router and it deleted the flash memory (yay) so I had to start again from scratch, this time it works!  I'm now trying to get IPV6 up and running with a dynamic IP using he.net, so far so good, I've managed to set the 877W up to give out IPV6 addresses, I just can't seem to figure out how to open the router to allow ICMP requests so the router can automatically update my ipv4 endpoint address to give me ipv6...  I'm guessing I need to add an "allow" before that "deny" but Java being Java, SDM doesn't exactly work very well on Windows 7 and all the kerfaffle has dropped my IP profile down to 2mb.... it's slow to download the stuff I'm trying to download  Crazy
Oh well, patience is a virtue.
MrC
Grafter
Posts: 523
Thanks: 2
Registered: 17-07-2008

Re: Any Cisco experts around?

Quote from: David
Nope, in Dialer0 there is:
ppp ipcp dns request
Which requests the DNS servers from PlusNet,

Yes but as fourfourdevon and soft360lap1 have said, don't you need a DNS entry in the DHCP section to tell the clients which DNS server to use (whether the 877 itself or an external one)? You should be able to check which DNS servers the clients are using and see whether the wireless client(s) are picking up the 877 or are using a different one.
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: Any Cisco experts around?

I believe (and I could be wrong, it's very complex) that:the overload statements cover it all.  My current (working) config is sending the DNS servers to my PC (it shows up in network settings) but I can't ping from the router now.
win2003
Grafter
Posts: 27
Registered: 05-08-2007

Re: Any Cisco experts around?

Perhaps you need to add the "ip dns server" command.
http://blog.ioshints.info/2007/11/configure-dns-servers-through-ipcp.html
David_W
Rising Star
Posts: 2,297
Thanks: 30
Registered: 19-07-2007

Re: Any Cisco experts around?

My current (working) config looks like:
!
version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service sequence-numbers
!
hostname CiscoRouter
!
boot-start-marker
boot-end-marker
!
logging buffered 10240 debugging
logging console critical
!
username ~privilege 15 password 7 ~
no aaa new-model
ip subnet-zero
no ip source-route
ip cef
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.99
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool dhcppool
  import all
  network 192.168.0.0 255.255.255.0
  default-router 192.168.0.1
  update arp
!
!
ip tcp selective-ack
ip tcp timestamp
no ip bootp server
no ip domain lookup
ip domain name local
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall cuseeme
ip inspect name firewall h323
ip inspect name firewall rcmd
ip inspect name firewall realaudio
ip inspect name firewall streamworks
ip inspect name firewall vdolive
ip inspect name firewall sqlnet
ip inspect name firewall tftp
ip inspect name firewall ftp
ip inspect name firewall icmp
ip inspect name firewall sip
ip inspect name firewall esmtp max-data 52428800
ip inspect name firewall fragment maximum 256 timeout 1
ip inspect name firewall netshow
ip inspect name firewall rtsp
ip inspect name firewall skinny
ip ips po max-events 100
ip ips name intrusion
ip ddns update method he-ipv6
HTTP
 add https://ipv4.tunnelbroker.net/ipv4_end.phpipv4b=<a>&pass=~&user_id=~&tunnel_id=~
interval maximum 15 0 0 0
!
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool poolv6
prefix-delegation 2001:470:1F09:611::/64 0005000400F1A4D07003
prefix-delegation pool prefix-pool lifetime 1800 60
dns-server 2001:503:BA3E::2:30
!
no ftp-server write-enable
!
crypto pki trustpoint he-ipv6
enrollment terminal pem
revocation-check none
!
!
file verify auto
!
!
!
bridge irb
!
!
interface Tunnel0
description Hurricane Electric IPv6 Tunnel Broker
ip ddns update he-ipv6
no ip address
ipv6 address 2001:470:1F09:611::/64
ipv6 enable
tunnel source Dialer0
tunnel destination 216.66.80.26
tunnel mode ipv6ip
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no ip mroute-cache
atm vc-per-vp 128
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 0/38
 oam-pvc 0
 encapsulation aal5mux ppp dialer
 dialer pool-member 1
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid Cisco 877W
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 ~
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
station-role root
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
ipv6 address 2001:470:1F08:611::2/64
ipv6 enable
ipv6 nd prefix 2001:470:1F08:611::/64
ipv6 nd prefix 2001:470:1F09:611::/64 infinite infinite
ipv6 dhcp server poolv6
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dialer0
ip ddns update he-ipv6
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
ip nat outside
ip inspect firewall out
ip ips intrusion in
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ~
ppp chap password 7 ~
ppp pap sent-username ~ password 7 ~
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp route default
!
interface BVI1
ip address 192.168.0.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
ip classless
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 remark The local LAN.
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 remark Where management can be done from.
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 101 remark Traffic allowed to enter the router from the Internet
access-list 101 remark CCP_ACL Category=17
access-list 101 deny   ip 0.0.0.0 0.255.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 169.254.0.0 0.0.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.0.2.0 0.0.0.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 198.18.0.0 0.1.255.255 any
access-list 101 deny   ip 224.0.0.0 0.15.255.255 any
access-list 101 deny   ip any host 255.255.255.255
access-list 101 permit tcp any any eq 1723
access-list 101 permit gre any any
access-list 101 permit icmp any any echo
access-list 101 deny   ip any any log
access-list 101 permit icmp any any
access-list 102 remark Traffic allowed to enter the router from the Ethernet
access-list 102 remark CCP_ACL Category=17
access-list 102 remark HE Pingable
access-list 102 permit icmp host 66.220.2.74 any log
access-list 102 permit ip any host 192.168.0.1
access-list 102 deny   ip any host 192.168.0.255
access-list 102 deny   udp any any eq tftp log
access-list 102 deny   ip any 0.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 10.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 127.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 169.254.0.0 0.0.255.255 log
access-list 102 deny   ip any 172.16.0.0 0.15.255.255 log
access-list 102 deny   ip any 192.0.2.0 0.0.0.255 log
access-list 102 deny   ip any 192.168.0.0 0.0.255.255 log
access-list 102 deny   ip any 198.18.0.0 0.1.255.255 log
access-list 102 deny   udp any any eq 135 log
access-list 102 deny   tcp any any eq 135 log
access-list 102 deny   udp any any eq netbios-ns log
access-list 102 deny   udp any any eq netbios-dgm log
access-list 102 deny   tcp any any eq 445 log
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 102 permit ip any host 255.255.255.255
access-list 102 deny   ip any any log
dialer-list 1 protocol ip permit
ipv6 route ::/0 Tunnel0
!
!
control-plane
!
bridge 1 route ip
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
access-class 2 in
privilege level 15
login local
transport preferred all
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
end

It seems to work, I'm connected, my laptop is connected and I can surf the net (slowly), well I did change the auto-update to IP address rather than domain name as the router won't translate it now.  Still trying to get the IPV6 tunnel to work correctly.