cancel
Showing results for 
Search instead for 
Did you mean: 

582n - remote access problem

sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

582n - remote access problem

Hello all, first post since getting PlusNet FTTC
I have the standard supplied Technicolor 582n modem/router and want to get remote access working.
I want to do this so I can block/enable devices used by my children at various times of the day. All this works fine when inside the LAN.
However despite enabling both HTTP and HTTPS access (using the well known commands on this forum and elsewhere) when connecting from the internet despite me getting a login screen, when entering my password it appears to accept it but immediately returns me to the login screen.
I'm assuming that because I can see the login screen comms over HTTPS and / or HTTP are fine, but something behind the scenes is logging me off or at least refusing the connection.
Has anyone any ideas ?
Please don't suggest using Logmein or similar - I want to be able to log directly onto the router.
Also, in the GUI I get a page not found when I click on remote assistance.
FW is 10.2.5.2.EO
Failing that, can anyone recommend a better router ? Ideally I'd like to be able to define firewall rules where I can block a range of addresses easily - this seems to be blocked in the Technicolor router.
12 REPLIES
sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

Re: 582n - remote access problem

Anyone ?
Is anyone able to access their 582n router remotely ?
If so, what did they do to enable it ?
What FW version are you on ?
Any pointers gratefully received.
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: 582n - remote access problem

Remote access works with firmware version 8.4.4.J (ADSL) and 8.C.M.0 (Fibre).
Never tried with R10 firmware.
Firmware downloads:
http://products.plus-payh.co.uk/firmware/
RA Method:
http://npr.me.uk/remote.html
sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

Re: 582n - remote access problem

Thanks
I have already followed your excellent guide without success so I'm thinking perhaps it just doesn't work in 10.x firmware.
Do you think there will be any issues in downgrading firmware ? I really dont want to lose all my setings as I've setup reservations for every MAC address etc
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: 582n - remote access problem

Using the following command in my R10 FW router:
user list name=admin channel=http origin=wan
Gives:
User 'admin' is disallowed to login from wan to http
So with R10 firmware it look as though the user "admin" doesn't have sufficient privileges to login from wan Sad
The couple of methods I know to increase the user privilege no longer works with this firmware.
The User "tech" does have sufficient privilege but the password is not known.
Blame Plusnet for messing with the admin privilege.  Tongue
Moving to R8 firmware may not be a good idea as yet, you will lose custom settings.
Also the R8 FW doesn't have TOD access control in the GUI -- I assume you're using that. Still works via telnet.
I'll have a play with this later, I'm sure there must be a way around PN's privilege settings.
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: 582n - remote access problem

We've contacted our router supplier to check to see if there is a different Telnet command to enable remote access on the newer firmware. I'll let you know when we get a response.
Chris Pettitt
Cloud Environments Engineer
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: 582n - remote access problem

Can you try the following command, it appear to increase the "Administrator" privilege to allow login from wan.
mlp role addpriv name=Administrator access=anyaccess service=anyservice
saveall
My R10 TG582n is not connected to the net so I can't fully test this.
Please let me know how you get on with this.
sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

Re: 582n - remote access problem

Thanks npr - will try later when I get home
Appreciate the help :-)
mattturner
Grafter
Posts: 246
Thanks: 2
Registered: 25-06-2009

Re: 582n - remote access problem

Hi,
Yes, we use this command to add the nescesary privileges. I've always used it though and didn't know that the older versions of the firmware didn't need it.
:mlp role addpriv name Administrator access anyaccess service anyservice

Matt
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: 582n - remote access problem

Hi Matt,
The older R8 version with the role of "Administrator" may have needed the privileges increasing.
The instructions on my web site require changing the role to "root" which has higher privileges.
Unfortunately the R10 firmware doesn't allow changing the role from Administrator to root or SuperUser.
sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

Re: 582n - remote access problem

Quote from: npr
Can you try the following command, it appear to increase the "Administrator" privilege to allow login from wan.
mlp role addpriv name=Administrator access=anyaccess service=anyservice
saveall
My R10 TG582n is not connected to the net so I can't fully test this.
Please let me know how you get on with this.

Hi npr
Looks like this works.
I've tried it on my phone via 3G with Wifi turned off and it works.
I'll double check at work tomorrow and confirm it works.
Thanks so much for your help - I'm glad I found this forum :-) (and to Matt too)
Hopefully this will help someone else too - I can't imagine I'm the only person wanting to do this.
Community Veteran
Posts: 1,840
Thanks: 101
Fixes: 6
Registered: 21-01-2013

Re: 582n - remote access problem

Glad you've got it working and thanks for the feed back.
I've updated the website to help those with a router / firmware using a "admin" username.
sasquartch
Newbie
Posts: 6
Registered: 07-04-2014

Re: 582n - remote access problem

TO CONFIRM: Just tried at work - and it works fine.
npr - thanks so much for your help - will certainly be taking a closer look at your site as it looks a goldmine of information.
Thanks again, Paul