cancel
Showing results for 
Search instead for 
Did you mean: 

Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

rascalscastles
Newbie
Posts: 9
Registered: 30-03-2011

Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

I have a plusnet provided Thomson 585v8 router with a
Siemens S685IP phone connected to  VOIPFONE (www.voipfone.co.uk) and SIPGATE (www.sipgate.co.uk)
I keep loosing wireless connection on the laptop and I have to keep resetting the power on the S685IP and the router to allow incomming calls via VOIP, incomming and outgoing landline calls are fine.

I have always had problems with this, since i moved to plusnet from virgin media (cable)
all i keep reading about is how rubbish these thomson routers are.
does anyone else have a similar problem?

Thanks
Nathan
http://www.RascalsCastles.co.uk
4 REPLIES
Community Veteran
Posts: 6,249
Thanks: 430
Fixes: 39
Registered: 30-07-2007

Re: Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

Quote
keep loosing wireless connection on the laptop and I have to keep resetting the power on the S685IP and the router to allow incomming calls via VOIP, incomming and outgoing landline calls are fine.

I suspect this isn't just a voip problem. I suspect your broadband connection is dropping, or the router is rebooting and hence you're getting reconnected. This may give a different IP and therefore the voip connection needs reregistering before you can get incoming calls.
What do the lights on the router show when this happens ?
rascalscastles
Newbie
Posts: 9
Registered: 30-03-2011

Re: Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

I think i may have found a fix!
Start --> Run --> type 'cmd' into this box --> Press Enter
At the prompt, type 'telnet' followed by the ip address of the plusnet router (default is 192.168.1.254).
Login using admin with serial number of router as password
:connection unbind application=SIP port=5060
:service host add name=VoIP mode=server
:service host rule add name=VoIP protocol=udp baseport=5060 portrange=5060-5061
:service host rule add name=VoIP protocol=udp baseport=16384 portrange=16384-16482
:service host assign name=VoIP host=192.168.1.2 log=disabled
:nat tmpladd intf=Internet type=nat outside_addr=0.0.0.1 inside_addr=192.168.1.2 protocol=udp
:saveall
:system reboot
then make sure your VOIP device is on ip 192.168.1.2 (or change IP above!)
I used it on a tomson TG585 v8 with firmware version 8.2.7.8
I have a S685IP attached and it looks to be working atm
Nathan
http://www.RascalsCastles.co.uk
rascalscastles
Newbie
Posts: 9
Registered: 30-03-2011

Re: Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

Vista and windows 7 does not have telnet installed by default, here's how to install it:
1. Click Start then select Control Panel.
2. Select Programs and Features.
3. Select Turn Windows features on or off.
4. Select the Telnet Client option.
5. Click OK.
Nathan
http://www.RascalsCastles.co.uk
Community Veteran
Posts: 6,249
Thanks: 430
Fixes: 39
Registered: 30-07-2007

Re: Thomson 585v8 with Siemens S685IP with Voipfone and SIPGate

I suspect this
Quote
:connection unbind application=SIP port=5060
is the significant bit.
That disables the onboard SIP ALG. This tries to assist the SIP protocol to route packets across the NAT firewall. Some routers implementations are pretty bad however and are best disabled. As long as you have the outbound proxy (nat.plus.net:5082) configured on the S685 you may well find you can dispense with rest of the port forwarding commands.