cancel
Showing results for 
Search instead for 
Did you mean: 

Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

I am tearing out what little hair I have left. I have configured my A580IP and can make outgoing VOIP calls. I can receive incoming landline calls but any call to my VOIP number says that it is unavailable. I have set up an application in the T585 called sipgate and routed both the original and recommended alternative ports to the A580IP (the firewall is currently off).
I have been through the Gigaset configuration with the siemens help desk and nothing they tried helps.
I have tried talking tom plusnet techsupport but they just say that they dont support port forwarding.
Sipgate shows the device as online and it shows the calls have been received but not connected.
Does anyone have any ideas
Thanks in advance.
19 REPLIES
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

What's your PlusNet firewall set to ? https://portal.plus.net/my.html?action=firewall , needs to be Low or Off.
jojopillo
Grafter
Posts: 9,786
Registered: 16-06-2010

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

HI colinallinson,
Seems like the same issue was solved here, the only difference being your username is admin and the password is the serial number of your router beginning with CP (this is case sensitive).
Jojo Smiley
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

Hi MisterW
Firewall is off
Hi Joanne
I was using port 5060 by default and I am now using port 49060 (as recommended by Siemens.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

I believe Jojo may be  right. The TG585 SIP alg is probably still going to get in the way as port 5060 will still be used on the outgoing register even though you have changed the local port to 49060.
Try disabling it as per her link.
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

MisterW
Ihave read through that thread and I cannot understand what needs to be disabled / changed.
On my A580IP
Under the advanced settings for the specific sipgate VOIP connection I have (for Listen VOIP) SIP 49060 & RTP 49004-49020
Under general advanced settings I have the Proxy server on 5060 and Register Server on 5060 (is this what you are suggesting changing?).
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

No , you're not changing anything on your A580,  you're changing settings on the TG585.
Basically, some routers implement what's called a SIP ALG ( Application Layer Gateway ) and its meant to assist with routing of SIP traffic throught the router and avoiding having to do port forwarding. Unfortunately most routers implementations are 'broken' in some way and they cause more trouble than they are worth and so are best disabled. That is what JoJo was suggesting, but you can't disable it from the normal web interface on the router you have to use Telnet to login to the router using the details as below. If you are running Windows on your PC then you need to do it from a CMD window.
Quote
Telnet
Type  o 192.168.1.254
Connected to speedtouch
Escape character is ‘^]’.
Username : Administrator
Password : ********
———-…
… welcome message trimmed
Type menu
look for connection>unbind> application
application=choose sip (press enter key to bring choices up)
port= enter 5060 press enter then choose OK

Re-boot router

Hope that helps
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

MisterW
OK - Now I understand & I have done that but I am afraid it did not make a difference.  I did reboot (Power off/on) the router and wait for it to fully establish.  Is there ac way that I can check if it took the setting? Maybe I should revert my A580IP back to 5060 now that I have done this?
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

OK - I am there - a million thanks for your patience.
Putting the port usage back to 5060 after doing the unbind was the magic incantation.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

Glad we got it sorted. Smiley
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

Sorry - spoke too soon - it has stopped working again without any changes. It seems somewhat intermittent.
I have run out of time to work on this so I have diverted all calls (at Sipgate) to my home phone on no answer.
It is interesting that when I dial the SIP number, I dont get a dial tone but it takes the normal time waiting for an answer before diverting - so Sipgate thinks it is ringing. That is also what it tells me on it's call log (no error message).
Anyway - Outgoing calls are fine and incoming calls get diverted - not ideal but I can live with that.
Just updating in case anyone reads this and thinks that the solution worked for me.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

Your Broadband connection hasn't dropped and reconnected since it was working has it ?
If it has and you have a Dynamic IP then you may well have been allocated a new IP and so Sipgate will be sending the incoming call  to the wrong IP until your A580 reregisters, every hour ( by default ) usually.
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

No - I am pretty sure it is not the broadband dropping completely because - before I rebooted it - it had been up for over 3 days (according to the router).
I have a new symptom that I have just noticed. When I make an outgoing VOIP call then I dont hear any ringing. However it must be because I eventually get to the answerphone the other side. I hadnt noticed this before because I was ringing the mobile in the same room!!
It looks as if it is something to do with the ring signalling in both directions. Maybe something to do with the codec's - I have left them as they were.?
This all seems very strange.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

Quote
It looks as if it is something to do with the ring signalling in both directions. Maybe something to do with the codec's - I have left them as they were.?

I have a Sipgate account but I don't use it very often so it's not normally active on my C475IP.
If it helps , my codec settings on that account are:-
G.711a
G.711u
G.726
G.729
Not sure where I got those settings from but they are certainly different to my PlusNet voip account.
colinallinson
Dabbler
Posts: 17
Registered: 23-06-2011

Re: Thompson 585 V8 + Gigaset A580IP + Sipgate - Outgoing VOIP only

MisterW
I have checked my CODEC's and they are the same as yours so that idea bites the dust.
I have finallly heard back from SIPGATE and they say that I should try port 5160 (not sure if they mean just for this connection or also for outgoing). They also say that they have had bad experiences from other Thompson 585 users and I might never get this going - but they will not suggest alternative routers that may be more successful.
Is there any way I can check which ports are bound to SIP ALG (maybe there are others that I need to unbind or maybe my unbind did not work correctly?).