cancel
Showing results for 
Search instead for 
Did you mean: 

[Solved] CSip Simple Android - Wifi Problems

andun84
Grafter
Posts: 224
Registered: 01-08-2007

[Solved] CSip Simple Android - Wifi Problems

About 30 mins ago I set up my broadband phone on my Nexus 4 using CSip Simple and was able to register on the Gradwell network and make a call to another landline. When I went back to try it again about 30 mins later the option to phone from plusnet had disappeared and I could only choose to ring through the mobile network. When I went into the settings it is showing now as Inactive.
When I log into my voip.plus.net account I see this in the status for the number:
Quote
nat.mcr1, expired at 2013-02-10 17:27:53, logged into v-sip-1
NAT: 700xxxx on v-nat-proxy-1 from xx.xx.xx.xxx (xx-xx-xxx-xxx.plus.com), internal IP 192.168.1.xx, until 2013-02-10 17:41:56
NAT: 700xxxx on v-nat-proxy-1 from xx.xx.xxx.xxx (xx-xx-xxx-xxx.plus.com), internal IP 192.168.1.xx, until 2013-02-10 17:12:33

Any ideas what's up?
11 REPLIES
Moderator
Moderator
Posts: 17,213
Thanks: 888
Fixes: 101
Registered: 11-01-2008

Re: CSip Simple on Nexus 4 showing "Inactive"

were you on wi-fi before and that's deactivated you can't use it through 3g etc.?
I haven't had that problem before on a HTC Desire HD or my Nexus 4.
Will Moderate For Thanks
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple on Nexus 4 showing "Inactive"

I was wifi for both attempts however. I've just taken it off wifi and shows the same on the mobile network data connection.
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple on Nexus 4 showing "Inactive"

Ok a reboot of the phone brought it back online again however one thing I notice in that the account overview it had a status showing:
Quote
online until 2013-02-10 21:28:04

At 21:28 the broadband phone went offline again this time the message on the phone says:
Quote
"Error while registering - Request Timeout"

and the account overview not surprisingly says:
Quote
offline since 2013-02-10 21:28:04

Is it normal to have those online until x time with such short durations or could that be part of my problem.
Moderator
Moderator
Posts: 17,213
Thanks: 888
Fixes: 101
Registered: 11-01-2008

Re: CSip Simple on Nexus 4 showing "Inactive"

i usually get time out over 3g not wi-fi
Will Moderate For Thanks
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple on Nexus 4 showing "Inactive"

OK. Some time over night it reconnected to the network and it has been up since then, including both wifi and 3g.
Looks a little flaky but hopefully that's it stabilised now.
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple on Nexus 4 showing "Inactive"

Looks like this is wifi issue. No problems all day at work on the mobile network however get in this evening and I'm showing as offline since I got home a couple of hours ago. Just coming up "Error while registering - Request Timeout".
Do I need to do anything at the router end of things? I haven't opened any ports or anything but then again it is connecting some times so it must be able to find a route out sometimes. Any ideas anyone?
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple on Nexus 4 showing "Inactive"

Looking more like a router issue as I jumped immediately on to IP phone (as it comes up my mobile) when I left home and out of range of my router.
I tried opening up port 5060 however that made no difference. Anybody any other suggestions?
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple Android - Wifi Problems

Still getting this problem. I chose advanced setup in CSipSimple. This is what I have entered.
Account Name: Plusnet
Caller ID: My VOIP Landline Number
Server: sip2.plus.net:5060
Username: my user id which goes along the lines of 700xxxx
Sip Authentication ID: Left Blank
Password: My password (reset to make sure there was no issue here so definitely right)
Use TCP (not UDP) - Left Unticked - Get another error when ticked
Proxy: nat.plus.net:5082
As I say this works on 3g without issue (well apart from the fact that 02's pathetic data allowance has be slowed down so unusable at the min).
Can somebody who is using this confirm my settings. Thanks
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: CSip Simple Android - Wifi Problems

OK found the problem. X-Lite was blocking the port so removed it. I'd forgotten I had even installed this a long time ago so uninstalled and now no problems.
Moderator
Moderator
Posts: 17,213
Thanks: 888
Fixes: 101
Registered: 11-01-2008

Re: CSip Simple Android - Wifi Problems

glad you got it sorted Smiley
Will Moderate For Thanks
andun84
Grafter
Posts: 224
Registered: 01-08-2007

Re: [Solved] CSip Simple Android - Wifi Problems

Yeah glad to get it sorted it was doing my head in  Grin