cancel
Showing results for 
Search instead for 
Did you mean: 

NAT proxy DNS changes - 27/01/2010

Community Gaffer
Community Gaffer
Posts: 12,801
Thanks: 635
Fixes: 62
Registered: 04-04-2007

NAT proxy DNS changes - 27/01/2010

Afternoon folks,
Heads up that I'm about to post the following to our Service Status feed. Can people keep their eyes peeled for any issues that arise following this work and report back if they notice anything untoward?
The current server address is 194.165.60.134 and we'll be changing this to 79.135.125.160 as part of this work. Once the maintenance is complete:
nat.plus.net will point to 79.135.125.160
legacy-nat.plus.net will point to 194.165.60.134
Any questions or concerns then please shout up!
[quote author="Service Status"]Planned Broadband Phone (VoIP) DNS Maintenance - Wednesday 27th January 3.00pm-3.30pm
When's this work happening?
This afternoon, 27th January.
What does it affect?
Our Broadband Phone VoIP service.
How long will it take?
About ten minutes excluding the time taken for DNS to propagate.
What does the work involve?
Gradwell, our VoIP supplier, have recently advised us that they're wanting to migrate their partner accounts across to a new virtual NAT proxy system. This system has been successfully used, without issue, by Gradwell customers for over a year. We're going to be making a DNS change so that the proxy address nat.plus.net points to a new IP address.
Am I likely to notice the work?
If you use our VoIP service then you might do. Following the DNS change you may experience SIP registration or call quality issues. If you do experience any problems during the next 24-48 hours or so then we suggest you try restarting your VoIP hardware/software to force re-authentication with the servers.
Is there anything else I need to know?
If you do encounter problems then you can revert to using the IP address of the old server by changing the proxy address you're using to legacy-nat.plus.net.
A copy of this announcement has also been posted to our Community Site forums where we welcome any feedback - http://community.plus.net/forum/index.php/topic,83011.html
Kind Regards,
Bob Pullen
Customer Support

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

48 REPLIES
Moderator
Moderator
Posts: 17,196
Thanks: 885
Fixes: 101
Registered: 11-01-2008

Re: NAT proxy DNS changes - 27/01/2010

Thanks for the warning Bob Smiley
Will Moderate For Thanks
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: NAT proxy DNS changes - 27/01/2010

Bob,
Thanks for the heads up.
Not very long notice, but at least it was before it happened... (just!).
Hopefully there'll be no problems or teething troubles introduced... since the VOIP platform has been very stable for me for a long time now!
Mike
Community Veteran
Posts: 1,139
Thanks: 4
Registered: 20-07-2007

Re: NAT proxy DNS changes - 27/01/2010

No problems here at the moment.
Bob
Community Veteran
Posts: 6,531
Thanks: 186
Fixes: 12
Registered: 16-02-2009

Re: NAT proxy DNS changes - 27/01/2010

Will have to test my E65 tomorrow and see if it still works with the new settings (after the carfuffel I had back in Sept).
paxy
Grafter
Posts: 254
Thanks: 3
Registered: 01-08-2007

Re: NAT proxy DNS changes - 27/01/2010

Do I need to make changes on my equipment or should things just carry on working?!
Community Veteran
Posts: 1,139
Thanks: 4
Registered: 20-07-2007

Re: NAT proxy DNS changes - 27/01/2010

I've not had to change anything.
Bob
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: NAT proxy DNS changes - 27/01/2010

All looks good here.
I did a nslookup and it looks like I'm using the new IP address (in case the router DNS was caching the result).
I might bravely try a router reboot later just to double check! Wink
Mike
mdean
Grafter
Posts: 70
Registered: 13-05-2007

Re: NAT proxy DNS changes - 27/01/2010

Hi
No changes should be needed to be made on your sip device if you are using nat.plus.net as your proxy address.
Only people that use the IP address should need to make changes. to the new IP address.
puddy
Grafter
Posts: 1,571
Registered: 10-06-2007

Re: NAT proxy DNS changes - 27/01/2010

Hi Bob
I was told by Jameseh not to use nat.plus.net I thought all of use were told to use natproxy.plus.net and nat.plus.nat was dead a long time ago
I have used natproxy plus.net on my Grandstream GXP2000  GXV3005 Speedtouch 716wl Gigaset 460ip and Nokia Phones i.e E65 N95 & N900 and I have been using newsip in realm
Please advise us on this matter
Puddy
mdean
Grafter
Posts: 70
Registered: 13-05-2007

Re: NAT proxy DNS changes - 27/01/2010

HI

natproxy.plus.net and nat.plus.net both resolve to the same IP address 79.135.125.160.
tp
Dabbler
Posts: 14
Registered: 29-01-2010

Re: NAT proxy DNS changes - 27/01/2010

Greetings,
I've noticed a change, not sure if it's a problem though.
I'm ATA using is a Linksys SPA3102.  The default registration time is every 3600 seconds.
I'm no SIP expert, but I understand that normally this is overridden by the value given by the server when it replies to the "register" message. With the old server, this was about every 30 seconds and all worked well. But not with the new one. I'm not sure why, but my box is ignoring it, because it's using the default value, 3600s, so that my line spends most of it's time unregistered and unable to receive calls.  Changing the default is a workaround, as is reverting to the old server (which is what I've done, for the moment).  Sooner or later I expect the old server will be retired, so a permanent fix will be needed. I've logged what seem to be the relevant messages and the new server certainly sends the time (60s) There must be many other users of this ATA.
Ideas, anyone?
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: NAT proxy DNS changes - 27/01/2010

I must confess, as not a SIP expert either, I thought it was the other way round (unless I am mis-understanding you).
I thought the client decided the registration time, but if none was specified it'd use a default set by the server.
I have always changed the default time in my client if I wanted a shorter refresh... I think that is the correct way to do it. It has certainly always worked for me... but admittedly I don't know much about the protocol rules, so you could well be right instead!
Mike
mdean
Grafter
Posts: 70
Registered: 13-05-2007

Re: NAT proxy DNS changes - 27/01/2010

Hi tp,
not sure on this one myself. it may be worth raising a question on your account so the we can investigate this further. as far as I am aware this is the first problem of this nature.
I have not seen any problem with my setup since the DNS changes.
puddy
Grafter
Posts: 1,571
Registered: 10-06-2007

Re: NAT proxy DNS changes - 27/01/2010

Quote from: tp
Greetings,
I've noticed a change, not sure if it's a problem though.
I'm ATA using is a Linksys SPA3102.  The default registration time is every 3600 seconds.
I'm no SIP expert, but I understand that normally this is overridden by the value given by the server when it replies to the "register" message. With the old server, this was about every 30 seconds and all worked well. But not with the new one. I'm not sure why, but my box is ignoring it, because it's using the default value, 3600s Ideas, anyone?

These setting should work with your device
                                                                  UK Settings for Linksys PAP2 Device

Line Enable:  yes
sip port :5060 try 5062 for line 2
proxy :sip.plus.net                  Register: Yes
Make Call Without Reg: No       Register Expires: 3600
Ans Call Without Reg  :  No
Display Name: sip  id number    User ID: sip id number
Password: sip password           Use Auth ID: Yes
Auth ID: sip id number
Audio Configuration
Preferred Codec:G7LLu            Silence Supp Enable: no
Use Pref Codec Only:No           FAX CED Detect Enable:No
DTMF Tx Method: INFO
Line 1  Advance Settings
Proxy and Registration  
Outbound Proxy:nat.plus.net:5082 or try natproxy.plus.net:5082
save settings
United Kingdom Regional Settings
Dial tone: 350@-19,440@-22;10(*/0/1+2)
Ring back: 400@-20,450@-20;*(.4/.2/1+2,.4/2/1+2)
Busy tone: 400@-20;10(.375/.375/1)
Reorder tone: 400@-20;10(*/0/1)
SIT 1 tone: 950@-16,1400@-16,1800@-16;20(.330/0/1,.330/0/2,.330/0/3,0/1/0)
MWI dial tone: 350@-19,440@-22;10(.75/.75/1+2)
CWT1 cadence: 30(.1/2)
CWT2 cadence: 30(.25/.25,.25/.25,.25/5)
CWT frequency: 400@-10
Ring 1 cadence: 60(.4/.2,.4/2)
Ring 2 cadence (BT Call Sign): 60(1/2)
Ring 3 cadence (BT Ring Back): 60(.25/.25,.25/.25,.25/1.75)
Ring 4 cadence: 60(.4/ .8)
Ring 5 cadence: 60(2/4)
Time Zone: GMT
FXS Port Impedance: 370+620||310nF
Caller ID Method: ETSI FSK With PR(UK)
Daylight Saving Rule: start=3/-1/7/2:0:0;end=10/-1/7/2:0:0;save=1:0:
UK dial plan
this will change problems when dialing number
( *x. | **x. | 0xxx xxx xxx. | 186 xxx xxxx | [1-8]xx | [1-8]xxx | [1-9]xx xxxx | 00 xxxxx x. | 141 0 x. | 1470 0 x. )
If you get this problem
Applied al lthe settings that were listed by Puddy but couldn't receive incoming calls.
The "Use Outbound Proxy" box  has to be set to Yes
puddy