cancel
Showing results for 
Search instead for 
Did you mean: 

IS this a NAT problem?

mark1
Newbie
Posts: 2
Registered: 16-04-2011

IS this a NAT problem?

I have a LInksys spa3102 which is connected to my Belkin N1 router via the WAN port. on a staic IP address.
I have set up two voip accounts on the linksys.
sip.plus.net on gw1 (gateway 1)
sipgate.co.uk on gw4 (gateway4)
When placing an outbound call on gw1 the destination phone rings (mobilephone), but only a slight 'click' can be heard from the voip handset. On answering this call from my mobile, there is no inbound audio at all on the voip side. Outbound audio is ok.
Making the same call using gw4 returns no problems.
From my research, I understand that this could be a NAT problem, but I am unsure why this only affects the plusnet account and not the sipgate.
I have set up port forwarding and also placed the linksys ip in a DMZ which hasn't made any difference.
The one other thing I have noticed is that if I restart both the broadband and voip router and try the same call I can sometimes hear the inbound ringtone, but there is still no audio on connection.
Setting up my spa3102 has been quite a steep learning curve, and I may be overlooking something simple! I would be grateful if anyone could advise me on where they think I am going wrong.
Thanks,
Mark
4 REPLIES
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: IS this a NAT problem?

Certainly sounds like a NAT problem. Sipgate uses STUN to circumvent the NAT issues whereas PlusNet provide an outbound proxy. Having two voip accounts on the same device is quite often problematic since the STUN/Outbound proxy settings tend to be device wide rather than for each account. Have you tried each account independently ?
puddy
Grafter
Posts: 1,571
Registered: 10-06-2007

Re: IS this a NAT problem?

Hi Mark
Welcome to the Plusnet VOIP forum we are a easy bunch to talk and we can usually solve most types of problems with Plusnet voip service.
I have found that their is no need to open or forward ports with plusnet or sipgate on your router and the linksys only needs to go in to a spare port on the back of your router, but a point to note is that I have never used a Belkin router

Have a look on this setup page from Gradwell     http://www.gradwell.com/s...ort/kb/article.php?id=115
in addition have a read through this listing that was in the forum last year http://community.plus.net/forum/index.php/topic,83011.0.html
Gradwell supply Plusnet voip service so it may help changing some settings to plusnet instead of gradwell
I do know that some users are reporting that when ending a voip call it takes up to 30 seconds to end the call on your device
I myself have only used the pap2 adapter
Please let us know how you get on?

Kind regards
Puddy

Here are my settings for the Linksys PAP2 which is near enough the same device has yours
                                                                  UK Settings for Linksys PAP2 Device

Line Enable:  yes
sip port :5060 try 5062 for line 2
proxy :sip.plus.net                  Register: Yes
Make Call Without Reg: No       Register Expires: 3600
Ans Call Without Reg  :  No
Display Name: sip  id number    User ID: sip id number
Password: sip password           Use Auth ID: Yes
Auth ID: sip id number
Audio Configuration
Preferred Codec:G7LLu            Silence Supp Enable: no
Use Pref Codec Only:No           FAX CED Detect Enable:No
DTMF Tx Method: INFO
Line 1  Advance Settings
Proxy and Registration  
Outbound Proxy:nat.plus.net:5082 or try natproxy.plus.net:5082
save settings
United Kingdom Regional Settings
Dial tone: 350@-19,440@-22;10(*/0/1+2)
Ring back: 400@-20,450@-20;*(.4/.2/1+2,.4/2/1+2)
Busy tone: 400@-20;10(.375/.375/1)
Reorder tone: 400@-20;10(*/0/1)
SIT 1 tone: 950@-16,1400@-16,1800@-16;20(.330/0/1,.330/0/2,.330/0/3,0/1/0)
MWI dial tone: 350@-19,440@-22;10(.75/.75/1+2)
CWT1 cadence: 30(.1/2)
CWT2 cadence: 30(.25/.25,.25/.25,.25/5)
CWT frequency: 400@-10
Ring 1 cadence: 60(.4/.2,.4/2)
Ring 2 cadence (BT Call Sign): 60(1/2)
Ring 3 cadence (BT Ring Back): 60(.25/.25,.25/.25,.25/1.75)
Ring 4 cadence: 60(.4/ .Cool
Ring 5 cadence: 60(2/4)
Time Zone: GMT
FXS Port Impedance: 370+620||310nF
Caller ID Method: ETSI FSK With PR(UK)
Daylight Saving Rule: start=3/-1/7/2:0:0;end=10/-1/7/2:0:0;save=1:0:
UK dial plan
this will change problems when dialing number
( *x. | **x. | 0xxx xxx xxx. | 186 xxx xxxx | [1-8]xx | [1-8]xxx | [1-9]xx xxxx | 00 xxxxx x. | 141 0 x. | 1470 0 x. )
If you get this problem
Applied al lthe settings that were listed by Puddy but couldn't receive incoming calls.
The "Use Outbound Proxy" box  has to be set to Yes
mark1
Newbie
Posts: 2
Registered: 16-04-2011

Re: IS this a NAT problem?

UPDATE
Fistly, thank you to MisterW and Puddy for taking the time to respond to my problem.
Puddy I looked at both your links. The forum link, didn't throw any light and was unrelated. The gradwell link you posted was dead, but It got me to have a read on the gradewell site, where I tried various settings that they recommended but had no luck.
MisterW, I reset the spa3102 back to factory settings and reconfigured it with plusnet voip settings only. This had no change.
One thing I had noticed was that I didn't have any issues whilst placing/receiving calls using a softphone on my pc. This led me to believe that it must be a configuration error on the spa3102. If it was NAT related then I would imagine that it would affect my pc as well....
... but now I'm not so sure.
On another thread on this forum relating to the spa3102 the op stated he enabled  stun server using [stun.sipgate.co.uk]
http://community.plus.net/forum/index.php/topic,55004.0.html
I had tried this but didn't have any result. I had finally, after extensive testing, come to the conclusion that the spa3102 just wasn't compatible with the N1 router using plusnet voip and I would have to use my sipgate account which worked ok with this setup.
While retrieving my sipgate account info, I noticed they listed their stun server as [stun.sipgate.net:10000]. With nothing to loose, I tried this with my plusnet voip account and.......... Smiley Smiley Cheesy IT WORKED!!  Cheesy Smiley Smiley
I have tested both incoming and ougoing calls and can confirm that using  [stun.sipgate.net:10000] results in no loss of audio.
Please don't ask me to explain why this works. I haven't got a clue!
Maybe one of you can enlighten me!
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: IS this a NAT problem?

Good to hear you got it working. Odd that it worked from a softphone and not from the spa, could be that the sofphone was using uPnp to get the router to open the ports it needed.
As you've discovered getting voip(sip) to work where the client is behind a NAT router is often troublesome, some routers can make it worse by implementing a sip application layer gateway(alg) but doing it badly. Usually the Plusnet outbound proxy method works since effectively the connection from the sip registrar is to the proxy which is not behind your NAT.
For a bit of background info have a read of this http://kb.smartvox.co.uk/index.php/voip-sip/sip-nat-problem/ and the link to possible solutions to the problem.