cancel
Showing results for 
Search instead for 
Did you mean: 

Ekiga settings

waveform80
Newbie
Posts: 2
Registered: 18-08-2008

Ekiga settings

I used to have Ekiga working with the old PlusTalk offering (never used it much, but at least it logged in). I recently decided to give Ekiga (or rather SIP in general) another shot, to see if it's any better/cheaper than Skype (which I use currently). However, for the life of me I can't figure out the correct settings for Ekiga. This post from last year: http://community.plus.net/forum/index.php/topic,1334.0.html seemed to have some relevant information, but doesn't want to work with my settings. For reference, here's my present settings - if anyone can clue me in as to where I'm going wrong I'd be most grateful:
Protocols / Network Settings

  • Listen on IP: eth0's address

  • NAT Traversal Method: STUN

  • STUN Server: stun.ekiga.net


Protocols / SIP Settings

  • Outbound Proxy: sip.plus.net


Account Settings

  • Registrar: sip.plus.net

  • User: my 7-digit extension number

  • Password: my SIP password

  • Authentication Login: my 7-digit extension number

  • Registration Timeout: 3600


The error I'm receiving is the rather non-descript "Registration failed: Forbidden" though whether this means the user is wrong, or the password, or the registrar or something else I've no idea. I've tried several different STUN server settings, a couple of different proxy settings (e.g. adding :5060 after sip.plus.net), all to no avail. For reference, I am behind NAT, and the router doesn't talk SIP so I guess something like STUN will be necessary.
64 REPLIES
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

You dont need STUN with an Outbound Proxy. Try disabling it.
If that doesnt work then I'm sure I've had Ekiga working on my Ubuntu box at home.
You'll have to wait until I get home this evening but then I will post my settings.
Hope that helps
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

My settings:-
----------------------------------------
Protocols / Network Settings

    * Listen on IP: eth0's address
    * NAT Traversal Method: None
    * STUN Server: <blank>
Protocols / SIP Settings

    * Outbound Proxy: nat.plus.net:5082
    * Forward URL: sip:
Account Settings

    * Registrar: sip.plus.net
    * User: my 7-digit extension number
    * Password: my SIP password
    * Authentication Login: my 7-digit extension number
    * Registration Timeout: 3600
-----------------------------------------------
Basically as I see it the difference is not using STUN and nat.plus.net:5082 as the Outbound proxy.

Let me know how it goes with those changes.
Note: One other thing to try if the above doesnt work.
If you had an old Plustalk account and your sip Id starts with 4. Some of these accounts
seem to need the 4 dropping from the sip id for the new system,.


Community Veteran
Posts: 3,291
Thanks: 2
Registered: 10-08-2007

Re: Ekiga settings

Ian
Thank you for posting the Ekiga settings. I was also struggling with the set up. All working perfectly now thank you.
waveform80
Newbie
Posts: 2
Registered: 18-08-2008

Re: Ekiga settings

Quote from: ianwarrilow
Basically as I see it the difference is not using STUN and nat.plus.net:5082 as the Outbound proxy.

Let me know how it goes with those changes.
Note: One other thing to try if the above doesnt work.
If you had an old Plustalk account and your sip Id starts with 4. Some of these accounts
seem to need the 4 dropping from the sip id for the new system,.

Thanks ever so much Ian! All working now. I'd tried the nat.plus.net:5082 outbound proxy previously as part of my experiments, including with no STUN server - however, it turns out the vital component I was missing was the removal of the leading 4 on the SIP ID. Many thanks for that little gem of wisdom (I wonder how I would've found out about this otherwise; my extension is still listed as 4xxxxxx in the VOIP centre, and I don't see any mention of dropping the leading 4 in the official setup guides - although I may have missed it).
Anyway, many thanks once again,
Dave.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

@waveform80
Thanks for the reply, glad it worked.
I almost didn't mention about dropping the '4', I  thought that had been sorted and didn't apply anymore,
obviously not!!.
I'd seen this give a problem in the past on a couple of occasions and I think there was
a post from one of the PlusNet staff explaining it  Something to do with upgrading from the old six digit accounts
to seven digit ones and not quite getting the registration server details updated correctly....
Anyway at least you're sorted and looks like it helped Santiago as well.
Will177
Grafter
Posts: 39
Registered: 19-06-2009

Re: Ekiga settings

Quote from: Santiago
Ian
Thank you for posting the Ekiga settings. I was also struggling with the set up. All working perfectly now thank you.

Thanks from me too.  I now have Ekiga registered with my sip.plus.net account.  Smiley
But how do you get Ekiga to dial a UK telephone number such as 020 123 4567?   I see PC-to-Phone account settings but they say it only works if you choose to use the acouunt in the URL below, which is Diamondcard. 
https://www.diamondcard.us/exec/voip-login?act=sgn&spo=ekiga

So, will Ekiga not allow one to dial UK telephone numbers via my Plusnet VOIP account then?
Has anyone here got Ekiga to work via sip.plus.net to call UK BT landline telephones?
Thanks in advance - HOLD ON, I've JUST WORKED IT OUT! Smiley
I can answer my own question (I tried this earlier and it failed as it was appending @ekiga.net as this was my default account)
To make it work, I made sip.plus.net my default account and and then just typed this into the Ekiga box:
0044201234567
and it converted this to
sip:0044201234567@sip.plus.net
and then phone started ringing at the other end! Smiley

Note: You don't necessarily  need the 00 prefix and the country code 44 prefix
you can just type 0201234567  and this translates to sip:0201234567@sip.plus.net
Cool! Smiley
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

@Will177,
Are you using Ekiga on Linux ?
I found it a bit clunky and eventually moved to X-Lite, there is a Linux version you can download from here http://www.counterpath.com/x-lite.html&active=4
Having said that I dont use a softphone very much at all now, I've got a Siemens C475 IP phone.
Will177
Grafter
Posts: 39
Registered: 19-06-2009

Re: Ekiga settings

I didn't like XLite - too many config options Smiley
Anyway, I  have now moved to Ekiga 3.2.0 in Jaunty and now it will not register to Plusnet Sad
Ekiga just says registration is refused - request terminated  Sad
This is what Ekiga sip debug says:
...

2009/07/23 16:45:13.870   0:01.051      Opal Liste...0xb5664b90 SIP     Waiting for PDU on udp$194.165.60.134:5082<if=udp$10.187.204.111:5060>
2009/07/23 16:45:13.872   0:01.053      Opal Liste...0xb5664b90 SIP     PDU received: rem=udp$194.165.60.134:5082,local=udp$10.187.204.111:5060,if=10.187.204.111%wlan0
SIP/2.0 403 You may only access your own lines.
CSeq: 1 SUBSCRIBE^M
Via: SIP/2.0/UDP 10.187.204.111:5060;branch=z9hG4bK5266047b-0d76-de11-85df-00226892710b^M
Server: OpenSER (1.3.0-notls (i386/linux))^M
From: "Will Berriss"<sip:will@10.187.204.111>;tag=8ca5037b-0d76-de11-85df-00226892710b^M
Call-ID: f623027b-0d76-de11-85df-00226892710b@tintin^M
To: <sip:6310150@sip.plus.net>;tag=167a5d3f^M
Content-Length: 0^M
^M
2009/07/23 16:45:13.874   0:01.055      Opal Liste...0xb5664b90 SIP     Transaction 1 SUBSCRIBE completed.
2009/07/23 16:45:13.874   0:01.055      Opal Liste...0xb5664b90 SIP     Not retrying SUBSCRIBE due to error response 403 Forbidden
2009/07/23 16:45:13.874   0:01.055      Opal Liste...0xb5664b90 SIP     Changing SUBSCRIBE handler from Subscribing to Unsubscribed, target=sip:6310150@sip.plus.net, id=f623027b-0d76-de11-85df-00226892710b@tintin
2009/07/23 16:45:13.875   0:01.056      Opal Liste...0xb5664b90 SIP     Set state Terminated_Aborted for transaction 1 SUBSCRIBE
2009/07/23 16:45:13.875   0:01.056      Opal Liste...0xb5664b90 SIP     Not retrying SUBSCRIBE due to error response 487 Request Terminated
2009/07/23 16:45:13.875   0:01.056      Opal Liste...0xb5664b90 SIP     Changing SUBSCRIBE handler from Unsubscribed to Unsubscribed, target=sip:6310150@sip.plus.net, id=f623027b-0d76-de11-85df-00226892710b@tintin
...

I think LOOSE ROUTED is the key bit, i.e.:
...
From: <sip:6310150@sip.plus.net>;tag=58e6e424-8778-de11-902f-001fd08fb983
Call-ID: 80bee424-8778-de11-902f-001fd08fb983@moya
To: <sip:6310150@sip.plus.net>
Contact: <sip:6310150@81.174.232.241>;q=1, <sip:6310150@10.187.204.3>;q=0.667, <sip:6310150@10.8.0.1>;q=0.334
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING
Expires: 3600
Content-Length: 0
Max-Forwards: 70

2009/07/26 20:21:10.389   0:02.089   subscriber:0xb64c9950 OpalUDP Setting interface to 10.8.0.1%tun0
2009/07/26 20:21:10.389   0:02.089   subscriber:0xb64c9950 SIP Transaction timers set: retry=0.500, completion=6.000
2009/07/26 20:21:10.410   0:02.110 Opal Liste...0xbcc12950 OpalUDP Binding to interface: 81.174.232.241:5060
2009/07/26 20:21:10.410   0:02.110 Opal Liste...0xbcc12950 SIP Waiting for PDU on udp$79.135.125.154:5060<if=udp$81.174.232.241:5060>
2009/07/26 20:21:10.410   0:02.110 Opal Liste...0xbcc12950 SIP PDU received: rem=udp$79.135.125.154:5060,local=udp$81.174.232.241:5060,if=10.187.204.3%eth0
SIP/2.0 403 Loose routed REGISTER is not allowed
CSeq: 1 REGISTER
Via: SIP/2.0/UDP 81.174.232.241:5060;branch=z9hG4bK9c16f824-8778-de11-902f-001fd08fb983;rport=5060
Server: OpenSER (1.3.0-notls (i386/linux))
From: <sip:6310150@sip.plus.net>;tag=58e6e424-8778-de11-902f-001fd08fb983
Call-ID: 80bee424-8778-de11-902f-001fd08fb983@moya
To: <sip:6310150@sip.plus.net>;tag=b2c23028ba73f9fa8662c41a9f705abd.5af7
Content-Length: 0

...
Anyone know how to fix this? 
Anyone had success with Ekiga 3.2.0 and plusnet VOIP?
Thanks in advance
adie:quote
puddy
Grafter
Posts: 1,571
Registered: 10-06-2007

Re: Ekiga settings

in outbound proxy I thought we should be using natproxy.plus.net
instead of the old setting nat.plus.net?
I thought we should have changed over earlier this year?

puddy
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

@Will177,
I wonder if it suffers from the same issue as the Nokia Sip client ?
Gradwell recently changed the realm that's sent in the ' 407 authorisation required' response, from 'sip.plus.net' to 'newsip'. Most sip clients dont bother to check realm against their configuration and just use the one from the 407 response, the Nokia N95 client did, and it stopped registering until 'newsip'  was configured as its realm. Maybe Ekiga does a similar check , try putting newsip in the 'realm/domain' for the SIP account.
If I get chance later today, I've got a netbook running Jaunty (UNR), I will try and register my Plusnet voip account with Ekiga.
Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

@Will177,
Ok' I'm sorry to say but Ekiga 3.2.0 on Jaunty works fine for me.
It doesnt seem to show the registered status properly but I made a call to a landline and to the echotest (160).
I'll possibly try it in debug mode later and get a log file.
puddy
Grafter
Posts: 1,571
Registered: 10-06-2007

Re: Ekiga settings

Quote from: MisterW
I wonder if it suffers from the same issue as the Nokia Sip client ?
Gradwell recently changed the realm that's sent in the ' 407 authorisation required' response, from 'sip.plus.net' to 'newsip'. Most sip clients dont bother to check realm against their configuration and just use the one from the 407 response, the Nokia N95 client did, and it stopped registering until 'newsip'  was configured as its realm.

could it be a firewall issue?
if so changing nat.plus.net to natproxy could work its supposed to work if you have routing/firewall issues
or
I know we should not be using sip2.plus.net you could give it a try
puddy
Will177
Grafter
Posts: 39
Registered: 19-06-2009

Re: Ekiga settings

Quote from: MisterW
@Will177,
Ok' I'm sorry to say but Ekiga 3.2.0 on Jaunty works fine for me.
It doesnt seem to show the registered status properly but I made a call to a landline and to the echotest (160).
I'll possibly try it in debug mode later and get a log file.

Cool, glad to know it is possible get Ekiga 3.2.0 working with Plusnet VOIP on Jaunty then. Smiley
Please could you tell me everything you set and what you set it to in Ekiga (Account setting and Ekiga prefs?)  It might just help me.  (Obviously not the sensitive details, just made up examples Smiley )
Thanks puddy and MisterW for all your suggestions which I have just tried to no avail.  Sad
I have done the following:
1.  On my router I've opened ports 5000-5100 ( UDP and TCP) , 5060 (UDP only), 5082 (both UDP and TCP) and 1720 (TCP only)
2.  Rebooted my router (just in case)
3.  Ekiga General Settings -  I checked/ticked the Disable Network detection box  (so as to turn STUN off I believe)
4.  Ekiga SIP Settings: Set Outbound proxy to  nat.plus.net:5082  (I also tried natproxy.plus.net:5082  and without the :5082 too)
5.  Double-checked all my account credentials  (and tried sip2.plus.net too)

Ekiga still says  Could not register sip:6310150:sip.plus.net  Sad

Any more ideas?  Is it a firewall thing?  Do I need any more ports open on my router?  Surely not?
Do I somehow need to turn video off (there is no option for this) as Gradwell don't let us use video generally.
I'm stymied.
Thanks (again) in advance.






Community Veteran
Posts: 6,249
Thanks: 428
Fixes: 39
Registered: 30-07-2007

Re: Ekiga settings

Ok Will177 here goes, my settings
Account Settings
<you 7 digit sip id>
Name: PlusNet
Registrar: sip.plus.net:5060
User: <your 7 digit sip id>
Authentication User: <your 7 digit sip id>
Password: < your Sip password>
Timeout: 3600
Enable Account : Checked
Preferences
    Protocols
      Sip Settings
            Misc Settings
                  Outbound Proxy: natproxy.plus.net:5082
                  Forward URI: sip:

Everything else as default I think
I've tried running mine with debug viz 'ekiga -d 4 2>output.txt'  and the SUBSCRIBE request is issued after the registration which doesnt seem to be in your log.
If you get no luck with the settings above try debug again and you're welcome to PM me the debug file and I'll take a look at it and see if I can diagnose the problem. TBH it looks like a registration failure to me... double check you Sip id & password